aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-12-10 20:01:34 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-12-10 20:01:34 +0000
commit1ad1f75c70c72de7c8a4682deb5c8efade963c51 (patch)
tree64014a032c6c64defee104c2cd334b0af686a8cc /www
parentc506775ffe8669a1f37d4f27cdf30204393dd117 (diff)
downloadports-1ad1f75c70c72de7c8a4682deb5c8efade963c51.tar.gz
ports-1ad1f75c70c72de7c8a4682deb5c8efade963c51.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mod_http2-devel/Makefile9
-rw-r--r--www/mod_md-devel/Makefile4
2 files changed, 5 insertions, 8 deletions
diff --git a/www/mod_http2-devel/Makefile b/www/mod_http2-devel/Makefile
index 0483833f2346..6c3e678791ea 100644
--- a/www/mod_http2-devel/Makefile
+++ b/www/mod_http2-devel/Makefile
@@ -1,10 +1,12 @@
# Created by: Bernard Spil <brnrd@FreeBSD.org>
# $FreeBSD$
-PORTNAME= mod_http2-devel
+PORTNAME= mod_http2
PORTVERSION= 1.10.14
DISTVERSIONPREFIX= v
CATEGORIES= www
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -devel
MAINTAINER= brnrd@FreeBSD.org
COMMENT= Early experience HTTP/2 modules for Apache httpd
@@ -22,13 +24,10 @@ GH_ACCOUNT= icing
GH_PROJECT= mod_h2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=ext-
-CONFIGURE_ENV= CONFIG_SHELL=/bin/sh
MODULENAME= ${GH_PROJECT}
CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
PORTDOCS= README README.md
PLIST_FILES= ${APACHEMODDIR}/mod_h2.so \
@@ -42,8 +41,6 @@ post-install:
${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_proxy_h2.so
${RM} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_http2.so
${RM} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_proxy_http2.so
- ${MV} ${STAGEDIR}${PREFIX}/share/doc/mod_http2 \
- ${STAGEDIR}${DOCSDIR}
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_proxy_h2.so
${RM} -v ${STAGEDIR}${DOCSDIR}/LICENSE
diff --git a/www/mod_md-devel/Makefile b/www/mod_md-devel/Makefile
index c5721e90d5c7..6b99c4581c29 100644
--- a/www/mod_md-devel/Makefile
+++ b/www/mod_md-devel/Makefile
@@ -5,6 +5,7 @@ PORTNAME= mod_md
PORTVERSION= 1.0.7
DISTVERSIONPREFIX= v
CATEGORIES= www
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
PKGNAMESUFFIX= -devel
MAINTAINER= brnrd@FreeBSD.org
@@ -19,7 +20,7 @@ LIB_DEPENDS= libaprutil-1.so:devel/apr1 \
USES= autoreconf libtool ssl
USE_GITHUB= yes
-USE_APACHE= 24
+USE_APACHE= 24+
GH_ACCOUNT= icing
GH_PROJECT= mod_md
@@ -45,6 +46,5 @@ post-install:
${WRKSRC}/src/a2md
${INSTALL} ${WRKSRC}/src/a2md ${STAGEDIR}${PREFIX}/bin/a2md
${RM} ${STAGEDIR}${PREFIX}/share/doc/mod_md/LICENSE
-# ${RM} ${STAGEDIR}${PREFIX}/bin/ext-a2md
.include <bsd.port.post.mk>