aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-14 17:41:04 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-06-14 17:41:04 +0000
commit1cde8c04ac889c583a0909e4ceadad35ef3c1620 (patch)
tree777582e1c86f102094ea3092f578b6fcb70e134e /www
parent383e83349d9fdb93791577559ce638ad8dab490c (diff)
downloadports-1cde8c04ac889c583a0909e4ceadad35ef3c1620.tar.gz
ports-1cde8c04ac889c583a0909e4ceadad35ef3c1620.zip
www/py-uvicorn: Update to 0.14.0
Diffstat (limited to 'www')
-rw-r--r--www/py-uvicorn/Makefile7
-rw-r--r--www/py-uvicorn/distinfo6
-rw-r--r--www/py-uvicorn/files/patch-setup.py13
3 files changed, 6 insertions, 20 deletions
diff --git a/www/py-uvicorn/Makefile b/www/py-uvicorn/Makefile
index 4fd77da47e93..b1711c338f10 100644
--- a/www/py-uvicorn/Makefile
+++ b/www/py-uvicorn/Makefile
@@ -1,8 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= uvicorn
-PORTVERSION= 0.13.4
-PORTREVISION= 1
+PORTVERSION= 0.14.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,11 +14,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=7<8:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}h11>=0.8:net/py-h11@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}httptools>=0.1.0:www/py-httptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httptools>=0.2.0<0.3:www/py-httptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}python-dotenv>=0.13:www/py-python-dotenv@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=5.1:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}uvloop>=0.14.0:devel/py-uvloop@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}websockets>=8.0:devel/py-websockets@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}websockets>=9.1:devel/py-websockets@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
diff --git a/www/py-uvicorn/distinfo b/www/py-uvicorn/distinfo
index d6643b11593b..7dc583a4a091 100644
--- a/www/py-uvicorn/distinfo
+++ b/www/py-uvicorn/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1614794328
-SHA256 (uvicorn-0.13.4.tar.gz) = 3292251b3c7978e8e4a7868f4baf7f7f7bb7e40c759ecc125c37e99cdea34202
-SIZE (uvicorn-0.13.4.tar.gz) = 32426
+TIMESTAMP = 1622214130
+SHA256 (uvicorn-0.14.0.tar.gz) = 45ad7dfaaa7d55cab4cd1e85e03f27e9d60bc067ddc59db52a2b0aeca8870292
+SIZE (uvicorn-0.14.0.tar.gz) = 35445
diff --git a/www/py-uvicorn/files/patch-setup.py b/www/py-uvicorn/files/patch-setup.py
deleted file mode 100644
index 4f0cecc2579c..000000000000
--- a/www/py-uvicorn/files/patch-setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- setup.py.orig 2021-02-20 16:48:34 UTC
-+++ setup.py
-@@ -51,8 +51,8 @@ minimal_requirements = [
-
-
- extra_requirements = [
-- "websockets==8.*",
-- "httptools==0.1.* ;" + env_marker_cpython,
-+ "websockets>=8.0",
-+ "httptools>=0.1.0 ;" + env_marker_cpython,
- "uvloop>=0.14.0,!=0.15.0,!=0.15.1; " + env_marker_cpython,
- "colorama>=0.4;" + env_marker_win,
- "watchgod>=0.6",