aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-11 17:42:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-11 17:42:14 +0000
commit36dbd96bef44421fd6850b6811e73d1b84873226 (patch)
tree0d5dfd0a7a10e36e7b5a2cff4343e676433d679a /www
parent8c5b79937d99977f2513df3d1245d12f56c3e169 (diff)
downloadports-36dbd96bef44421fd6850b6811e73d1b84873226.tar.gz
ports-36dbd96bef44421fd6850b6811e73d1b84873226.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/awffull/Makefile35
-rw-r--r--www/awffull/pkg-plist64
2 files changed, 57 insertions, 42 deletions
diff --git a/www/awffull/Makefile b/www/awffull/Makefile
index e9df99e1c6d6..985cd5b7dfd1 100644
--- a/www/awffull/Makefile
+++ b/www/awffull/Makefile
@@ -3,13 +3,15 @@
PORTNAME= awffull
PORTVERSION= 3.10.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES?= www
MASTER_SITES= http://www.stedee.id.au/files/
MAINTAINER?= chad@wickdev.com
COMMENT= AWFFull is a webserver log analysis tool forked from Webalizer
+LICENSE= GPLv3
+
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd \
libpng15.so:${PORTSDIR}/graphics/png \
@@ -21,7 +23,8 @@ CONFLICTS?= ja-awffull-[0-9]*
FONTDEFAULT?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/VeraBd.ttf
FONTLABEL?= ${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf
-OPTIONS_DEFINE= GEOIP
+OPTIONS_DEFINE= GEOIP DOCS EXAMPLES NLS
+OPTIONS_SUB= yes
USES= gettext iconv
@@ -33,13 +36,25 @@ CONFIGURE_ARGS+=--with-font-default=${FONTDEFAULT} \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGEOIP}
-LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
-CONFIGURE_ARGS+=--enable-geoip
-.else
-CONFIGURE_ARGS+=--disable-geoip
-.endif
+GEOIP_LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+GEOIP_CONFIGURE_ENABLE= geoip
+
+NLS_CONFIGURE_ENABLE= nls
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} \
+ COPYING ChangeLog DNS.README PERFORMANCE_TIPS.txt \
+ README* TODO country-codes.txt \
+ ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample* ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/*.pl ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/flags
+ ${INSTALL_DATA} ${WRKSRC}/flags/README ${WRKSRC}/flags/*.png \
+ ${STAGEDIR}${EXAMPLESDIR}/flags
.include <bsd.port.mk>
diff --git a/www/awffull/pkg-plist b/www/awffull/pkg-plist
index 08eb21a5bb84..e02fe32d8548 100644
--- a/www/awffull/pkg-plist
+++ b/www/awffull/pkg-plist
@@ -1,35 +1,35 @@
bin/awffull
man/man1/awffull.1.gz
man/man5/awffull.conf.5.gz
-share/locale/ca/LC_MESSAGES/awffull.mo
-share/locale/cs/LC_MESSAGES/awffull.mo
-share/locale/da/LC_MESSAGES/awffull.mo
-share/locale/de/LC_MESSAGES/awffull.mo
-share/locale/el/LC_MESSAGES/awffull.mo
-share/locale/es/LC_MESSAGES/awffull.mo
-share/locale/et/LC_MESSAGES/awffull.mo
-share/locale/fi/LC_MESSAGES/awffull.mo
-share/locale/fr/LC_MESSAGES/awffull.mo
-share/locale/gl/LC_MESSAGES/awffull.mo
-share/locale/hr/LC_MESSAGES/awffull.mo
-share/locale/hu/LC_MESSAGES/awffull.mo
-share/locale/id/LC_MESSAGES/awffull.mo
-share/locale/is/LC_MESSAGES/awffull.mo
-share/locale/it/LC_MESSAGES/awffull.mo
-share/locale/ja/LC_MESSAGES/awffull.mo
-share/locale/ko/LC_MESSAGES/awffull.mo
-share/locale/lv/LC_MESSAGES/awffull.mo
-share/locale/ml/LC_MESSAGES/awffull.mo
-share/locale/nl/LC_MESSAGES/awffull.mo
-share/locale/no/LC_MESSAGES/awffull.mo
-share/locale/pl/LC_MESSAGES/awffull.mo
-share/locale/pt/LC_MESSAGES/awffull.mo
-share/locale/pt_BR/LC_MESSAGES/awffull.mo
-share/locale/ro/LC_MESSAGES/awffull.mo
-share/locale/ru/LC_MESSAGES/awffull.mo
-share/locale/sl/LC_MESSAGES/awffull.mo
-share/locale/sr/LC_MESSAGES/awffull.mo
-share/locale/sv/LC_MESSAGES/awffull.mo
-share/locale/tr/LC_MESSAGES/awffull.mo
-share/locale/uk/LC_MESSAGES/awffull.mo
-share/locale/zh/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/da/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/de/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/el/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/es/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/et/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/id/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/is/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/it/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/no/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/awffull.mo
+%%NLS%%share/locale/zh/LC_MESSAGES/awffull.mo