aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2009-01-20 17:34:18 +0000
committerNicola Vitale <nivit@FreeBSD.org>2009-01-20 17:34:18 +0000
commit6cbde64c65fda2104d72eb600261e22d89ccd6bf (patch)
tree6276fc0c3321e669f4085a81d6a8ca10e190ab81 /www
parenta6942d3d9ebb0235226746e554e7673e406fe907 (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/py-turbosetup/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/www/py-turbosetup/Makefile b/www/py-turbosetup/Makefile
index 308f1b78c226..7b8fb88ea692 100644
--- a/www/py-turbosetup/Makefile
+++ b/www/py-turbosetup/Makefile
@@ -23,8 +23,7 @@ RUN_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools \
NO_BUILD= yes
-# Use the same version of www/py-turbogears
-USE_PYTHON= 2.4
+USE_PYTHON= yes
PLIST_SUB= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION} \
@@ -43,4 +42,10 @@ do-extract:
do-install:
@${EASY_INSTALL_CMD} ${EASY_INSTALL_ARGS} ${DISTDIR}/${PYTURBOSETUP_EGG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 240 || ${PYTHON_REL} >= 250
+IGNORE= the distribution file is only available for Python 2.4
+.endif
+
+.include <bsd.port.post.mk>