aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-04-18 07:28:03 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-04-18 08:28:33 +0000
commit7220a250ce9464445c5df399d89754368474c0ad (patch)
tree1d5263a06ada551afcbfee46dd332ce24619a7ad /www
parentf5ea0ae2e6d53ce24527b96decff7cc6bc2f2ea6 (diff)
downloadports-7220a250ce9464445c5df399d89754368474c0ad.tar.gz
ports-7220a250ce9464445c5df399d89754368474c0ad.zip
www/py-django-bootstrap-pagination: Switch to Django 3.2
* Adjust RUN_DEPENDS to use Django 3.2 (LTS release) because the extended support for Django 3.0 has expired on 6th April 2021. * Also avoid the installation of the test suite into the root of Python's site-lib directory as it can lead to conflicts with other packages. PR: 255114 Approved by: dbaio (maintainer)
Diffstat (limited to 'www')
-rw-r--r--www/py-django-bootstrap-pagination/Makefile3
-rw-r--r--www/py-django-bootstrap-pagination/files/patch-setup.py14
2 files changed, 16 insertions, 1 deletions
diff --git a/www/py-django-bootstrap-pagination/Makefile b/www/py-django-bootstrap-pagination/Makefile
index 90360b8e00a3..bff2696b6aac 100644
--- a/www/py-django-bootstrap-pagination/Makefile
+++ b/www/py-django-bootstrap-pagination/Makefile
@@ -1,5 +1,6 @@
PORTNAME= django-bootstrap-pagination
DISTVERSION= 1.7.1
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -9,7 +10,7 @@ COMMENT= Bootstrap pagination for django
LICENSE= MIT
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django30>=1.7.0:www/py-django30@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django32>=1.7.0:www/py-django32@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
diff --git a/www/py-django-bootstrap-pagination/files/patch-setup.py b/www/py-django-bootstrap-pagination/files/patch-setup.py
new file mode 100644
index 000000000000..b541907c0fb6
--- /dev/null
+++ b/www/py-django-bootstrap-pagination/files/patch-setup.py
@@ -0,0 +1,14 @@
+Avoid the installation of the test suite in the top-level directory
+of ${PYTHON_SITELIBDIR}.
+
+--- setup.py.orig 2019-06-13 21:18:37 UTC
++++ setup.py
+@@ -17,7 +17,7 @@ setup(
+ keywords="django bootstrap pagination templatetag",
+ author=u'Jason McClellan<jason@jasonmcclellan.io>, Koert van der Veer<koert@ondergetekende.nl>',
+ author_email='jason@jasonmccllelan.io',
+- packages=find_packages(),
++ packages=find_packages(exclude=['tests']),
+ url='https://github.com/jmcclell/django-bootstrap-pagination',
+ license='MIT licence, see LICENCE',
+ description='Render Django Page objects as Bootstrap 3.x/4.x Pagination compatible HTML',