aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-01-13 01:29:38 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-01-13 01:29:38 +0000
commit7e823ca9cbb489de6f03a3313a1d9c7bb60b980a (patch)
treec406a7745f832145adb1b9ee61a44498fd4a32b5 /www
parent6112134f225606f40880f90d267f5c1112e200db (diff)
downloadports-7e823ca9cbb489de6f03a3313a1d9c7bb60b980a.tar.gz
ports-7e823ca9cbb489de6f03a3313a1d9c7bb60b980a.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_pgsql/Makefile69
-rw-r--r--www/mod_auth_pgsql/distinfo1
-rw-r--r--www/mod_auth_pgsql/pkg-comment1
-rw-r--r--www/mod_auth_pgsql/pkg-descr4
-rw-r--r--www/mod_auth_pgsql/pkg-plist8
6 files changed, 84 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 29e10a91d6f8..d58dcf0410a0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -100,6 +100,7 @@
SUBDIR += mmosaic
SUBDIR += mod_access_referer
SUBDIR += mod_auth_mysql
+ SUBDIR += mod_auth_pgsql
SUBDIR += mod_dav
SUBDIR += mod_dtcl
SUBDIR += mod_fastcgi
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
new file mode 100644
index 000000000000..1edca2dfcc4c
--- /dev/null
+++ b/www/mod_auth_pgsql/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: apache mod_auth_pgsql
+# Date created: 2000/11/10
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+
+PORTNAME= mod_auth_pgsql
+PORTVERSION= 0.9.5a
+CATEGORIES= www
+MASTER_SITES= ftp://ftp.eurolink.it/pub/linux/postgreSQL/mod_auth_pgsql/
+
+MAINTAINER= mi@aldan.algebra.com
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/${AP_PORT} \
+ ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
+RUN_DEPENDS= ${LOCALBASE}/sbin/${AP_TARGET}:${PORTSDIR}/www/${AP_PORT} \
+ ${LOCALBASE}/pgsql/lib/libpq.so:${PORTSDIR}/databases/postgresql7
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
+
+.include <bsd.port.pre.mk>
+
+APXS= ${LOCALBASE}/sbin/apxs
+
+AP_PORT?= apache13
+.if exists(${APXS})
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
+.endif
+.if exists(${APXS}) && ${APXS_WORKS} != no
+AP_TARGET!= ${APXS} -q TARGET
+AP_SYSCONF!= ${APXS} -q SYSCONFDIR
+AP_INCLUDE!= ${APXS} -q INCLUDEDIR
+AP_LIBEXEC!= ${APXS} -q LIBEXECDIR
+CFLAGS:= `${APXS} -q CFLAGS` ${CFLAGS}
+.else
+AP_TARGET?= httpd
+AP_SYSCONF?= ${PREFIX}/etc/apache
+AP_INCLUDE?= ${PREFIX}/include/apache
+AP_LIBEXEC?= ${PREFIX}/libexec/apache
+.endif
+
+AUTH_PGSQL_DOCS= apache/manual/mod/mod_auth_pgsql
+
+PLIST_SUB+= AUTH_PGSQL_DOCS="${AUTH_PGSQL_DOCS}"
+
+PKGMESSAGE= ${WRKSRC}/.install_notes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pgsql=${PREFIX}/pgsql \
+ --with-apxs=${APXS}
+
+.if !defined(NOPORTDOCS)
+PLIST_SUB+= DOC=''
+post-install:
+ @${MKDIR} ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/README \
+ ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/
+ ${TR} -d \\015 < ${WRKSRC}/mod_auth_pgsql.html \
+ > ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ ${CHMOD} ${SHAREMODE} \
+ ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ ${CHOWN} ${SHAREOWN}:${SHAREGRP} \
+ ${PREFIX}/share/doc/${AUTH_PGSQL_DOCS}/index.html
+ ${LN} -sf ${AUTH_PGSQL_DOCS} ${PREFIX}/share/doc/
+.else
+PLIST_SUB+= DOC='@comment '
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_auth_pgsql/distinfo b/www/mod_auth_pgsql/distinfo
new file mode 100644
index 000000000000..f811943cb13e
--- /dev/null
+++ b/www/mod_auth_pgsql/distinfo
@@ -0,0 +1 @@
+MD5 (mod_auth_pgsql-0.9.5a.tar.gz) = 8c8da3bdc8c1d04aa3173b5ee6715b51
diff --git a/www/mod_auth_pgsql/pkg-comment b/www/mod_auth_pgsql/pkg-comment
new file mode 100644
index 000000000000..b75baa2d4cda
--- /dev/null
+++ b/www/mod_auth_pgsql/pkg-comment
@@ -0,0 +1 @@
+Allows users to use PostgreSQL databases for user authentication
diff --git a/www/mod_auth_pgsql/pkg-descr b/www/mod_auth_pgsql/pkg-descr
new file mode 100644
index 000000000000..50f3b87a96f1
--- /dev/null
+++ b/www/mod_auth_pgsql/pkg-descr
@@ -0,0 +1,4 @@
+This add-on module allows the apache web server to use a PostgreSQL
+database for user and/or group authentication. For large user lists this
+can offer a significate speed up over apache's standard flat file
+format.
diff --git a/www/mod_auth_pgsql/pkg-plist b/www/mod_auth_pgsql/pkg-plist
new file mode 100644
index 000000000000..d970ccc7a942
--- /dev/null
+++ b/www/mod_auth_pgsql/pkg-plist
@@ -0,0 +1,8 @@
+libexec/apache/mod_auth_pgsql.so
+@exec %D/sbin/apxs -e -a -n auth_pgsql %f
+@unexec %D/sbin/apxs -e -A -n auth_pgsql %f
+%%DOC%%share/doc/%%AUTH_PGSQL_DOCS%%/README
+%%DOC%%share/doc/%%AUTH_PGSQL_DOCS%%/index.html
+%%DOC%%@exec (cd %D/share/doc && ln -sf %%AUTH_PGSQL_DOCS%% mod_auth_pgsql)
+%%DOC%%@unexec rm -f %D/share/doc/mod_auth_pgsql
+%%DOC%%@dirrm share/doc/%%AUTH_PGSQL_DOCS%%