aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBenjamin Jacobs <freebsd@dev.thsi.be>2024-03-11 21:43:46 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2024-03-11 21:50:58 +0000
commit8025aa10ceb960b62c9a826fb56eb1ac68ea1ce3 (patch)
tree959847a64e64c876f5bdd4c254c22f44ca3ff372 /www
parente773e6cf13b183d5a5fa341727ea504d45b9fb87 (diff)
downloadports-8025aa10ceb960b62c9a826fb56eb1ac68ea1ce3.tar.gz
ports-8025aa10ceb960b62c9a826fb56eb1ac68ea1ce3.zip
Diffstat (limited to 'www')
-rw-r--r--www/geneweb/Makefile4
-rw-r--r--www/geneweb/files/patch-ged2gwb_Makefile18
-rw-r--r--www/geneweb/files/patch-ged2gwb_ged2gwb.ml11
-rw-r--r--www/geneweb/files/patch-ged2gwb_ged2gwb2.ml11
-rw-r--r--www/geneweb/files/patch-setup_Makefile11
-rw-r--r--www/geneweb/files/patch-src__Makefile9
-rw-r--r--www/geneweb/files/patch-src_dag.ml52
-rw-r--r--www/geneweb/files/patch-src_date.ml26
-rw-r--r--www/geneweb/files/patch-src_db2disk.ml20
-rw-r--r--www/geneweb/files/patch-src_gwd.ml38
-rw-r--r--www/geneweb/files/patch-src_mutil.ml20
-rw-r--r--www/geneweb/files/patch-src_relation.ml16
-rw-r--r--www/geneweb/files/patch-tools_camlp5__comm.sh11
-rw-r--r--www/geneweb/files/patch-wserver_Makefile17
-rw-r--r--www/geneweb/files/patch-wserver_wserver.ml61
15 files changed, 324 insertions, 1 deletions
diff --git a/www/geneweb/Makefile b/www/geneweb/Makefile
index 752457442848..d224efaec9e2 100644
--- a/www/geneweb/Makefile
+++ b/www/geneweb/Makefile
@@ -28,7 +28,9 @@ SUB_FILES+= pkg-message
USE_RC_SUBR= gwd
post-patch:
- @${REINPLACE_CMD} -e 's,52,& -unsafe-string,' \
+ @${REINPLACE_CMD} \
+ -e 's,^OCAMLC=.*,OCAMLC=ocamlfind ocamlc -package camlp5.streams -package camlp5.gramlib -package unix -package str -w -3 -warn-error +a-52 -unsafe-string,' \
+ -e 's,^OCAMLOPT=.*,OCAMLOPT=ocamlfind ocamlopt -package camlp5.streams -package camlp5.gramlib -package unix -package str -w -3 -warn-error +a-52 -unsafe-string,' \
${WRKSRC}/tools/Makefile.inc.unix
post-install:
diff --git a/www/geneweb/files/patch-ged2gwb_Makefile b/www/geneweb/files/patch-ged2gwb_Makefile
new file mode 100644
index 000000000000..b8158fc3c38d
--- /dev/null
+++ b/www/geneweb/files/patch-ged2gwb_Makefile
@@ -0,0 +1,18 @@
+--- ged2gwb/Makefile.orig 2024-02-11 19:42:58 UTC
++++ ged2gwb/Makefile
+@@ -26,13 +26,13 @@ ged2gwb.opt: $(OBJS:.cmo=.cmx)
+ $(OCAMLC) -custom $(STATIC) $(OCAMLD) unix.cma str.cma $(LIBUNIX) -I $(CAMLP5D) gramlib.cma $(OBJS) -o ged2gwb.out
+
+ ged2gwb.opt: $(OBJS:.cmo=.cmx)
+- $(OCAMLOPT) $(STATIC) unix.cmxa str.cmxa $(LIBUNIX) -I $(CAMLP5D) gramlib.cmxa $(OBJS:.cmo=.cmx) -o ged2gwb.opt
++ $(OCAMLOPT) -linkpkg $(OBJS:.cmo=.cmx) -o ged2gwb.opt
+
+ ged2gwb2.out: $(OBJS2)
+ $(OCAMLC) -custom $(STATIC) $(OCAMLD) unix.cma str.cma $(LIBUNIX) -I $(CAMLP5D) gramlib.cma $(OBJS2) -o ged2gwb2.out
+
+ ged2gwb2.opt: $(OBJS2:.cmo=.cmx)
+- $(OCAMLOPT) $(STATIC) unix.cmxa str.cmxa $(LIBUNIX) -I $(CAMLP5D) gramlib.cmxa $(OBJS2:.cmo=.cmx) -o ged2gwb2.opt
++ $(OCAMLOPT) -linkpkg $(OBJS2:.cmo=.cmx) -o ged2gwb2.opt
+
+ depend:
+ TOP=.. ../tools/camlp5_depend.sh $(OCAMLI) *.ml* > .depend
diff --git a/www/geneweb/files/patch-ged2gwb_ged2gwb.ml b/www/geneweb/files/patch-ged2gwb_ged2gwb.ml
new file mode 100644
index 000000000000..4f79a70b096b
--- /dev/null
+++ b/www/geneweb/files/patch-ged2gwb_ged2gwb.ml
@@ -0,0 +1,11 @@
+--- ged2gwb/ged2gwb.ml.orig 2024-02-11 19:27:48 UTC
++++ ged2gwb/ged2gwb.ml
+@@ -603,7 +603,7 @@ value date_lexer =
+ ;
+
+ value date_lexer =
+- {Token.tok_func s = (make_date_lexing s, fun _ -> Token.dummy_loc);
++ {Token.tok_func s = (make_date_lexing s, Plexing.Locations.create());
+ Token.tok_using = using_token; Token.tok_removing _ = ();
+ Token.tok_match = tparse; Token.tok_text _ = "<tok>";
+ Token.tok_comm = None}
diff --git a/www/geneweb/files/patch-ged2gwb_ged2gwb2.ml b/www/geneweb/files/patch-ged2gwb_ged2gwb2.ml
new file mode 100644
index 000000000000..dfd4eb15e342
--- /dev/null
+++ b/www/geneweb/files/patch-ged2gwb_ged2gwb2.ml
@@ -0,0 +1,11 @@
+--- ged2gwb/ged2gwb2.ml.orig 2024-02-11 19:44:49 UTC
++++ ged2gwb/ged2gwb2.ml
+@@ -501,7 +501,7 @@ value date_lexer =
+ ;
+
+ value date_lexer =
+- {Token.tok_func s = (make_date_lexing s, fun _ -> Token.dummy_loc);
++ {Token.tok_func s = (make_date_lexing s, Plexing.Locations.create ());
+ Token.tok_using = using_token; Token.tok_removing _ = ();
+ Token.tok_match = tparse; Token.tok_text _ = "<tok>";
+ Token.tok_comm = None}
diff --git a/www/geneweb/files/patch-setup_Makefile b/www/geneweb/files/patch-setup_Makefile
new file mode 100644
index 000000000000..2d4cfb73c3e4
--- /dev/null
+++ b/www/geneweb/files/patch-setup_Makefile
@@ -0,0 +1,11 @@
+--- setup/Makefile.orig 2024-02-11 19:47:03 UTC
++++ setup/Makefile
+@@ -64,7 +64,7 @@ setup.opt: $(OBJS:.cmo=.cmx)
+ $(OCAMLC) -custom $(STATIC) unix.cma $(LIBUNIX) $(OBJS) -o setup.out
+
+ setup.opt: $(OBJS:.cmo=.cmx)
+- $(OCAMLOPT) $(STATIC) unix.cmxa $(LIBUNIX) $(OBJS:.cmo=.cmx) -o setup.opt
++ $(OCAMLOPT) -linkpkg $(OBJS:.cmo=.cmx) -o setup.opt
+
+ depend:
+ TOP=.. ../tools/camlp5_depend.sh $(OCAMLI) *.ml* > .depend
diff --git a/www/geneweb/files/patch-src__Makefile b/www/geneweb/files/patch-src__Makefile
index 35ed89973d9d..bcb4bd2c2b1f 100644
--- a/www/geneweb/files/patch-src__Makefile
+++ b/www/geneweb/files/patch-src__Makefile
@@ -8,3 +8,12 @@
OCAMLI=-I ../wserver -I ../dag2html
GWC_OBJS=argl.cmo lock.cmo adef.cmo iovalue.cmo buff.cmo name.cmo mutil.cmo secure.cmo btree.cmo futil.cmo dutil.cmo database.cmo db2.cmo db2disk.cmo diff.cmo outbase.cmo gwdb.cmo pqueue.cmo progrBar.cmo consang.cmo consangAll.cmo checkItem.cmo check.cmo calendar.cmo notesLinks.cmo gwcomp.cmo db1link.cmo gwc.cmo
GWC2_OBJS=calendar.cmo adef.cmo iovalue.cmo buff.cmo name.cmo mutil.cmo gwcomp.cmo argl.cmo lock.cmo progrBar.cmo secure.cmo iochan.cmo futil.cmo db2.cmo db2out.cmo notesLinks.cmo db2disk.cmo dutil.cmo btree.cmo database.cmo gwdb.cmo consang.cmo consangAll.cmo checkItem.cmo check.cmo db2link.cmo gwc2.cmo
+@@ -99,7 +98,7 @@ gwd.opt: $(GWD_OBJS:.cmo=.cmx)
+ gwd.opt: $(GWD_OBJS:.cmo=.cmx)
+ $(OCAMLOPT) $(GWD_OBJS1:.cmo=.cmx) -a -o x1.cmxa
+ $(OCAMLOPT) $(GWD_OBJS2:.cmo=.cmx) -a -o x2.cmxa
+- $(OCAMLOPT) $(STATIC) unix.cmxa str.cmxa -I $(CAMLP5D) gramlib.cmxa x1.cmxa x2.cmxa compilation.cmx gwd.cmx $(LIBUNIX) -o gwd.opt
++ $(OCAMLOPT) -linkpkg x1.cmxa x2.cmxa compilation.cmx gwd.cmx -o gwd.opt
+
+ gwu.out: $(GWU_OBJS)
+ $(OCAMLC) -custom $(STATIC) unix.cma $(LIBUNIX) $(GWU_OBJS) -o gwu.out
diff --git a/www/geneweb/files/patch-src_dag.ml b/www/geneweb/files/patch-src_dag.ml
new file mode 100644
index 000000000000..2ee9d41b42c2
--- /dev/null
+++ b/www/geneweb/files/patch-src_dag.ml
@@ -0,0 +1,52 @@
+--- src/dag.ml.orig 2016-11-06 14:21:56 UTC
++++ src/dag.ml
+@@ -48,7 +48,7 @@ value tag_dag d =
+ })
+ d
+ ;
+-end END;
++end; END;
+
+ (* input dag *)
+
+@@ -308,7 +308,7 @@ value print_table conf hts =
+ end_centered conf;
+ }
+ ;
+-end END;
++end; END;
+
+ (*
+ * Print without HTML table tags: using <pre>
+@@ -837,7 +837,7 @@ value print_html_table conf hts =
+ else print_table conf hts
+ }
+ ;
+-end END;
++end; END;
+
+ value make_tree_hts conf base elem_txt vbar_txt invert set spl d =
+ let no_group = p_getenv conf.env "nogroup" = Some "on" in
+@@ -1026,7 +1026,7 @@ value print_dag_page conf base page_title hts next_txt
+ Hutil.trailer conf
+ }
+ ;
+-end END;
++end; END;
+
+ (* *)
+
+@@ -1275,11 +1275,11 @@ value old_print_slices_menu_or_dag_page conf base page
+ if p_getenv conf.env "slices" = Some "on" then print_slices_menu conf hts
+ else print_dag_page conf base page_title hts next_txt
+ ;
+-end ELSE declare
++end; ELSE declare
+ value old_print_slices_menu_or_dag_page conf base page_title hts next_txt =
+ incorrect_request conf
+ ;
+-end END;
++end; END;
+
+ value print_slices_menu_or_dag_page conf base page_title hts next_txt =
+ (**)
diff --git a/www/geneweb/files/patch-src_date.ml b/www/geneweb/files/patch-src_date.ml
new file mode 100644
index 000000000000..51e10a47b836
--- /dev/null
+++ b/www/geneweb/files/patch-src_date.ml
@@ -0,0 +1,26 @@
+--- src/date.ml.orig 2024-02-11 18:32:01 UTC
++++ src/date.ml
+@@ -1185,7 +1185,7 @@ value old_print_calendar conf base =
+ trailer conf;
+ }
+ ;
+-end END;
++end; END;
+
+ (* *)
+
+@@ -1241,7 +1241,7 @@ value print_calendar conf base =
+ (fun _ -> Templ.eval_transl conf) (fun _ -> raise Not_found)
+ get_vother set_vother (print_foreach conf) [] (eval_julian_day conf)
+ ;
+-end ELSE declare
++end; ELSE declare
+ value print_calendar conf base =
+ Hutil.interp conf base "calendar"
+ {Templ.eval_var = eval_var conf;
+@@ -1251,4 +1251,4 @@ value print_calendar conf base =
+ Templ.print_foreach = print_foreach conf}
+ [] (eval_julian_day conf)
+ ;
+-end END;
++end; END;
diff --git a/www/geneweb/files/patch-src_db2disk.ml b/www/geneweb/files/patch-src_db2disk.ml
new file mode 100644
index 000000000000..a1c8ff62cce3
--- /dev/null
+++ b/www/geneweb/files/patch-src_db2disk.ml
@@ -0,0 +1,20 @@
+--- src/db2disk.ml.orig 2024-02-11 18:31:31 UTC
++++ src/db2disk.ml
+@@ -230,7 +230,7 @@ value spi2_first db2 spi (f1, f2) s = do {
+ let ic = fast_open_in_bin_and_seek db2 f1 f2 "index.dat" pos in
+ try
+ loop i where rec loop i =
+- let (s1, pos) : (string * int) = Iovalue.input ic in
++ let (s1, pos) = Iovalue.input ic in
+ if start_with s1 s then Some (s1, pos, i) else loop (i + 1)
+ with
+ [ End_of_file -> None ]
+@@ -284,7 +284,7 @@ value spi2_next db2 spi (f1, f2) need_whole_list =
+ let pos = input_binary_int ic in
+ fast_open_in_bin_and_seek db2 f1 f2 "index.dat" pos
+ in
+- let (s, pos) : (string * int) = Iovalue.input ic in
++ let (s, pos) = Iovalue.input ic in
+ let dlen = i - spi.curr_i in
+ Some (i, s, pos, dlen)
+ with
diff --git a/www/geneweb/files/patch-src_gwd.ml b/www/geneweb/files/patch-src_gwd.ml
new file mode 100644
index 000000000000..f47b13df5a72
--- /dev/null
+++ b/www/geneweb/files/patch-src_gwd.ml
@@ -0,0 +1,38 @@
+--- src/gwd.ml.orig 2024-02-11 19:03:33 UTC
++++ src/gwd.ml
+@@ -27,7 +27,7 @@ IFDEF UNIX THEN
+ [Open_wronly; Open_append; Open_creat; Open_text; Open_nonblock]
+ ;
+ IFDEF UNIX THEN
+-value max_clients = ref None
++value max_clients = ref None;
+ END;
+ value robot_xcl = ref None;
+ value auth_file = ref "";
+@@ -1749,7 +1749,7 @@ IFDEF SYS_COMMAND THEN
+ ;
+
+ IFDEF SYS_COMMAND THEN
+-value wserver_auto_call = ref False
++value wserver_auto_call = ref False;
+ END;
+
+ value geneweb_server () =
+@@ -1809,7 +1809,7 @@ value cgi_timeout tmout _ =
+ Wserver.wprint "</body>\n";
+ Wserver.wflush ();
+ exit 0;
+- }
++ };
+ END;
+
+ IFDEF UNIX THEN
+@@ -1818,7 +1818,7 @@ value manage_cgi_timeout tmout =
+ let _ = Sys.signal Sys.sigalrm (Sys.Signal_handle (cgi_timeout tmout)) in
+ let _ = Unix.alarm tmout in
+ ()
+- else ()
++ else ();
+ END;
+
+ value geneweb_cgi addr script_name contents =
diff --git a/www/geneweb/files/patch-src_mutil.ml b/www/geneweb/files/patch-src_mutil.ml
new file mode 100644
index 000000000000..9cd2eadfdf23
--- /dev/null
+++ b/www/geneweb/files/patch-src_mutil.ml
@@ -0,0 +1,20 @@
+--- src/mutil.ml.orig 2024-02-11 18:31:48 UTC
++++ src/mutil.ml
+@@ -95,7 +95,7 @@ value decline case s =
+ | '>' -> String.sub s ibeg (i + 1 - ibeg) ^ loop (i + 1) (i + 1)
+ | _ -> loop ibeg (i + 1) ]
+ ;
+-end ELSE declare
++end; ELSE declare
+ (* [decline] has been deprecated since version 5.00
+ compatibility code: *)
+ value colon_to_at_word s ibeg iend =
+@@ -158,7 +158,7 @@ value decline case s =
+ (if not (String.contains s ':') then s else colon_to_at s)
+ ;
+ (* end compatibility code *)
+-end END;
++end; END;
+
+ value nominative s =
+ match rindex s ':' with
diff --git a/www/geneweb/files/patch-src_relation.ml b/www/geneweb/files/patch-src_relation.ml
new file mode 100644
index 000000000000..b34a3c83f85e
--- /dev/null
+++ b/www/geneweb/files/patch-src_relation.ml
@@ -0,0 +1,16 @@
+--- src/relation.ml.orig 2024-02-11 19:02:59 UTC
++++ src/relation.ml
+@@ -194,11 +194,11 @@ value old_print_relationship_dag conf base elem_txt vb
+ let hts = Dag.make_tree_hts conf base elem_txt vbar_txt invert set [] d in
+ Dag.print_slices_menu_or_dag_page conf base page_title hts next_txt
+ ;
+-end ELSE declare
++end; ELSE declare
+ value old_print_relationship_dag conf base elem_txt vbar_txt path next_txt =
+ incorrect_request conf
+ ;
+-end END;
++end; END;
+
+ value add_common_parent base ip1 ip2 set =
+ let a1 = poi base ip1 in
diff --git a/www/geneweb/files/patch-tools_camlp5__comm.sh b/www/geneweb/files/patch-tools_camlp5__comm.sh
new file mode 100644
index 000000000000..8fb5e568bb61
--- /dev/null
+++ b/www/geneweb/files/patch-tools_camlp5__comm.sh
@@ -0,0 +1,11 @@
+--- tools/camlp5_comm.sh.orig 2024-02-11 18:33:15 UTC
++++ tools/camlp5_comm.sh
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+ # $Id: camlp5_comm.sh,v 5.2 2010-09-23 17:16:49 ddr Exp $
+
+-ARGS1="$TOP/wserver/pa_macro5.cmo"
++ARGS1="`ocamlfind query camlp5.macro`/pa_macro.cmo"
+ FILE=
+ while test "" != "$1"; do
+ case $1 in
diff --git a/www/geneweb/files/patch-wserver_Makefile b/www/geneweb/files/patch-wserver_Makefile
new file mode 100644
index 000000000000..0bc23fc5d7ba
--- /dev/null
+++ b/www/geneweb/files/patch-wserver_Makefile
@@ -0,0 +1,17 @@
+--- wserver/Makefile.orig 2024-02-11 18:30:32 UTC
++++ wserver/Makefile
+@@ -4,12 +4,8 @@ OBJS=wserver.cmo
+
+ OBJS=wserver.cmo
+
+-all:: pa_macro5.cmo $(OBJS)
+-opt:: pa_macro5.cmo $(OBJS:.cmo=.cmx)
+-
+-pa_macro5.cmo: pa_macro5.ml
+- camlp5r pa_extend.cmo q_MLast.cmo -o pa_macro5.ppo pa_macro5.ml
+- ocamlc -c -I "`camlp5 -where`" -impl pa_macro5.ppo
++all:: $(OBJS)
++opt:: $(OBJS:.cmo=.cmx)
+
+ depend:
+ TOP=.. ../tools/camlp5_depend.sh $(OCAMLI) *.ml* > .depend
diff --git a/www/geneweb/files/patch-wserver_wserver.ml b/www/geneweb/files/patch-wserver_wserver.ml
new file mode 100644
index 000000000000..21ea44996da0
--- /dev/null
+++ b/www/geneweb/files/patch-wserver_wserver.ml
@@ -0,0 +1,61 @@
+--- wserver/wserver.ml.orig 2024-02-11 18:29:57 UTC
++++ wserver/wserver.ml
+@@ -263,7 +263,7 @@ value timeout tmout spid _ =
+ else ();
+ let _ = Unix.waitpid [] pid in ();
+ exit 2
+- }
++ };
+ END;
+
+ value get_request_and_content strm =
+@@ -363,7 +363,7 @@ value copy_what_necessary t oc =
+ })
+ in
+ let _ = get_request_and_content strm in
+- ()
++ ();
+ END;
+
+ value rec list_remove x =
+@@ -372,13 +372,13 @@ value rec list_remove x =
+ | [y :: l] -> if x = y then l else [y :: list_remove x l] ]
+ ;
+
+-IFDEF NOFORK THEN declare end ELSE
+-value pids = ref []
++IFDEF NOFORK THEN declare end; ELSE
++value pids = ref [];
+ END;
+-IFDEF NOFORK THEN declare end ELSE
+-value cleanup_verbose = ref True
++IFDEF NOFORK THEN declare end; ELSE
++value cleanup_verbose = ref True;
+ END;
+-IFDEF NOFORK THEN declare end ELSE
++IFDEF NOFORK THEN declare end; ELSE
+ value cleanup_sons () =
+ List.iter
+ (fun p ->
+@@ -402,10 +402,10 @@ value cleanup_sons () =
+ in
+ if pid = 0 then ()
+ else pids.val := list_remove pid pids.val)
+- pids.val
++ pids.val;
+ END;
+
+-IFDEF NOFORK THEN declare end ELSE
++IFDEF NOFORK THEN declare end; ELSE
+ value wait_available max_clients s =
+ match max_clients with
+ [ Some m ->
+@@ -434,7 +434,7 @@ eprintf "*** %02d/%02d/%4d %02d:%02d:%02d %d process(e
+ else ();
+ };
+ }
+- | None -> () ]
++ | None -> () ];
+ END;
+
+ value wait_and_compact s =