aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-12-11 11:07:35 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-12-11 11:07:35 +0000
commit9ef34e5282e872890ccb6086dc683e79e27d3588 (patch)
treecf6999b64ad3008f36f8fac74a65fca71f067376 /www
parent6e28f35c2ce948494d9f40dd22f2a55d90f7e43a (diff)
downloadports-9ef34e5282e872890ccb6086dc683e79e27d3588.tar.gz
ports-9ef34e5282e872890ccb6086dc683e79e27d3588.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile26
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f637d1b73340..197c5c0f1fa0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -754,6 +754,7 @@
SUBDIR += p5-Catalyst-Plugin-Session-Store-FastMmap
SUBDIR += p5-Catalyst-Plugin-Session-Store-File
SUBDIR += p5-Catalyst-Plugin-Session-Store-Memcached
+ SUBDIR += p5-Catalyst-Plugin-Session-Store-Memcached-Fast
SUBDIR += p5-Catalyst-Plugin-Setenv
SUBDIR += p5-Catalyst-Plugin-Singleton
SUBDIR += p5-Catalyst-Plugin-SmartURI
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile
new file mode 100644
index 000000000000..347bc976eb1b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast
+# Date created: 11 Dec 2008
+# Whom: Denis Pokataev <catone@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Session-Store-Memcached-Fast
+PORTVERSION= 0.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= catone@cpan.org
+COMMENT= Memcached storage backend for session data
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Cache-Memcached-Fast>=0:${PORTSDIR}/databases/p5-Cache-Memcached-Fast \
+ p5-Catalyst-Plugin-Session>=0.01:${PORTSDIR}/www/p5-Catalyst-Plugin-Session
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= 5.8.2+
+
+MAN3= Catalyst::Plugin::Session::Store::Memcached::Fast.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/distinfo b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/distinfo
new file mode 100644
index 000000000000..83f7b8d965eb
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Session-Store-Memcached-Fast-0.02.tar.gz) = 72cacc2f6e9740af00d755dc5f1f468b
+SHA256 (Catalyst-Plugin-Session-Store-Memcached-Fast-0.02.tar.gz) = 62c9b556e8e4b1dbf5a823e60a0509dca7c6c82848232240584f60ab520c6d0b
+SIZE (Catalyst-Plugin-Session-Store-Memcached-Fast-0.02.tar.gz) = 2929
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-descr b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-descr
new file mode 100644
index 000000000000..37ceebf2c97b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-descr
@@ -0,0 +1,3 @@
+Memcached session storage backend
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Session-Store-Memcached-Fast/
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-plist b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-plist
new file mode 100644
index 000000000000..7bf33ad17e88
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Catalyst/Plugin/Session/Store/Memcached/Fast.pm
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session/Store/Memcached
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session/Store
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin/Session
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst