aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-18 16:03:16 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-18 16:03:16 +0000
commita7ebc6b6af894137049859619789b9d49f53d4cd (patch)
tree42e9a6c65cd630a24f1cd0be259f77c000ddc941 /www
parentc9a0322c4242d5c2b51e17bdebe27bc3191f83de (diff)
downloadports-a7ebc6b6af894137049859619789b9d49f53d4cd.tar.gz
ports-a7ebc6b6af894137049859619789b9d49f53d4cd.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/cadaver/Makefile6
-rw-r--r--www/httperf/Makefile8
2 files changed, 2 insertions, 12 deletions
diff --git a/www/cadaver/Makefile b/www/cadaver/Makefile
index 82b08cd949c7..69d5182dd2b4 100644
--- a/www/cadaver/Makefile
+++ b/www/cadaver/Makefile
@@ -16,6 +16,7 @@ COMMENT= Commandline client for DAV
LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2 \
neon.23:${PORTSDIR}/www/neon
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -28,11 +29,6 @@ MAN1= cadaver.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-LDFLAGS+= -lgnugetopt
-.endif
-
.if !defined(WITHOUT_OPENSSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ssl --with-force-ssl
diff --git a/www/httperf/Makefile b/www/httperf/Makefile
index be90a412b785..3b1dcb09f492 100644
--- a/www/httperf/Makefile
+++ b/www/httperf/Makefile
@@ -14,17 +14,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for measuring webserver performance
USE_OPENSSL= yes
+USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= httperf.1
-.if !exists(/usr/include/getopt.h)
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}