aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-06 07:23:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-20 06:57:34 +0000
commita91d65363fe8aa72bdf427bb639b0fe258ee7c01 (patch)
treebff05a5e79d56100a683a17dd262f3cdbf38cf36 /www
parent18f78deb5310e3dc0c3283cc5893339da900640c (diff)
downloadports-a91d65363fe8aa72bdf427bb639b0fe258ee7c01.tar.gz
ports-a91d65363fe8aa72bdf427bb639b0fe258ee7c01.zip
Mk/Uses/ninja.mk: Add support for devel/samurai (D29353)
Samurai is a Ninja-compatible build tool with fewer dependencies than Ninja. Hook it to the framework via a new NINJA_DEFAULT. This also adds %p to NINJA_STATUS to make Ninja or Samurai print the percentage of completed jobs to make it easier to eyeball how much of the build is done. PR: 254678 Exp-run by: antoine
Diffstat (limited to 'www')
-rw-r--r--www/deno/Makefile4
-rw-r--r--www/qt5-webengine/Makefile3
2 files changed, 3 insertions, 4 deletions
diff --git a/www/deno/Makefile b/www/deno/Makefile
index 7b49f38716d7..304301d68144 100644
--- a/www/deno/Makefile
+++ b/www/deno/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= binutils>0:devel/binutils \
gn:devel/gn \
libunwind>0:devel/libunwind
-USES= cargo ninja pkgconfig:build python:3.6+,build
+USES= cargo ninja:build pkgconfig:build python:3.6+,build
USE_GITHUB= yes
GH_ACCOUNT= denoland
@@ -27,7 +27,7 @@ RUSTY_VERS= 0.21.0
CARGO_ENV+= CLANG_BASE_PATH=/usr \
GN=${PREFIX}/bin/gn \
- NINJA=${PREFIX}/bin/ninja \
+ NINJA=${NINJA_CMD} \
V8_FROM_SOURCE=1
RUSTFLAGS+= -C link-arg=-fuse-ld=lld
diff --git a/www/qt5-webengine/Makefile b/www/qt5-webengine/Makefile
index 95e5dbb87031..1fd7501c7334 100644
--- a/www/qt5-webengine/Makefile
+++ b/www/qt5-webengine/Makefile
@@ -24,7 +24,6 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 5 library to render web content
BUILD_DEPENDS= bison:devel/bison \
- ninja:devel/ninja \
yasm:devel/yasm \
${LOCALBASE}/include/linux/input.h:devel/evdev-proto \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
@@ -72,7 +71,7 @@ SNDIO_VARS_OFF= QMAKE_CONFIGURE_ARGS+=-no-sndio
# We pass `norecursive' to USES=qmake because src/plugins/plugins.pro checks
# whether webenginewidgets is available, which fails when qmake processes all
# .pro files at once.
-USES= gl gnome gperf jpeg python:2.7,build pkgconfig \
+USES= gl gnome gperf jpeg ninja:build pkgconfig python:2.7,build \
qmake:norecursive,outsource qt-dist:5,webengine shebangfix xorg
USE_GL= gl
USE_GNOME= glib20 libxml2 libxslt