aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2024-05-02 10:32:04 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2024-05-02 10:33:59 +0000
commitb15f03433541fb3bc784c86c62c35eaa47cb4af4 (patch)
tree19ec091ff39288740def5510d03b9c8ec35bd747 /www
parent2417fd85e5a24624658ac0262f1bd19d954aa6eb (diff)
downloadports-b15f03433541fb3bc784c86c62c35eaa47cb4af4.tar.gz
ports-b15f03433541fb3bc784c86c62c35eaa47cb4af4.zip
www/chromium: update to 124.0.6367.118
Diffstat (limited to 'www')
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/distinfo14
-rw-r--r--www/chromium/files/patch-chrome_app_chrome__main__delegate.cc44
-rw-r--r--www/chromium/files/patch-chrome_browser_chrome__browser__main__extra__parts__linux.cc8
-rw-r--r--www/chromium/files/patch-chrome_browser_prefs_browser__prefs.cc6
-rw-r--r--www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json514
-rw-r--r--www/chromium/files/patch-ui_base_ui__base__features.cc6
7 files changed, 56 insertions, 38 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 2ecdf3ba1ace..9a2a287d8e19 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,5 +1,5 @@
PORTNAME= chromium
-PORTVERSION= 124.0.6367.78
+PORTVERSION= 124.0.6367.118
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 13866f6c4f6c..249c42923349 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1714079974
-SHA256 (chromium-124.0.6367.78.tar.xz) = 697ea9e8591e0a74deea260a50441711b1ea499ca19e91d6012c5b4d200d1acf
-SIZE (chromium-124.0.6367.78.tar.xz) = 3438644780
-SHA256 (chrome-linux-124.0.6367.78-llvm17.profdata.tar.xz) = 7e7396b45fbc4647e8a2fdfc549eb851be815365aee03b5178df10117ff2b4df
-SIZE (chrome-linux-124.0.6367.78-llvm17.profdata.tar.xz) = 30063488
-SHA256 (chromium-124.0.6367.78-testdata.tar.xz) = 910629247cf98b81ec9b323612068b0ad9f49379605863960e9e3b44f2d5a4cd
-SIZE (chromium-124.0.6367.78-testdata.tar.xz) = 280902680
+TIMESTAMP = 1714547240
+SHA256 (chromium-124.0.6367.118.tar.xz) = 8aa5a14aad1234b48b568da9ef23d6e0b1b72d7f4ca5c4039462e54e6ad45d96
+SIZE (chromium-124.0.6367.118.tar.xz) = 3444501448
+SHA256 (chrome-linux-124.0.6367.118-llvm17.profdata.tar.xz) = c31572a6cba6268c1938e2c6ea35e567ea8809370f59504fcccb4e67a8dbe24b
+SIZE (chrome-linux-124.0.6367.118-llvm17.profdata.tar.xz) = 30065808
+SHA256 (chromium-124.0.6367.118-testdata.tar.xz) = 81bef611eddfa954dc9ef1772eef72a053d8ae07ed0d57883889c00ca342bf34
+SIZE (chromium-124.0.6367.118-testdata.tar.xz) = 279593964
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/chromium/files/patch-chrome_app_chrome__main__delegate.cc b/www/chromium/files/patch-chrome_app_chrome__main__delegate.cc
index 22672e805dd8..3b8e559bce55 100644
--- a/www/chromium/files/patch-chrome_app_chrome__main__delegate.cc
+++ b/www/chromium/files/patch-chrome_app_chrome__main__delegate.cc
@@ -1,4 +1,4 @@
---- chrome/app/chrome_main_delegate.cc.orig 2024-04-19 13:02:56 UTC
+--- chrome/app/chrome_main_delegate.cc.orig 2024-05-01 07:03:57 UTC
+++ chrome/app/chrome_main_delegate.cc
@@ -146,7 +146,7 @@
#include "components/about_ui/credit_utils.h"
@@ -34,7 +34,16 @@
#include "chrome/browser/policy/policy_path_parser.h"
#include "components/crash/core/app/crashpad.h"
#endif
-@@ -346,7 +346,7 @@ void AdjustLinuxOOMScore(const std::string& process_ty
+@@ -249,7 +249,7 @@
+ #include "base/scoped_add_feature_flags.h"
+ #include "ui/base/ui_base_features.h"
+ #include "ui/ozone/public/ozone_platform.h"
+-#if BUILDFLAG(IS_LINUX)
++#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_BSD)
+ #include "chrome/browser/chrome_browser_main_extra_parts_linux.h"
+ #endif
+ #endif // BUILDFLAG(IS_OZONE)
+@@ -349,7 +349,7 @@ void AdjustLinuxOOMScore(const std::string& process_ty
// and resources loaded.
bool SubprocessNeedsResourceBundle(const std::string& process_type) {
return
@@ -43,7 +52,7 @@
// The zygote process opens the resources for the renderers.
process_type == switches::kZygoteProcess ||
#endif
-@@ -431,7 +431,7 @@ bool HandleVersionSwitches(const base::CommandLine& co
+@@ -434,7 +434,7 @@ bool HandleVersionSwitches(const base::CommandLine& co
// TODO(crbug.com/1052397): Revisit the macro expression once build flag switch
// of lacros-chrome is complete.
@@ -52,7 +61,7 @@
// Show the man page if --help or -h is on the command line.
void HandleHelpSwitches(const base::CommandLine& command_line) {
if (command_line.HasSwitch(switches::kHelp) ||
-@@ -477,7 +477,7 @@ void SetCrashpadUploadConsentPostLogin() {
+@@ -480,7 +480,7 @@ void SetCrashpadUploadConsentPostLogin() {
}
#endif // BUILDFLAG(IS_CHROMEOS_LACROS)
@@ -61,7 +70,7 @@
void SIGTERMProfilingShutdown(int signal) {
content::Profiling::Stop();
struct sigaction sigact;
-@@ -559,7 +559,7 @@ std::optional<int> AcquireProcessSingleton(
+@@ -562,7 +562,7 @@ std::optional<int> AcquireProcessSingleton(
// process can be exited.
ChromeProcessSingleton::CreateInstance(user_data_dir);
@@ -70,7 +79,7 @@
// Read the xdg-activation token and set it in the command line for the
// duration of the notification in order to ensure this is propagated to an
// already running browser process if it exists.
-@@ -643,7 +643,7 @@ void InitializeUserDataDir(base::CommandLine* command_
+@@ -646,7 +646,7 @@ void InitializeUserDataDir(base::CommandLine* command_
std::string process_type =
command_line->GetSwitchValueASCII(switches::kProcessType);
@@ -79,7 +88,7 @@
// On Linux, Chrome does not support running multiple copies under different
// DISPLAYs, so the profile directory can be specified in the environment to
// support the virtual desktop use-case.
-@@ -770,7 +770,7 @@ void RecordMainStartupMetrics(base::TimeTicks applicat
+@@ -773,7 +773,7 @@ void RecordMainStartupMetrics(base::TimeTicks applicat
#endif
#if BUILDFLAG(IS_MAC) || BUILDFLAG(IS_WIN) || BUILDFLAG(IS_LINUX) || \
@@ -88,7 +97,16 @@
// Record the startup process creation time on supported platforms. On Android
// this is recorded in ChromeMainDelegateAndroid.
startup_metric_utils::GetCommon().RecordStartupProcessCreationTime(
-@@ -1155,7 +1155,7 @@ void ChromeMainDelegate::CommonEarlyInitialization(Inv
+@@ -964,7 +964,7 @@ std::optional<int> ChromeMainDelegate::PostEarlyInitia
+ #if BUILDFLAG(IS_OZONE)
+ // Initialize Ozone platform and add required feature flags as per platform's
+ // properties.
+-#if BUILDFLAG(IS_LINUX)
++#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_BSD)
+ ChromeBrowserMainExtraPartsLinux::InitOzonePlatformHint();
+ #endif
+ ui::OzonePlatform::PreEarlyInitialization();
+@@ -1162,7 +1162,7 @@ void ChromeMainDelegate::CommonEarlyInitialization(Inv
chrome::GetChannel() == version_info::Channel::DEV;
const bool emit_crashes =
#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_CHROMEOS) || BUILDFLAG(IS_MAC) || \
@@ -97,7 +115,7 @@
is_canary_dev;
#else
false;
-@@ -1174,7 +1174,7 @@ void ChromeMainDelegate::CommonEarlyInitialization(Inv
+@@ -1181,7 +1181,7 @@ void ChromeMainDelegate::CommonEarlyInitialization(Inv
// for more context.
base::sequence_manager::internal::ThreadController::InitializeFeatures(
/*record_sample_metadata=*/is_canary_dev);
@@ -106,7 +124,7 @@
base::MessagePumpLibevent::InitializeFeatures();
#elif BUILDFLAG(IS_MAC)
base::PlatformThread::InitFeaturesPostFieldTrial();
-@@ -1323,7 +1323,7 @@ std::optional<int> ChromeMainDelegate::BasicStartupCom
+@@ -1330,7 +1330,7 @@ std::optional<int> ChromeMainDelegate::BasicStartupCom
// TODO(crbug.com/1052397): Revisit the macro expression once build flag
// switch of lacros-chrome is complete.
@@ -115,7 +133,7 @@
// This will directly exit if the user asked for help.
HandleHelpSwitches(command_line);
#endif
-@@ -1353,7 +1353,7 @@ std::optional<int> ChromeMainDelegate::BasicStartupCom
+@@ -1360,7 +1360,7 @@ std::optional<int> ChromeMainDelegate::BasicStartupCom
#if BUILDFLAG(IS_CHROMEOS)
chromeos::dbus_paths::RegisterPathProvider();
#endif
@@ -124,7 +142,7 @@
nacl::RegisterPathProvider();
#endif
-@@ -1750,7 +1750,7 @@ void ChromeMainDelegate::PreSandboxStartup() {
+@@ -1757,7 +1757,7 @@ void ChromeMainDelegate::PreSandboxStartup() {
CHECK(!loaded_locale.empty()) << "Locale could not be found for " << locale;
}
@@ -133,7 +151,7 @@
// Zygote needs to call InitCrashReporter() in RunZygote().
if (process_type != switches::kZygoteProcess) {
if (command_line.HasSwitch(switches::kPreCrashpadCrashTest)) {
-@@ -1851,7 +1851,7 @@ absl::variant<int, content::MainFunctionParams> Chrome
+@@ -1858,7 +1858,7 @@ absl::variant<int, content::MainFunctionParams> Chrome
// This entry is not needed on Linux, where the NaCl loader
// process is launched via nacl_helper instead.
diff --git a/www/chromium/files/patch-chrome_browser_chrome__browser__main__extra__parts__linux.cc b/www/chromium/files/patch-chrome_browser_chrome__browser__main__extra__parts__linux.cc
index e30002b2521b..80dcc921f211 100644
--- a/www/chromium/files/patch-chrome_browser_chrome__browser__main__extra__parts__linux.cc
+++ b/www/chromium/files/patch-chrome_browser_chrome__browser__main__extra__parts__linux.cc
@@ -1,9 +1,9 @@
---- chrome/browser/chrome_browser_main_extra_parts_linux.cc.orig 2024-04-19 13:02:56 UTC
+--- chrome/browser/chrome_browser_main_extra_parts_linux.cc.orig 2024-05-01 07:03:57 UTC
+++ chrome/browser/chrome_browser_main_extra_parts_linux.cc
-@@ -169,7 +169,7 @@ ChromeBrowserMainExtraPartsLinux::ChromeBrowserMainExt
- ChromeBrowserMainExtraPartsLinux::~ChromeBrowserMainExtraPartsLinux() = default;
+@@ -175,7 +175,7 @@ void ChromeBrowserMainExtraPartsLinux::PostBrowserStar
- void ChromeBrowserMainExtraPartsLinux::PreEarlyInitialization() {
+ // static
+ void ChromeBrowserMainExtraPartsLinux::InitOzonePlatformHint() {
-#if BUILDFLAG(IS_LINUX)
+#if BUILDFLAG(IS_LINUX) || BUILDFLAG(IS_BSD)
// On the desktop, we fix the platform name if necessary.
diff --git a/www/chromium/files/patch-chrome_browser_prefs_browser__prefs.cc b/www/chromium/files/patch-chrome_browser_prefs_browser__prefs.cc
index 5631409a268a..de849528cb42 100644
--- a/www/chromium/files/patch-chrome_browser_prefs_browser__prefs.cc
+++ b/www/chromium/files/patch-chrome_browser_prefs_browser__prefs.cc
@@ -1,4 +1,4 @@
---- chrome/browser/prefs/browser_prefs.cc.orig 2024-04-19 13:02:56 UTC
+--- chrome/browser/prefs/browser_prefs.cc.orig 2024-05-01 07:03:57 UTC
+++ chrome/browser/prefs/browser_prefs.cc
@@ -488,18 +488,18 @@
#endif
@@ -31,7 +31,7 @@
#include "ui/color/system_theme.h"
#endif
-@@ -1715,7 +1715,7 @@ void RegisterLocalState(PrefRegistrySimple* registry)
+@@ -1722,7 +1722,7 @@ void RegisterLocalState(PrefRegistrySimple* registry)
registry->RegisterBooleanPref(prefs::kOopPrintDriversAllowedByPolicy, true);
#endif
@@ -40,7 +40,7 @@
registry->RegisterBooleanPref(prefs::kChromeForTestingAllowed, true);
#endif
-@@ -2060,12 +2060,12 @@ void RegisterProfilePrefs(user_prefs::PrefRegistrySync
+@@ -2067,12 +2067,12 @@ void RegisterProfilePrefs(user_prefs::PrefRegistrySync
#endif
#if BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX) || \
diff --git a/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5 b/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
index e8b0df090779..f1773706aebd 100644
--- a/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
+++ b/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
@@ -1,6 +1,6 @@
---- third_party/blink/renderer/platform/runtime_enabled_features.json5.orig 2024-04-19 13:02:56 UTC
+--- third_party/blink/renderer/platform/runtime_enabled_features.json5.orig 2024-05-01 07:03:57 UTC
+++ third_party/blink/renderer/platform/runtime_enabled_features.json5
-@@ -321,7 +321,7 @@
+@@ -313,7 +313,7 @@
name: "AppTitle",
status: "experimental",
origin_trial_feature_name: "AppTitle",
@@ -9,7 +9,7 @@
base_feature: "WebAppEnableAppTitle",
},
{
-@@ -1969,7 +1969,7 @@
+@@ -1961,7 +1961,7 @@
base_feature_status: "enabled",
copied_from_base_feature_if: "overridden",
origin_trial_feature_name: "FullscreenPopupWindows",
@@ -18,7 +18,7 @@
},
{
name: "GamepadButtonAxisEvents",
-@@ -2890,7 +2890,7 @@
+@@ -2882,7 +2882,7 @@
name: "PaymentHandlerMinimalHeaderUX",
origin_trial_feature_name: "PaymentHandlerMinimalHeaderUX",
origin_trial_allows_third_party: true,
@@ -27,7 +27,7 @@
status: "stable",
},
{
-@@ -3082,7 +3082,7 @@
+@@ -3074,7 +3074,7 @@
{
name: "PrivateNetworkAccessPermissionPrompt",
origin_trial_feature_name: "PrivateNetworkAccessPermissionPrompt",
@@ -36,7 +36,7 @@
status: "stable",
public: true,
base_feature: "none",
-@@ -3950,7 +3950,7 @@
+@@ -3942,7 +3942,7 @@
name: "UnrestrictedSharedArrayBuffer",
base_feature: "none",
origin_trial_feature_name: "UnrestrictedSharedArrayBuffer",
@@ -45,7 +45,7 @@
},
// Enables using policy-controlled feature "usb-unrestricted" to allow
// isolated context to access protected USB interface classes and to
-@@ -4110,7 +4110,7 @@
+@@ -4102,7 +4102,7 @@
{
name: "WebAppScopeExtensions",
origin_trial_feature_name: "WebAppScopeExtensions",
diff --git a/www/chromium/files/patch-ui_base_ui__base__features.cc b/www/chromium/files/patch-ui_base_ui__base__features.cc
index d0da3c97ac93..2a6cf5fba425 100644
--- a/www/chromium/files/patch-ui_base_ui__base__features.cc
+++ b/www/chromium/files/patch-ui_base_ui__base__features.cc
@@ -1,6 +1,6 @@
---- ui/base/ui_base_features.cc.orig 2024-04-19 13:02:56 UTC
+--- ui/base/ui_base_features.cc.orig 2024-05-01 07:03:57 UTC
+++ ui/base/ui_base_features.cc
-@@ -227,7 +227,7 @@ BASE_FEATURE(kExperimentalFlingAnimation,
+@@ -228,7 +228,7 @@ BASE_FEATURE(kExperimentalFlingAnimation,
"ExperimentalFlingAnimation",
// TODO(crbug.com/1052397): Revisit the macro expression once build flag switch
// of lacros-chrome is complete.
@@ -9,7 +9,7 @@
(BUILDFLAG(IS_LINUX) && !BUILDFLAG(IS_CHROMEOS_ASH) && \
!BUILDFLAG(IS_CHROMEOS_LACROS))
base::FEATURE_ENABLED_BY_DEFAULT
-@@ -326,7 +326,7 @@ bool IsForcedColorsEnabled() {
+@@ -327,7 +327,7 @@ bool IsForcedColorsEnabled() {
BASE_FEATURE(kEyeDropper,
"EyeDropper",
#if BUILDFLAG(IS_WIN) || BUILDFLAG(IS_MAC) || BUILDFLAG(IS_LINUX) || \