aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBradley T. Hughes <bhughes@FreeBSD.org>2021-04-20 18:21:24 +0000
committerBradley T. Hughes <bhughes@FreeBSD.org>2021-04-20 21:29:53 +0000
commitbc3d0937d0d2cc4a2e80334f5391a2d87458943e (patch)
treea132ebabe853a3a01396f4064260ea3d38d54553 /www
parent4eec712dfdae23fb9d6fd10a047a602039b321c9 (diff)
downloadports-bc3d0937d0d2cc4a2e80334f5391a2d87458943e.tar.gz
ports-bc3d0937d0d2cc4a2e80334f5391a2d87458943e.zip
www/node: Update 15.14.0_1 -> 16.0.0
Upgrade to the latest major vesrion of Node.js. Regenerate patches since some have been adopted upstream, while others needed refreshing. https://nodejs.org/en/blog/release/v16.0.0/ Sponsored by: Miles AS
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile5
-rw-r--r--www/node/distinfo6
-rw-r--r--www/node/files/patch-deps_v8_src_libsampler_sampler.cc4
-rw-r--r--www/node/files/patch-deps_v8_src_objects_js-list-format.cc83
-rw-r--r--www/node/pkg-plist38
5 files changed, 7 insertions, 129 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index beae171a295d..442b80d9c18b 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -1,7 +1,6 @@
PORTNAME= node
DISTVERSIONPREFIX= v
-DISTVERSION= 15.14.0
-PORTREVISION= 1
+DISTVERSION= 16.0.0
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${DISTVERSION}/
@@ -41,7 +40,7 @@ BUNDLED_SSL_CONFIGURE_OFF= --shared-openssl --openssl-use-def-ca-store
BUNDLED_SSL_RUN_DEPENDS_OFF= ca_root_nss>=0:security/ca_root_nss
NLS_CONFIGURE_ON= --with-intl=system-icu
-NLS_BUILD_DEPENDS= icu>=68.2:devel/icu
+NLS_BUILD_DEPENDS= icu>=69.1:devel/icu
NLS_LIB_DEPENDS= libicui18n.so:devel/icu
DTRACE_CONFIGURE_ON= --with-dtrace
diff --git a/www/node/distinfo b/www/node/distinfo
index 4d05a657adbf..58d89aa9b66e 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617773019
-SHA256 (node-v15.14.0.tar.gz) = f3a35c1b29b58846575085fdee7774d78b75ff4cf1e52572afce7f38685b159a
-SIZE (node-v15.14.0.tar.gz) = 63225027
+TIMESTAMP = 1618941785
+SHA256 (node-v16.0.0.tar.gz) = ef4928ed381dcb8f5eca9c521b3ffa4a384c75cc76656999e16f5d1c171d8e7b
+SIZE (node-v16.0.0.tar.gz) = 64007010
diff --git a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
index 2839eafa428d..8a0fbeeda3d6 100644
--- a/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
+++ b/www/node/files/patch-deps_v8_src_libsampler_sampler.cc
@@ -1,6 +1,6 @@
---- deps/v8/src/libsampler/sampler.cc.orig 2020-10-20 11:49:50 UTC
+--- deps/v8/src/libsampler/sampler.cc.orig 2021-04-20 11:30:13 UTC
+++ deps/v8/src/libsampler/sampler.cc
-@@ -489,6 +489,10 @@ void SignalHandler::FillRegisterState(void* context, R
+@@ -488,6 +488,10 @@ void SignalHandler::FillRegisterState(void* context, R
state->pc = reinterpret_cast<void*>(mcontext.__gregs[_REG_PC]);
state->sp = reinterpret_cast<void*>(mcontext.__gregs[_REG_SP]);
state->fp = reinterpret_cast<void*>(mcontext.__gregs[_REG_FP]);
diff --git a/www/node/files/patch-deps_v8_src_objects_js-list-format.cc b/www/node/files/patch-deps_v8_src_objects_js-list-format.cc
deleted file mode 100644
index f5e093480b87..000000000000
--- a/www/node/files/patch-deps_v8_src_objects_js-list-format.cc
+++ /dev/null
@@ -1,83 +0,0 @@
-https://github.com/v8/v8/commit/035c305ce7761f51328b45f1bd83e26aef267c9d
-
-../deps/v8/src/objects/js-list-format.cc:145:55: error: 'createInstance' is a private member of 'icu::ListFormatter'
- icu::ListFormatter* formatter = icu::ListFormatter::createInstance(
- ~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~
-/usr/local/include/unicode/listformatter.h:267:27: note: declared private here
- static ListFormatter* createInstance(const Locale& locale, const char* style, UErrorCode& errorCode);
- ^
-
---- deps/v8/src/objects/js-list-format.cc.orig 2021-04-06 20:39:46 UTC
-+++ deps/v8/src/objects/js-list-format.cc
-@@ -29,46 +29,27 @@ namespace v8 {
- namespace internal {
-
- namespace {
--const char* kStandard = "standard";
--const char* kOr = "or";
--const char* kUnit = "unit";
--const char* kStandardShort = "standard-short";
--const char* kOrShort = "or-short";
--const char* kUnitShort = "unit-short";
--const char* kStandardNarrow = "standard-narrow";
--const char* kOrNarrow = "or-narrow";
--const char* kUnitNarrow = "unit-narrow";
-
--const char* GetIcuStyleString(JSListFormat::Style style,
-- JSListFormat::Type type) {
-+UListFormatterWidth GetIcuWidth(JSListFormat::Style style) {
-+ switch (style) {
-+ case JSListFormat::Style::LONG:
-+ return ULISTFMT_WIDTH_WIDE;
-+ case JSListFormat::Style::SHORT:
-+ return ULISTFMT_WIDTH_SHORT;
-+ case JSListFormat::Style::NARROW:
-+ return ULISTFMT_WIDTH_NARROW;
-+ }
-+ UNREACHABLE();
-+}
-+
-+UListFormatterType GetIcuType(JSListFormat::Type type) {
- switch (type) {
- case JSListFormat::Type::CONJUNCTION:
-- switch (style) {
-- case JSListFormat::Style::LONG:
-- return kStandard;
-- case JSListFormat::Style::SHORT:
-- return kStandardShort;
-- case JSListFormat::Style::NARROW:
-- return kStandardNarrow;
-- }
-+ return ULISTFMT_TYPE_AND;
- case JSListFormat::Type::DISJUNCTION:
-- switch (style) {
-- case JSListFormat::Style::LONG:
-- return kOr;
-- case JSListFormat::Style::SHORT:
-- return kOrShort;
-- case JSListFormat::Style::NARROW:
-- return kOrNarrow;
-- }
-+ return ULISTFMT_TYPE_OR;
- case JSListFormat::Type::UNIT:
-- switch (style) {
-- case JSListFormat::Style::LONG:
-- return kUnit;
-- case JSListFormat::Style::SHORT:
-- return kUnitShort;
-- case JSListFormat::Style::NARROW:
-- return kUnitNarrow;
-- }
-+ return ULISTFMT_TYPE_UNITS;
- }
- UNREACHABLE();
- }
-@@ -143,7 +124,7 @@ MaybeHandle<JSListFormat> JSListFormat::New(Isolate* i
- icu::Locale icu_locale = r.icu_locale;
- UErrorCode status = U_ZERO_ERROR;
- icu::ListFormatter* formatter = icu::ListFormatter::createInstance(
-- icu_locale, GetIcuStyleString(style_enum, type_enum), status);
-+ icu_locale, GetIcuType(type_enum), GetIcuWidth(style_enum), status);
- if (U_FAILURE(status) || formatter == nullptr) {
- delete formatter;
- THROW_NEW_ERROR(isolate, NewRangeError(MessageTemplate::kIcuError),
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index 5e992a3f1c4a..3a7ebbf25252 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -1,39 +1,9 @@
bin/node
include/node/common.gypi
include/node/config.gypi
-include/node/cppgc/allocation.h
include/node/cppgc/common.h
-include/node/cppgc/custom-space.h
-include/node/cppgc/default-platform.h
-include/node/cppgc/garbage-collected.h
-include/node/cppgc/heap.h
-include/node/cppgc/internal/api-constants.h
-include/node/cppgc/internal/atomic-entry-flag.h
-include/node/cppgc/internal/caged-heap-local-data.h
-include/node/cppgc/internal/compiler-specific.h
-include/node/cppgc/internal/finalizer-trait.h
-include/node/cppgc/internal/gc-info.h
-include/node/cppgc/internal/logging.h
-include/node/cppgc/internal/persistent-node.h
-include/node/cppgc/internal/pointer-policies.h
-include/node/cppgc/internal/prefinalizer-handler.h
-include/node/cppgc/internal/process-heap.h
-include/node/cppgc/internal/write-barrier.h
-include/node/cppgc/liveness-broker.h
-include/node/cppgc/macros.h
-include/node/cppgc/member.h
-include/node/cppgc/persistent.h
-include/node/cppgc/platform.h
-include/node/cppgc/prefinalizer.h
-include/node/cppgc/source-location.h
-include/node/cppgc/trace-trait.h
-include/node/cppgc/type-traits.h
-include/node/cppgc/visitor.h
include/node/js_native_api.h
include/node/js_native_api_types.h
-include/node/libplatform/libplatform.h
-include/node/libplatform/libplatform-export.h
-include/node/libplatform/v8-tracing.h
include/node/node.h
include/node/node_api.h
include/node/node_api_types.h
@@ -487,18 +457,10 @@ include/node/node_version.h
%%BUNDLED_SSL%%include/node/openssl/x509err.h
%%BUNDLED_SSL%%include/node/openssl/x509v3.h
%%BUNDLED_SSL%%include/node/openssl/x509v3err.h
-include/node/v8-cppgc.h
-include/node/v8-fast-api-calls.h
include/node/v8-internal.h
-include/node/v8-metrics.h
include/node/v8-platform.h
include/node/v8-profiler.h
-include/node/v8-util.h
-include/node/v8-value-serializer-version.h
include/node/v8-version.h
-include/node/v8-version-string.h
-include/node/v8-wasm-trap-handler-posix.h
-include/node/v8-wasm-trap-handler-win.h
include/node/v8.h
include/node/v8config.h
%%DTRACE%%lib/dtrace/node.d