aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-27 23:33:32 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-27 23:33:32 +0000
commitc180ca8b315fc177ad282cbbaf80b19db248fa54 (patch)
tree9a5546ee99c013e815880c9c51441c793bd633e5 /www
parent0e20e74388655a7fdc8469a24a27dfa9307eaeff (diff)
downloadports-c180ca8b315fc177ad282cbbaf80b19db248fa54.tar.gz
ports-c180ca8b315fc177ad282cbbaf80b19db248fa54.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-aioh2/Makefile23
-rw-r--r--www/py-aioh2/distinfo3
-rw-r--r--www/py-aioh2/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5de6186ef15e..08f657d0502e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1497,6 +1497,7 @@
SUBDIR += py-WebError
SUBDIR += py-WebFlash
SUBDIR += py-WebTest
+ SUBDIR += py-aioh2
SUBDIR += py-aiohttp
SUBDIR += py-aiohttp-wsgi
SUBDIR += py-albatross
diff --git a/www/py-aioh2/Makefile b/www/py-aioh2/Makefile
new file mode 100644
index 000000000000..1bafa221c27c
--- /dev/null
+++ b/www/py-aioh2/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aioh2
+PORTVERSION= 0.2.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= HTTP/2 implementation with hyper-h2 on Python 3 asyncio
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}h2>=3:www/py-h2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}priority>=1.3.0:www/py-priority@${PY_FLAVOR}
+
+NO_ARCH= yes
+USE_PYTHON= autoplist distutils
+USES= python:3.4+
+
+.include <bsd.port.mk>
diff --git a/www/py-aioh2/distinfo b/www/py-aioh2/distinfo
new file mode 100644
index 000000000000..edd537732cdc
--- /dev/null
+++ b/www/py-aioh2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530050618
+SHA256 (aioh2-0.2.2.tar.gz) = 8da7b49261d9bbfe71b3b9e994eca1fcc53890c7868fc96eb6b9027e3f27220e
+SIZE (aioh2-0.2.2.tar.gz) = 24585
diff --git a/www/py-aioh2/pkg-descr b/www/py-aioh2/pkg-descr
new file mode 100644
index 000000000000..773768135cef
--- /dev/null
+++ b/www/py-aioh2/pkg-descr
@@ -0,0 +1,8 @@
+aioh2 is an HTTP/2 implementation with hyper-h2 on Python 3 asyncio.
+
+Features:
+- Asynchronous HTTP/2 client and server
+- Multiplexing streams of data with managed flow and priority control
+- Optional tickless health check
+
+WWW: https://github.com/decentfox/aioh2