aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-08-15 21:03:05 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-08-15 21:03:05 +0000
commitc82ca9149fb58fe854a1c4505c146dfc45ae0a99 (patch)
treec50138540fdfd85a1eb1c646c63f7488c0a4539c /www
parent1f8bb4dc02bb2efba4c0c8e5eb38fd51c4f383cf (diff)
downloadports-c82ca9149fb58fe854a1c4505c146dfc45ae0a99.tar.gz
ports-c82ca9149fb58fe854a1c4505c146dfc45ae0a99.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/midori/Makefile25
-rw-r--r--www/midori/distinfo4
-rw-r--r--www/midori/files/patch-config__search (renamed from www/midori/files/patch-data_search)9
-rw-r--r--www/midori/files/patch-wscript55
-rw-r--r--www/midori/pkg-plist20
5 files changed, 79 insertions, 34 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 9a662b5b5b21..90281a781a77 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.4
-PORTREVISION= 1
+PORTVERSION= 0.5.5
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
@@ -19,7 +18,9 @@ BUILD_DEPENDS= rsvg-convert:${PORTSDIR}/graphics/librsvg2 \
valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= webkitgtk-1:${PORTSDIR}/www/webkit-gtk2 \
sqlite3:${PORTSDIR}/databases/sqlite3 \
- notify:${PORTSDIR}/devel/libnotify
+ notify:${PORTSDIR}/devel/libnotify \
+ soup-gnome-2:${PORTSDIR}/devel/libsoup-gnome \
+ execinfo:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
CPPFLAGS+= -I${LOCALBASE}/include
@@ -29,7 +30,9 @@ CONFIGURE_ARGS+=--enable-addons \
--disable-gtk3 \
--jobs=${MAKE_JOBS_NUMBER}
+WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
HAS_CONFIGURE= yes
+USE_PYTHON= -2.7
USE_PYTHON_BUILD= yes
USE_BZIP2= yes
USE_GNOME= glib20 gtk20 intltool libxml2
@@ -40,10 +43,9 @@ USES= desktop-file-utils pkgconfig
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= APIDOCS NLS UNIQUE ZEITGEIST
+OPTIONS_DEFINE= DOCS NLS UNIQUE ZEITGEIST
OPTIONS_DEFAULT= NLS UNIQUE
-APIDOCS_DESC= Build API documentation
UNIQUE_DESC= Single instance support
ZEITGEIST_DESC= User logs activities
@@ -60,7 +62,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if ${PORT_OPTIONS:MAPIDOCS}
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= gtkdoc-scan:${PORTSDIR}/textproc/gtk-doc
CONFIGURE_ARGS+=--enable-apidocs
PLIST_SUB+= APIDOCS=""
@@ -84,11 +86,12 @@ CONFIGURE_ARGS+=--disable-zeitgeist
.endif
post-install:
-.if ${PORT_OPTIONS:MAPIDOCS}
- ${MKDIR} ${DOCSDIR}/api/katze/html
- ${MKDIR} ${DOCSDIR}/api/midori/html
- (cd ${WRKSRC}/_build/docs/api/katze/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/katze/html)
- (cd ${WRKSRC}/_build/docs/api/midori/html && ${COPYTREE_SHARE} \* ${DOCSDIR}/api/midori/html)
+.if ${PORT_OPTIONS:MDOCS}
+.for dir in katze midori
+ @${MKDIR} ${DOCSDIR}/api/${dir}/html
+ @cd ${WRKSRC}/_build/docs/api/${dir}/html && \
+ ${COPYTREE_SHARE} . ${DOCSDIR}/api/${dir}/html
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/www/midori/distinfo b/www/midori/distinfo
index 965b2239d887..4fc77a4b51b4 100644
--- a/www/midori/distinfo
+++ b/www/midori/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/midori_0.5.4_all_.tar.bz2) = d4ee77f3dd9bf2c07cea7674d533e77960e9346bd8b5482582ccb3cdaf182022
-SIZE (xfce4/midori_0.5.4_all_.tar.bz2) = 1229169
+SHA256 (xfce4/midori_0.5.5_all_.tar.bz2) = ca69382a285222a86028abebd73fed1976735883027ff0adc094b627789bbd62
+SIZE (xfce4/midori_0.5.5_all_.tar.bz2) = 1092309
diff --git a/www/midori/files/patch-data_search b/www/midori/files/patch-config__search
index 4fafcf236f60..04bb632fa822 100644
--- a/www/midori/files/patch-data_search
+++ b/www/midori/files/patch-config__search
@@ -1,14 +1,13 @@
---- data/search.orig 2010-05-26 12:31:56.000000000 +0200
-+++ data/search 2010-05-26 12:34:03.000000000 +0200
-@@ -6,6 +6,13 @@
- icon=
+--- ./config/search.orig 2013-08-14 18:32:02.000000000 +0000
++++ ./config/search 2013-08-15 10:17:00.000000000 +0000
+@@ -16,6 +16,12 @@
+ uri=http://www.google.com/search?q=%s
token=g
+[FreshPorts]
+name=FreshPorts
+text=The changes made to the FreeBSD ports tree
+uri=http://www.freshports.org/search.php?query=%s
-+icon=
+token=fp
+
[Wikipedia]
diff --git a/www/midori/files/patch-wscript b/www/midori/files/patch-wscript
index da84b9e23682..a2f2f5a5f99b 100644
--- a/www/midori/files/patch-wscript
+++ b/www/midori/files/patch-wscript
@@ -1,29 +1,62 @@
-Fix PACKAGE_VERSION in gtk_about_dialog widget.
-https://bugs.launchpad.net/midori/+bug/1200903
+- Fix PACKAGE_VERSION in gtk_about_dialog_widget (bug #1200903).
+- Check if execinfo.h header is found (bug #1212761).
+- Add test to avoid installing .orig files (for config/search).
---- ./wscript.orig 2013-07-15 22:38:28.000000000 +0000
-+++ ./wscript 2013-07-21 16:02:48.000000000 +0000
-@@ -29,7 +29,7 @@
+--- ./wscript.orig 2013-08-14 18:32:02.000000000 +0000
++++ ./wscript 2013-08-15 19:05:48.000000000 +0000
+@@ -29,7 +29,6 @@
APPNAME = 'midori'
- VERSION = VERSION_FULL = '0.5.4'
+ VERSION = VERSION_FULL = '0.5.5'
-VERSION_SUFFIX = ' (%s)' % VERSION
-+#VERSION_SUFFIX = ' (%s)' % VERSION
try:
if os.path.isdir ('.git'):
-@@ -44,8 +44,12 @@
+@@ -44,8 +43,10 @@
folder = os.getcwd ()
if VERSION in folder:
VERSION_FULL = os.path.basename (folder)
- if VERSION in VERSION_FULL:
- VERSION_SUFFIX = VERSION_FULL.replace (VERSION, '')
-+ if VERSION_FULL.endswith ('_all_'):
-+ VERSION_FULL = VERSION_FULL.replace('_all_', '')
+ if APPNAME in VERSION_FULL:
-+ VERSION_FULL = VERSION_FULL.replace(APPNAME, '')[1:]
++ VERSION_FULL = VERSION_FULL.replace (APPNAME, '')[1:]
+
+ VERSION_SUFFIX = ' (%s)' % VERSION_FULL
except:
pass
+@@ -234,6 +235,8 @@
+ conf.check (header_name='X11/extensions/scrnsaver.h',
+ includes='/usr/X11R6/include', mandatory=False)
+ conf.check (lib='Xss', libpath='/usr/X11R6/lib', mandatory=False)
++ # Check if execinfo.h header is found
++ conf.check (header_name='execinfo.h', mandatory=True)
+
+ have_gtk3 = option_enabled ('gtk3') or option_enabled ('webkit2') or option_enabled ('granite')
+ if have_gtk3:
+@@ -530,15 +533,16 @@
+
+ for config_file in os.listdir ('config'):
+ dest = '${SYSCONFDIR}/xdg/' + APPNAME
+- if (os.path.isdir ('config/' + config_file)):
+- dest += '/' + config_file
+- for child in os.listdir ('config/' + config_file):
+- if (os.path.isdir ('config/' + config_file + '/' + child)):
+- dest += '/' + child
+- child += '/*'
+- bld.install_files (dest, 'config/' + config_file + '/' + child)
+- continue
+- bld.install_files (dest, 'config/' + config_file)
++ if not config_file.endswith('.orig'):
++ if (os.path.isdir ('config/' + config_file)):
++ dest += '/' + config_file
++ for child in os.listdir ('config/' + config_file):
++ if (os.path.isdir ('config/' + config_file + '/' + child)):
++ dest += '/' + child
++ child += '/*'
++ bld.install_files (dest, 'config/' + config_file + '/' + child)
++ continue
++ bld.install_files (dest, 'config/' + config_file)
+
+ if Options.commands['check'] or bld.env['tests']:
+ bld.add_subdirs ('tests')
diff --git a/www/midori/pkg-plist b/www/midori/pkg-plist
index f0a3592f0963..2b047058c1fa 100644
--- a/www/midori/pkg-plist
+++ b/www/midori/pkg-plist
@@ -3,6 +3,7 @@ etc/xdg/midori/extensions/adblock/config
etc/xdg/midori/search
include/midori-%%VERSION%%/extensions/apps.h
include/midori-%%VERSION%%/extensions/delayed-load.h
+include/midori-%%VERSION%%/extensions/devpet.h
include/midori-%%VERSION%%/extensions/external-download-manager.h
include/midori-%%VERSION%%/extensions/history-list.h
include/midori-%%VERSION%%/extensions/nsplugin-manager.h
@@ -15,11 +16,13 @@ lib/midori/libcookie-manager.so
lib/midori/libcookie-permissions.so
lib/midori/libcopy-tabs.so
lib/midori/libdelayed-load.so
+lib/midori/libdevpet.so
lib/midori/libexternal-download-manager.so
lib/midori/libfeed-panel.so
lib/midori/libformhistory.so
lib/midori/libhistory-list.so
lib/midori/libmouse-gestures.so
+lib/midori/libnojs.so
lib/midori/libnsplugin-manager.so
lib/midori/libshortcuts.so
lib/midori/libstatus-clock.so
@@ -37,21 +40,19 @@ share/applications/midori-private.desktop
%%DOCSDIR%%/README
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/api-index-full.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/ch01.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/deprecated-api-index.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/home.png
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/index.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/index.sgml
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-KatzeItem.html
+%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-KatzeCellRendererComboBoxText.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-KatzePreferences.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-gtk3-compat.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-array.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-arrayaction.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-http-auth.html
-%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-http-cookies.html
-%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-http-cookies-sqlite.html
-%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-net.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-throbber.html
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze-katze-utils.html
-%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze.devhelp
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/katze.devhelp2
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/left.png
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/right.png
@@ -59,6 +60,7 @@ share/applications/midori-private.desktop
%%APIDOCS%%%%DOCSDIR%%/api/katze/html/up.png
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/api-index-full.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/ch01.html
+%%APIDOCS%%%%DOCSDIR%%/api/midori/html/deprecated-api-index.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/home.png
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/index.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/index.sgml
@@ -83,7 +85,6 @@ share/applications/midori-private.desktop
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-midori.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-socket.html
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori-sokoke.html
-%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori.devhelp
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/midori.devhelp2
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/right.png
%%APIDOCS%%%%DOCSDIR%%/api/midori/html/style.css
@@ -119,6 +120,8 @@ share/icons/hicolor/scalable/status/internet-news-reader.svg
%%NLS%%share/locale/da/LC_MESSAGES/midori.mo
%%NLS%%share/locale/de/LC_MESSAGES/midori.mo
%%NLS%%share/locale/el/LC_MESSAGES/midori.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/midori.mo
+%%NLS%%share/locale/en_CA/LC_MESSAGES/midori.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/midori.mo
%%NLS%%share/locale/eo/LC_MESSAGES/midori.mo
%%NLS%%share/locale/es/LC_MESSAGES/midori.mo
@@ -171,11 +174,17 @@ share/icons/hicolor/scalable/status/internet-news-reader.svg
%%DATADIR%%/res/error.html
%%DATADIR%%/res/gtk3.css
%%DATADIR%%/res/logo-shade.png
+%%DATADIR%%/res/logo-shade.svg
+%%DATADIR%%/res/nojs/nojs-statusicon-allowed.png
+%%DATADIR%%/res/nojs/nojs-statusicon-denied.png
+%%DATADIR%%/res/nojs/nojs-statusicon-mixed.png
%%DATADIR%%/res/speeddial-head.html
share/vala/vapi/apps.deps
share/vala/vapi/apps.vapi
share/vala/vapi/delayed-load.deps
share/vala/vapi/delayed-load.vapi
+share/vala/vapi/devpet.deps
+share/vala/vapi/devpet.vapi
share/vala/vapi/external-download-manager.deps
share/vala/vapi/external-download-manager.vapi
share/vala/vapi/history-list.deps
@@ -186,6 +195,7 @@ share/vala/vapi/transfers.deps
share/vala/vapi/transfers.vapi
@dirrmtry share/vala/vapi
@dirrmtry share/vala
+@dirrm %%DATADIR%%/res/nojs
@dirrm %%DATADIR%%/res
@dirrm %%DATADIR%%
%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES