aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2003-02-06 09:13:17 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2003-02-06 09:13:17 +0000
commitcaddaba4f4d73cba42a521cc4ecd5c202a7fe349 (patch)
treeddacdb7c644815a17228a87f14192b8911b95c4a /www
parentefaf7def87387c095b8b26548337c1e8799bcc41 (diff)
downloadports-caddaba4f4d73cba42a521cc4ecd5c202a7fe349.tar.gz
ports-caddaba4f4d73cba42a521cc4ecd5c202a7fe349.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/mod_php3/Makefile8
-rw-r--r--www/mod_php3/scripts/configure.php6
2 files changed, 14 insertions, 0 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 1fa644893745..3f3428d5d5f3 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -103,4 +103,12 @@ post-clean:
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+# XXX:
+# Has to be kept in sync with the defaults in configure.php
+.ifndef(WITHOUT_MYSQL)
+.ifmake describe
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+.endif
+.endif
+
.include <bsd.port.mk>
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index f46e1ffa0547..737e0381ab7f 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -92,6 +92,7 @@ while [ "$1" ]; do
\"MySQL\")
echo "LIB_DEPENDS+= mysqlclient.10:\${PORTSDIR}/databases/mysql323-client"
echo "CONFIGURE_ARGS+=--with-mysql=\${PREFIX}"
+ MYSQL=1
;;
\"PostgreSQL\")
echo "POSTGRESQL_PORT?= databases/postgresql7"
@@ -179,3 +180,8 @@ done
if [ "${LIBS}" ]; then
echo "CONFIGURE_ENV+= LIBS='${LIBS}'"
fi
+
+if [ -z "${MYSQL}" ]; then
+ echo "WITHOUT_MYSQL= 1"
+fi
+