aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-02-20 18:27:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-02-20 18:27:57 +0000
commitd914593af21cc76a96c765cda8bc89ba9f79365c (patch)
tree6113a87e681a365fbc87e50fdb59da3811c718fe /www
parent8c28e6b7935f448071999538fbbc1fd97893fddc (diff)
Notes
Diffstat (limited to 'www')
-rw-r--r--www/tidy-html5/Makefile3
-rw-r--r--www/tidy-html5/files/patch-CMakeLists.txt10
-rw-r--r--www/tidy-html5/files/patch-tidy.pc.cmake.in9
3 files changed, 16 insertions, 6 deletions
diff --git a/www/tidy-html5/Makefile b/www/tidy-html5/Makefile
index 917ed32e2fa4..1acecb17004d 100644
--- a/www/tidy-html5/Makefile
+++ b/www/tidy-html5/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tidy-html5
PORTVERSION= 5.6.0
+PORTREVISION= 1
CATEGORIES= www
MAINTAINER= thierry@FreeBSD.org
@@ -14,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/README/LICENSE.md
USE_GITHUB= yes
GH_ACCOUNT= htacg
-USES= cmake
+USES= cmake gnome
USE_GNOME= libxslt
USE_LDCONFIG= yes
diff --git a/www/tidy-html5/files/patch-CMakeLists.txt b/www/tidy-html5/files/patch-CMakeLists.txt
index e36db9a2d173..711ff088cc50 100644
--- a/www/tidy-html5/files/patch-CMakeLists.txt
+++ b/www/tidy-html5/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt.orig 2015-11-18 19:02:54 UTC
+--- CMakeLists.txt.orig 2017-11-25 13:54:41 UTC
+++ CMakeLists.txt
-@@ -42,7 +42,7 @@ option( BUILD_SHARED_LIB "Set OFF to NOT
- option( BUILD_TAB2SPACE "Set ON to build utility app, tab2space" OFF )
- option( BUILD_SAMPLE_CODE "Set ON to build the sample code" OFF )
+@@ -102,7 +102,7 @@ option( TIDY_COMPAT_HEADERS "Set ON to include compati
+ # Allow building with non-default man page directory.
+ #------------------------------------------------------------------------
if (NOT MAN_INSTALL_DIR)
- set(MAN_INSTALL_DIR share/man/man1)
+ set(MAN_INSTALL_DIR man/man1)
endif ()
- option( BUILD_DOCUMENTATION "Set ON to build the documentation" OFF )
+
diff --git a/www/tidy-html5/files/patch-tidy.pc.cmake.in b/www/tidy-html5/files/patch-tidy.pc.cmake.in
new file mode 100644
index 000000000000..6ea6e1437f6c
--- /dev/null
+++ b/www/tidy-html5/files/patch-tidy.pc.cmake.in
@@ -0,0 +1,9 @@
+--- tidy.pc.cmake.in.orig 2017-11-25 13:54:41 UTC
++++ tidy.pc.cmake.in
+@@ -7,5 +7,5 @@ Name: @LIB_NAME@
+ Description: @LIBTIDY_DESCRIPTION@
+ URL: @LIBTIDY_URL@
+ Version: @LIBTIDY_VERSION@
+-Libs: -L${libdir} -l@LIB_NAME@
++Libs: -L${libdir} -l@LIB_NAME@5
+ Cflags: -I${includedir}