aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2009-03-25 10:39:14 +0000
committerLars Thegler <lth@FreeBSD.org>2009-03-25 10:39:14 +0000
commitd9442410936dc93641ed7c8e2e1f0a28a509e650 (patch)
treea80ed8d930fd3452101cd7819c000a05485f13ec /www
parentf657ff7d2cbb7d8618afa5851e49af0fcdd16f0b (diff)
downloadports-d9442410936dc93641ed7c8e2e1f0a28a509e650.tar.gz
ports-d9442410936dc93641ed7c8e2e1f0a28a509e650.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-POE-Filter-HTTP-Parser/Makefile26
-rw-r--r--www/p5-POE-Filter-HTTP-Parser/distinfo3
-rw-r--r--www/p5-POE-Filter-HTTP-Parser/pkg-descr5
-rw-r--r--www/p5-POE-Filter-HTTP-Parser/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 8992b59148b6..9ea0736a4d68 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -986,6 +986,7 @@
SUBDIR += p5-POE-Component-Server-HTTPServer
SUBDIR += p5-POE-Component-Server-SOAP
SUBDIR += p5-POE-Component-Server-SimpleHTTP
+ SUBDIR += p5-POE-Filter-HTTP-Parser
SUBDIR += p5-ParallelUA
SUBDIR += p5-Path-Class-URI
SUBDIR += p5-PodToHTML
diff --git a/www/p5-POE-Filter-HTTP-Parser/Makefile b/www/p5-POE-Filter-HTTP-Parser/Makefile
new file mode 100644
index 000000000000..d4619c8a9b4f
--- /dev/null
+++ b/www/p5-POE-Filter-HTTP-Parser/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: POE-Filter-HTTP-Parser
+# Date created: 25 Mar 2009
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Filter-HTTP-Parser
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= A HTTP POE filter for HTTP clients or servers
+
+BUILD_DEPENDS= p5-POE>=1.003:${PORTSDIR}/devel/p5-POE \
+ p5-libwww>=0:${PORTSDIR}/www/libwww \
+ p5-HTTP-Parser>=0.04:${PORTSDIR}/www/p5-HTTP-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Filter::HTTP::Parser.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-POE-Filter-HTTP-Parser/distinfo b/www/p5-POE-Filter-HTTP-Parser/distinfo
new file mode 100644
index 000000000000..1f19f29b0b90
--- /dev/null
+++ b/www/p5-POE-Filter-HTTP-Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Filter-HTTP-Parser-0.08.tar.gz) = dc01ac5b578a5028a5d566a5b779f29c
+SHA256 (POE-Filter-HTTP-Parser-0.08.tar.gz) = 9df3fc21e18ea9ce78370b404becaaac58a6de1c56175d8ef8c774041bcfce49
+SIZE (POE-Filter-HTTP-Parser-0.08.tar.gz) = 25112
diff --git a/www/p5-POE-Filter-HTTP-Parser/pkg-descr b/www/p5-POE-Filter-HTTP-Parser/pkg-descr
new file mode 100644
index 000000000000..a16621db3ff2
--- /dev/null
+++ b/www/p5-POE-Filter-HTTP-Parser/pkg-descr
@@ -0,0 +1,5 @@
+POE::Filter::HTTP::Parser is a POE::Filter for HTTP which is based
+on HTTP::Parser. It can be used to easily create POE based HTTP
+servers or clients.
+
+WWW: http://search.cpan.org/dist/POE-Filter-HTTP-Parser/
diff --git a/www/p5-POE-Filter-HTTP-Parser/pkg-plist b/www/p5-POE-Filter-HTTP-Parser/pkg-plist
new file mode 100644
index 000000000000..b5b4e49fa476
--- /dev/null
+++ b/www/p5-POE-Filter-HTTP-Parser/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/POE/Filter/HTTP/Parser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/HTTP/Parser/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/HTTP/Parser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter/HTTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Filter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Filter/HTTP
+@dirrmtry %%SITE_PERL%%/POE/Filter
+@dirrmtry %%SITE_PERL%%/POE