aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2020-04-15 21:05:26 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2020-04-15 21:05:26 +0000
commite143c494dfdb5c887b4cbd2eb7fdd8b5b2bb525a (patch)
tree9e9bbe2e5640afdeebf0852df08490bb087b861b /www
parent507b586a4a2e15b124db95eebf3785dcfd61b11d (diff)
downloadports-e143c494dfdb5c887b4cbd2eb7fdd8b5b2bb525a.tar.gz
ports-e143c494dfdb5c887b4cbd2eb7fdd8b5b2bb525a.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/gitlab-ce/Makefile10
-rw-r--r--www/gitlab-ce/distinfo6
-rw-r--r--www/gitlab-ce/pkg-plist3
-rw-r--r--www/gitlab-workhorse/Makefile4
-rw-r--r--www/gitlab-workhorse/distinfo6
5 files changed, 16 insertions, 13 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index b47d92c4ceb8..e3c85164d140 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= gitlab-ce
-PORTVERSION= 12.9.2
-PORTREVISION= 1
+PORTVERSION= 12.9.3
+PORTREVISION= 0
CATEGORIES= www devel
MAINTAINER= mfechner@FreeBSD.org
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
# which makes maintaining this long list much easier!
MY_DEPENDS= git>=2.22.2:devel/git \
gitlab-shell>=12.0.0:devel/gitlab-shell \
- gitlab-workhorse>=8.25.1:www/gitlab-workhorse \
+ gitlab-workhorse>=8.25.2:www/gitlab-workhorse \
gitaly>=${PORTVERSION}:devel/gitaly \
gitlab-pages>=1.17.0:www/gitlab-pages \
redis>=3.2.12:databases/redis \
@@ -118,7 +118,7 @@ MY_DEPENDS= git>=2.22.2:devel/git \
rubygem-icalendar>=0:devel/rubygem-icalendar \
rubygem-diffy>=3.3<4:textproc/rubygem-diffy \
rubygem-diff_match_patch>=0.1.0<0.2.0:textproc/rubygem-diff_match_patch \
- rubygem-rack20>=2.0.7<2.1.0,3:www/rubygem-rack20 \
+ rubygem-rack20>=2.0.9<2.1.0,3:www/rubygem-rack20 \
rubygem-unicorn>=5.4.1<5.5.0:www/rubygem-unicorn \
rubygem-unicorn-worker-killer>=0.4.4<0.5.0:www/rubygem-unicorn-worker-killer \
rubygem-gitlab-puma>=4.3.3.g.2:www/rubygem-gitlab-puma \
@@ -245,7 +245,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
GL_PROJECT= gitlab-foss
# Find the here: https://gitlab.com/gitlab-org/gitlab-foss/-/tags
-GL_COMMIT= ac5568eb5d8cef68ced7c70729cc47f20d0a84b9
+GL_COMMIT= 571e31b8362a6903c97c5d42f2211151941a7cd3
USERS= git
GROUPS= git
diff --git a/www/gitlab-ce/distinfo b/www/gitlab-ce/distinfo
index 2f020bf7688f..32daf62eba8d 100644
--- a/www/gitlab-ce/distinfo
+++ b/www/gitlab-ce/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586165518
-SHA256 (gitlab-org-gitlab-foss-ac5568eb5d8cef68ced7c70729cc47f20d0a84b9_GL0.tar.gz) = d3d79744fab5dd216dcbe801c332922520aaccf50128a80fcca9dd799dd5f5fc
-SIZE (gitlab-org-gitlab-foss-ac5568eb5d8cef68ced7c70729cc47f20d0a84b9_GL0.tar.gz) = 89128913
+TIMESTAMP = 1586981336
+SHA256 (gitlab-org-gitlab-foss-571e31b8362a6903c97c5d42f2211151941a7cd3_GL0.tar.gz) = dc6448e3af0a77ef0c588c48e6db9f91a15f18bfb57fc336c2268dd44c22a575
+SIZE (gitlab-org-gitlab-foss-571e31b8362a6903c97c5d42f2211151941a7cd3_GL0.tar.gz) = 89130246
diff --git a/www/gitlab-ce/pkg-plist b/www/gitlab-ce/pkg-plist
index 3d5cf671e12a..79dd1f33d910 100644
--- a/www/gitlab-ce/pkg-plist
+++ b/www/gitlab-ce/pkg-plist
@@ -9003,6 +9003,7 @@
%%WWWDIR%%/db/post_migrate/20200203104214_services_remove_temporary_index_on_project_id.rb
%%WWWDIR%%/db/post_migrate/20200204113223_schedule_recalculate_project_authorizations.rb
%%WWWDIR%%/db/post_migrate/20200204113224_schedule_recalculate_project_authorizations_second_run.rb
+%%WWWDIR%%/db/post_migrate/20200204113225_schedule_recalculate_project_authorizations_third_run.rb
%%WWWDIR%%/db/post_migrate/20200206091544_migrate_create_commit_signature_worker_sidekiq_queue.rb
%%WWWDIR%%/db/post_migrate/20200206135203_udpate_index_ci_builds_on_name_for_security_products.rb
%%WWWDIR%%/db/post_migrate/20200207184023_add_temporary_index_to_promotion_notes.rb
@@ -20394,6 +20395,7 @@
%%WWWDIR%%/spec/migrations/schedule_populate_merge_request_assignees_table_spec.rb
%%WWWDIR%%/spec/migrations/schedule_recalculate_project_authorizations_second_run_spec.rb
%%WWWDIR%%/spec/migrations/schedule_recalculate_project_authorizations_spec.rb
+%%WWWDIR%%/spec/migrations/schedule_recalculate_project_authorizations_third_run_spec.rb
%%WWWDIR%%/spec/migrations/schedule_runners_token_encryption_spec.rb
%%WWWDIR%%/spec/migrations/schedule_set_confidential_note_events_on_webhooks_spec.rb
%%WWWDIR%%/spec/migrations/schedule_stages_index_migration_spec.rb
@@ -21868,6 +21870,7 @@
%%WWWDIR%%/spec/support/protected_branch_helpers.rb
%%WWWDIR%%/spec/support/protected_tag_helpers.rb
%%WWWDIR%%/spec/support/protected_tags/access_control_ce_shared_examples.rb
+%%WWWDIR%%/spec/support/rails/test_case_patch.rb
%%WWWDIR%%/spec/support/redis.rb
%%WWWDIR%%/spec/support/redis/redis_helpers.rb
%%WWWDIR%%/spec/support/redis/redis_shared_examples.rb
diff --git a/www/gitlab-workhorse/Makefile b/www/gitlab-workhorse/Makefile
index 13faccc0e085..96aee684e06f 100644
--- a/www/gitlab-workhorse/Makefile
+++ b/www/gitlab-workhorse/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gitlab-workhorse
-PORTVERSION= 8.25.1
+PORTVERSION= 8.25.2
PORTREVISION= 0
CATEGORIES= www
@@ -21,7 +21,7 @@ MAKE_ENV= GOFLAGS="${GO_BUILDFLAGS}"
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find the commit hash here: https://gitlab.com/gitlab-org/gitlab-workhorse/tags
-GL_COMMIT= fbdf2b231e3db4f1fbbfd5c66d6a0024f7d435ca
+GL_COMMIT= 7edfe8beeacbd32ded50bdbd187cbe08dbd6b565
# for go dependencies
USE_GITHUB= nodefault
diff --git a/www/gitlab-workhorse/distinfo b/www/gitlab-workhorse/distinfo
index 6f956214950c..7903c903ff41 100644
--- a/www/gitlab-workhorse/distinfo
+++ b/www/gitlab-workhorse/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1585262023
+TIMESTAMP = 1586981498
SHA256 (BurntSushi-toml-v0.3.1_GH0.tar.gz) = 6593da894578ba510a470735ffbdc88ce88033094dc5a8f4d3957ab87e18803f
SIZE (BurntSushi-toml-v0.3.1_GH0.tar.gz) = 42077
SHA256 (DataDog-dd-trace-go-v1.7.0_GH0.tar.gz) = d81bd47683ef9cbd228691b077373d3e15ca5fa5b9e7919099c4e87779040e84
@@ -111,8 +111,8 @@ SHA256 (uber-jaeger-client-go-v2.15.0_GH0.tar.gz) = 6b89d1a6684475fcbaed3f9d2137
SIZE (uber-jaeger-client-go-v2.15.0_GH0.tar.gz) = 164460
SHA256 (uber-jaeger-lib-v1.5.0_GH0.tar.gz) = 98901cc41df77858a2f601ad48b45bdf72af40c56f15bc5182416b15db0daac3
SIZE (uber-jaeger-lib-v1.5.0_GH0.tar.gz) = 31655
-SHA256 (gitlab-org-gitlab-workhorse-fbdf2b231e3db4f1fbbfd5c66d6a0024f7d435ca_GL0.tar.gz) = 3c1b3376cb7e124924ef756e38da47e09e3174f22708dd7aa1c70c5e0eff157e
-SIZE (gitlab-org-gitlab-workhorse-fbdf2b231e3db4f1fbbfd5c66d6a0024f7d435ca_GL0.tar.gz) = 214885
+SHA256 (gitlab-org-gitlab-workhorse-7edfe8beeacbd32ded50bdbd187cbe08dbd6b565_GL0.tar.gz) = 6c6b8a67d3f7538884a10d10d2539e77d9415996ebb350825c62a8102254d415
+SIZE (gitlab-org-gitlab-workhorse-7edfe8beeacbd32ded50bdbd187cbe08dbd6b565_GL0.tar.gz) = 215457
SHA256 (gitlab-org-gitaly-acc6be5a2cba43e4a39d05a7c995062fb9279ee6_GL0.tar.gz) = 40decb68620c061cadba556f836ef8efc953372b32903fd90825bb88fa79e943
SIZE (gitlab-org-gitaly-acc6be5a2cba43e4a39d05a7c995062fb9279ee6_GL0.tar.gz) = 2800331
SHA256 (gitlab-org-labkit-4f8041c014c2e9c6eed42674d76f5235afb5a36a_GL0.tar.gz) = 5be692b74fac460550a433ac34ac40213bbffd5ceac3a692cffd095fc033b90c