aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2018-01-09 20:22:14 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2018-01-09 20:22:14 +0000
commite3ddb83ed52db5eb894752c81576b16db5dde42b (patch)
treee0762ba44cc0fd8137d84d22f1491e99d6dc10c3 /www
parent7fb154ca8ffc3fa35f89d3440e6d180cadd46edd (diff)
downloadports-e3ddb83ed52db5eb894752c81576b16db5dde42b.tar.gz
ports-e3ddb83ed52db5eb894752c81576b16db5dde42b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/smarty3/Makefile13
-rw-r--r--www/smarty3/distinfo5
-rw-r--r--www/smarty3/pkg-plist9
3 files changed, 14 insertions, 13 deletions
diff --git a/www/smarty3/Makefile b/www/smarty3/Makefile
index e116247704e0..fa2066cef28c 100644
--- a/www/smarty3/Makefile
+++ b/www/smarty3/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= smarty
-PORTVERSION= 3.1.29
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+DISTVERSION= 3.1.30
CATEGORIES= www
PKGNAMESUFFIX= 3
@@ -13,16 +12,16 @@ COMMENT= PHP compiling template engine
LICENSE= LGPL3
-NO_BUILD= yes
USES= php:web
USE_PHP= pcre
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
-
USE_GITHUB= yes
GH_ACCOUNT= smarty-php
+NO_ARCH= yes
+NO_BUILD= yes
+
+SUB_FILES= pkg-message
+
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
do-install:
diff --git a/www/smarty3/distinfo b/www/smarty3/distinfo
index a593fb717099..2ecaa336ff70 100644
--- a/www/smarty3/distinfo
+++ b/www/smarty3/distinfo
@@ -1,2 +1,3 @@
-SHA256 (smarty-php-smarty-v3.1.29_GH0.tar.gz) = ce01732b9d1fe08d3ca3e9daa465388c8c2b698f0d2b657487e21c6e1de74a96
-SIZE (smarty-php-smarty-v3.1.29_GH0.tar.gz) = 248036
+TIMESTAMP = 1514112048
+SHA256 (smarty-php-smarty-v3.1.30_GH0.tar.gz) = 62461370c73fb3eb315c6a0a55f9bdbb04d115a0e3eaf46d76d68336524f344f
+SIZE (smarty-php-smarty-v3.1.30_GH0.tar.gz) = 255464
diff --git a/www/smarty3/pkg-plist b/www/smarty3/pkg-plist
index 43d3692b972f..c597e413cd93 100644
--- a/www/smarty3/pkg-plist
+++ b/www/smarty3/pkg-plist
@@ -53,6 +53,7 @@
%%DATADIR%%/sysplugins/smarty_cacheresource_custom.php
%%DATADIR%%/sysplugins/smarty_cacheresource_keyvaluestore.php
%%DATADIR%%/sysplugins/smarty_data.php
+%%DATADIR%%/sysplugins/smarty_internal_block.php
%%DATADIR%%/sysplugins/smarty_internal_cacheresource_file.php
%%DATADIR%%/sysplugins/smarty_internal_compile_append.php
%%DATADIR%%/sysplugins/smarty_internal_compile_assign.php
@@ -73,6 +74,7 @@
%%DATADIR%%/sysplugins/smarty_internal_compile_include_php.php
%%DATADIR%%/sysplugins/smarty_internal_compile_insert.php
%%DATADIR%%/sysplugins/smarty_internal_compile_ldelim.php
+%%DATADIR%%/sysplugins/smarty_internal_compile_make_nocache.php
%%DATADIR%%/sysplugins/smarty_internal_compile_nocache.php
%%DATADIR%%/sysplugins/smarty_internal_compile_private_block_plugin.php
%%DATADIR%%/sysplugins/smarty_internal_compile_private_foreachsection.php
@@ -118,6 +120,7 @@
%%DATADIR%%/sysplugins/smarty_internal_method_getconfigvars.php
%%DATADIR%%/sysplugins/smarty_internal_method_getdebugtemplate.php
%%DATADIR%%/sysplugins/smarty_internal_method_getdefaultmodifiers.php
+%%DATADIR%%/sysplugins/smarty_internal_method_getglobal.php
%%DATADIR%%/sysplugins/smarty_internal_method_getregisteredobject.php
%%DATADIR%%/sysplugins/smarty_internal_method_getstreamvariable.php
%%DATADIR%%/sysplugins/smarty_internal_method_gettags.php
@@ -159,18 +162,16 @@
%%DATADIR%%/sysplugins/smarty_internal_resource_stream.php
%%DATADIR%%/sysplugins/smarty_internal_resource_string.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_cachemodify.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_capture.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_codeframe.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_filterhandler.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_foreach.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_getincludepath.php
-%%DATADIR%%/sysplugins/smarty_internal_runtime_hhvm.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_inheritance.php
-%%DATADIR%%/sysplugins/smarty_internal_runtime_subtemplate.php
+%%DATADIR%%/sysplugins/smarty_internal_runtime_make_nocache.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_tplfunction.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_updatecache.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_updatescope.php
-%%DATADIR%%/sysplugins/smarty_internal_runtime_validatecompiled.php
-%%DATADIR%%/sysplugins/smarty_internal_runtime_var.php
%%DATADIR%%/sysplugins/smarty_internal_runtime_writefile.php
%%DATADIR%%/sysplugins/smarty_internal_smartytemplatecompiler.php
%%DATADIR%%/sysplugins/smarty_internal_template.php