aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2011-03-18 13:55:50 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2011-03-18 13:55:50 +0000
commite645b9a6800231a6e19ff00cb4358b92ecdf05a7 (patch)
treebf2783e9fce7bfca69ac865f28730ce0fbb8fde9 /www
parentea0fb1e52421829ace34e0f8b103edc6506d96fc (diff)
downloadports-e645b9a6800231a6e19ff00cb4358b92ecdf05a7.tar.gz
ports-e645b9a6800231a6e19ff00cb4358b92ecdf05a7.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/node/Makefile10
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-libev-kqueue55
-rw-r--r--www/node/files/patch-man-and-pkgconfig-path20
-rw-r--r--www/node/files/patch-man-path11
-rw-r--r--www/node/files/patch-platform-freebsd28
-rw-r--r--www/node/pkg-plist5
-rw-r--r--www/node04/Makefile10
-rw-r--r--www/node04/distinfo4
-rw-r--r--www/node04/files/patch-libev-kqueue55
-rw-r--r--www/node04/files/patch-man-and-pkgconfig-path20
-rw-r--r--www/node04/files/patch-man-path11
-rw-r--r--www/node04/files/patch-platform-freebsd28
-rw-r--r--www/node04/pkg-plist5
14 files changed, 120 insertions, 146 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index b1f6ad03a629..de3bbca3b1f5 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.2.6
+PORTVERSION= 0.4.2
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -21,12 +21,11 @@ MAN1= node.1
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
+USE_GNOME= pkgconfig
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= i386
MAKE_JOBS_SAFE= yes
-CONFLICTS= node-devel-[0-9]*
-
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST}
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
@@ -37,6 +36,9 @@ WAF_ARGS= --jobs=${MAKE_JOBS_NUMBER}
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} tools/waf-light ${WAF_ARGS} build)
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} tools/waf-light ${WAF_ARGS} install)
+
post-install:
@${INSTALL_MAN} ${WRKSRC}/doc/node.1 ${MANPREFIX}/man/man1/
diff --git a/www/node/distinfo b/www/node/distinfo
index 13dfdb46b90d..f6683397d13d 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.2.6.tar.gz) = e97fe9c81ff4b569ae9a0d46e64a0572a1f171293573a5b5290bcc3996a19701
-SIZE (node-v0.2.6.tar.gz) = 4010320
+SHA256 (node-v0.4.2.tar.gz) = 09b1100ca6828eedbe52418fbeb3352d71c0b1ff3344c44a5af3efb80c5b908c
+SIZE (node-v0.4.2.tar.gz) = 4922523
diff --git a/www/node/files/patch-libev-kqueue b/www/node/files/patch-libev-kqueue
deleted file mode 100644
index cdc01a945643..000000000000
--- a/www/node/files/patch-libev-kqueue
+++ /dev/null
@@ -1,55 +0,0 @@
---- deps/libev/wscript.orig 2010-04-10 08:05:03.000000000 +0800
-+++ deps/libev/wscript 2010-04-13 09:28:42.000000000 +0800
-@@ -2,6 +2,7 @@ import Options
- import platform
-
- PLATFORM_IS_DARWIN = platform.platform().find('Darwin') == 0
-+PLATFORM_IS_FREEBSD = platform.platform().find('FreeBSD') == 0
-
- def set_options(opt):
- pass
-@@ -27,12 +28,30 @@ def configure(conf):
- if conf.check_cc(header_name="poll.h"):
- conf.check_cc(header_name="poll.h", function_name="poll")
-
-- conf.check_cc(header_name="sys/event.h")
- conf.check_cc(header_name="sys/queue.h")
-- if PLATFORM_IS_DARWIN:
-- conf.check_cc(header_name="sys/event.h", function_name="kqueue")
-- else:
-- conf.check_cc(header_name="sys/queue.h", function_name="kqueue")
-+
-+ code = """
-+ #include <sys/types.h>
-+ #include <sys/event.h>
-+
-+ int main() {
-+ return 0;
-+ }
-+ """
-+ conf.check_cc(fragment=code, define_name="HAVE_SYS_EVENT_H", execute=False,
-+ msg="Checking for header sys/event.h")
-+
-+ code = """
-+ #include <sys/types.h>
-+ #include <sys/event.h>
-+
-+ int main() {
-+ int fd = kqueue();
-+ return 0;
-+ }
-+ """
-+ conf.check_cc(fragment=code, define_name="HAVE_KQUEUE", execute=False,
-+ msg="Checking for function kqueue")
-
- if conf.check_cc(header_name="sys/select.h"):
- conf.check_cc(header_name="sys/select.h", function_name="select")
-@@ -58,7 +77,7 @@ def configure(conf):
- have_librt = conf.check(lib='rt', uselib_store='RT')
- if have_librt:
- conf.check_cc(lib="rt", header_name="time.h", function_name="clock_gettime")
-- if PLATFORM_IS_DARWIN:
-+ if PLATFORM_IS_DARWIN or PLATFORM_IS_FREEBSD:
- conf.check_cc(header_name="time.h", function_name="nanosleep")
- elif have_librt:
- conf.check_cc(lib="rt", header_name="time.h", function_name="nanosleep")
diff --git a/www/node/files/patch-man-and-pkgconfig-path b/www/node/files/patch-man-and-pkgconfig-path
new file mode 100644
index 000000000000..fac4766beb77
--- /dev/null
+++ b/www/node/files/patch-man-and-pkgconfig-path
@@ -0,0 +1,20 @@
+--- wscript.orig 2011-03-03 03:10:26.000000000 -0300
++++ wscript 2011-02-03 05:46:45.000000000 -0200
+@@ -878,8 +878,6 @@
+
+ # Only install the man page if it exists.
+ # Do 'make doc install' to build and install it.
+- if os.path.exists('doc/node.1'):
+- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
+
+ bld.install_files('${PREFIX}/bin/', 'tools/node-waf', chmod=0755)
+ bld.install_files('${LIBDIR}/node/wafadmin', 'tools/wafadmin/*.py')
+@@ -891,7 +889,7 @@
+ node_conf.target = 'tools/nodejs.pc'
+ node_conf.dict = subflags(node)
+
+- bld.install_files('${LIBDIR}/pkgconfig', 'tools/nodejs.pc')
++ bld.install_files('${PREFIX}/libdata/pkgconfig', 'tools/nodejs.pc')
+
+ def shutdown():
+ Options.options.debug
diff --git a/www/node/files/patch-man-path b/www/node/files/patch-man-path
deleted file mode 100644
index 1695afc54970..000000000000
--- a/www/node/files/patch-man-path
+++ /dev/null
@@ -1,11 +0,0 @@
---- wscript.orig 2010-06-27 19:15:32.000000000 +0800
-+++ wscript 2010-06-27 19:16:02.000000000 +0800
-@@ -547,8 +547,6 @@
-
- # Only install the man page if it exists.
- # Do 'make doc install' to build and install it.
-- if os.path.exists('doc/node.1'):
-- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
-
- bld.install_files('${PREFIX}/bin/', 'bin/*', chmod=0755)
- bld.install_files('${PREFIX}/lib/node/wafadmin', 'tools/wafadmin/*.py')
diff --git a/www/node/files/patch-platform-freebsd b/www/node/files/patch-platform-freebsd
new file mode 100644
index 000000000000..1b2684957452
--- /dev/null
+++ b/www/node/files/patch-platform-freebsd
@@ -0,0 +1,28 @@
+--- deps/v8/src/platform-freebsd.cc.orig 2011-02-05 15:15:52.000000000 +0800
++++ deps/v8/src/platform-freebsd.cc 2011-02-05 15:34:20.000000000 +0800
+@@ -526,6 +526,16 @@
+ return result;
+ }
+
++ virtual bool TryLock() {
++ int result = pthread_mutex_trylock(&mutex_);
++ // Return false if the lock is busy and locking failed.
++ if (result == EBUSY) {
++ return false;
++ }
++ ASSERT(result == 0); // Verify no other errors.
++ return true;
++ }
++
+ private:
+ pthread_mutex_t mutex_; // Pthread mutex for POSIX platforms.
+ };
+@@ -604,7 +614,7 @@
+ TickSample sample;
+
+ // We always sample the VM state.
+- sample.state = VMState::current_state();
++ // sample.state = VMState::current_state();
+
+ // If profiling, we extract the current pc and sp.
+ if (active_sampler_->IsProfiling()) {
diff --git a/www/node/pkg-plist b/www/node/pkg-plist
index 0611cb61e60d..991e3b0261a0 100644
--- a/www/node/pkg-plist
+++ b/www/node/pkg-plist
@@ -1,5 +1,4 @@
bin/node
-bin/node-repl
bin/node-waf
include/node/config.h
include/node/eio.h
@@ -11,8 +10,11 @@ include/node/node_events.h
include/node/node_object_wrap.h
include/node/node_version.h
include/node/v8-debug.h
+include/node/v8-preparser.h
include/node/v8-profiler.h
+include/node/v8-testing.h
include/node/v8.h
+include/node/v8stdint.h
lib/node/wafadmin/Build.py
lib/node/wafadmin/Configure.py
lib/node/wafadmin/Constants.py
@@ -62,6 +64,7 @@ lib/node/wafadmin/__init__.py
lib/node/wafadmin/ansiterm.py
lib/node/wafadmin/pproc.py
lib/node/wafadmin/py3kfixes.py
+libdata/pkgconfig/nodejs.pc
@dirrm lib/node/wafadmin/Tools
@dirrm lib/node/wafadmin
@dirrm lib/node
diff --git a/www/node04/Makefile b/www/node04/Makefile
index b1f6ad03a629..de3bbca3b1f5 100644
--- a/www/node04/Makefile
+++ b/www/node04/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.2.6
+PORTVERSION= 0.4.2
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -21,12 +21,11 @@ MAN1= node.1
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
+USE_GNOME= pkgconfig
-ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS= i386
MAKE_JOBS_SAFE= yes
-CONFLICTS= node-devel-[0-9]*
-
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST}
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
@@ -37,6 +36,9 @@ WAF_ARGS= --jobs=${MAKE_JOBS_NUMBER}
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} tools/waf-light ${WAF_ARGS} build)
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} tools/waf-light ${WAF_ARGS} install)
+
post-install:
@${INSTALL_MAN} ${WRKSRC}/doc/node.1 ${MANPREFIX}/man/man1/
diff --git a/www/node04/distinfo b/www/node04/distinfo
index 13dfdb46b90d..f6683397d13d 100644
--- a/www/node04/distinfo
+++ b/www/node04/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.2.6.tar.gz) = e97fe9c81ff4b569ae9a0d46e64a0572a1f171293573a5b5290bcc3996a19701
-SIZE (node-v0.2.6.tar.gz) = 4010320
+SHA256 (node-v0.4.2.tar.gz) = 09b1100ca6828eedbe52418fbeb3352d71c0b1ff3344c44a5af3efb80c5b908c
+SIZE (node-v0.4.2.tar.gz) = 4922523
diff --git a/www/node04/files/patch-libev-kqueue b/www/node04/files/patch-libev-kqueue
deleted file mode 100644
index cdc01a945643..000000000000
--- a/www/node04/files/patch-libev-kqueue
+++ /dev/null
@@ -1,55 +0,0 @@
---- deps/libev/wscript.orig 2010-04-10 08:05:03.000000000 +0800
-+++ deps/libev/wscript 2010-04-13 09:28:42.000000000 +0800
-@@ -2,6 +2,7 @@ import Options
- import platform
-
- PLATFORM_IS_DARWIN = platform.platform().find('Darwin') == 0
-+PLATFORM_IS_FREEBSD = platform.platform().find('FreeBSD') == 0
-
- def set_options(opt):
- pass
-@@ -27,12 +28,30 @@ def configure(conf):
- if conf.check_cc(header_name="poll.h"):
- conf.check_cc(header_name="poll.h", function_name="poll")
-
-- conf.check_cc(header_name="sys/event.h")
- conf.check_cc(header_name="sys/queue.h")
-- if PLATFORM_IS_DARWIN:
-- conf.check_cc(header_name="sys/event.h", function_name="kqueue")
-- else:
-- conf.check_cc(header_name="sys/queue.h", function_name="kqueue")
-+
-+ code = """
-+ #include <sys/types.h>
-+ #include <sys/event.h>
-+
-+ int main() {
-+ return 0;
-+ }
-+ """
-+ conf.check_cc(fragment=code, define_name="HAVE_SYS_EVENT_H", execute=False,
-+ msg="Checking for header sys/event.h")
-+
-+ code = """
-+ #include <sys/types.h>
-+ #include <sys/event.h>
-+
-+ int main() {
-+ int fd = kqueue();
-+ return 0;
-+ }
-+ """
-+ conf.check_cc(fragment=code, define_name="HAVE_KQUEUE", execute=False,
-+ msg="Checking for function kqueue")
-
- if conf.check_cc(header_name="sys/select.h"):
- conf.check_cc(header_name="sys/select.h", function_name="select")
-@@ -58,7 +77,7 @@ def configure(conf):
- have_librt = conf.check(lib='rt', uselib_store='RT')
- if have_librt:
- conf.check_cc(lib="rt", header_name="time.h", function_name="clock_gettime")
-- if PLATFORM_IS_DARWIN:
-+ if PLATFORM_IS_DARWIN or PLATFORM_IS_FREEBSD:
- conf.check_cc(header_name="time.h", function_name="nanosleep")
- elif have_librt:
- conf.check_cc(lib="rt", header_name="time.h", function_name="nanosleep")
diff --git a/www/node04/files/patch-man-and-pkgconfig-path b/www/node04/files/patch-man-and-pkgconfig-path
new file mode 100644
index 000000000000..fac4766beb77
--- /dev/null
+++ b/www/node04/files/patch-man-and-pkgconfig-path
@@ -0,0 +1,20 @@
+--- wscript.orig 2011-03-03 03:10:26.000000000 -0300
++++ wscript 2011-02-03 05:46:45.000000000 -0200
+@@ -878,8 +878,6 @@
+
+ # Only install the man page if it exists.
+ # Do 'make doc install' to build and install it.
+- if os.path.exists('doc/node.1'):
+- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
+
+ bld.install_files('${PREFIX}/bin/', 'tools/node-waf', chmod=0755)
+ bld.install_files('${LIBDIR}/node/wafadmin', 'tools/wafadmin/*.py')
+@@ -891,7 +889,7 @@
+ node_conf.target = 'tools/nodejs.pc'
+ node_conf.dict = subflags(node)
+
+- bld.install_files('${LIBDIR}/pkgconfig', 'tools/nodejs.pc')
++ bld.install_files('${PREFIX}/libdata/pkgconfig', 'tools/nodejs.pc')
+
+ def shutdown():
+ Options.options.debug
diff --git a/www/node04/files/patch-man-path b/www/node04/files/patch-man-path
deleted file mode 100644
index 1695afc54970..000000000000
--- a/www/node04/files/patch-man-path
+++ /dev/null
@@ -1,11 +0,0 @@
---- wscript.orig 2010-06-27 19:15:32.000000000 +0800
-+++ wscript 2010-06-27 19:16:02.000000000 +0800
-@@ -547,8 +547,6 @@
-
- # Only install the man page if it exists.
- # Do 'make doc install' to build and install it.
-- if os.path.exists('doc/node.1'):
-- bld.install_files('${PREFIX}/share/man/man1/', 'doc/node.1')
-
- bld.install_files('${PREFIX}/bin/', 'bin/*', chmod=0755)
- bld.install_files('${PREFIX}/lib/node/wafadmin', 'tools/wafadmin/*.py')
diff --git a/www/node04/files/patch-platform-freebsd b/www/node04/files/patch-platform-freebsd
new file mode 100644
index 000000000000..1b2684957452
--- /dev/null
+++ b/www/node04/files/patch-platform-freebsd
@@ -0,0 +1,28 @@
+--- deps/v8/src/platform-freebsd.cc.orig 2011-02-05 15:15:52.000000000 +0800
++++ deps/v8/src/platform-freebsd.cc 2011-02-05 15:34:20.000000000 +0800
+@@ -526,6 +526,16 @@
+ return result;
+ }
+
++ virtual bool TryLock() {
++ int result = pthread_mutex_trylock(&mutex_);
++ // Return false if the lock is busy and locking failed.
++ if (result == EBUSY) {
++ return false;
++ }
++ ASSERT(result == 0); // Verify no other errors.
++ return true;
++ }
++
+ private:
+ pthread_mutex_t mutex_; // Pthread mutex for POSIX platforms.
+ };
+@@ -604,7 +614,7 @@
+ TickSample sample;
+
+ // We always sample the VM state.
+- sample.state = VMState::current_state();
++ // sample.state = VMState::current_state();
+
+ // If profiling, we extract the current pc and sp.
+ if (active_sampler_->IsProfiling()) {
diff --git a/www/node04/pkg-plist b/www/node04/pkg-plist
index 0611cb61e60d..991e3b0261a0 100644
--- a/www/node04/pkg-plist
+++ b/www/node04/pkg-plist
@@ -1,5 +1,4 @@
bin/node
-bin/node-repl
bin/node-waf
include/node/config.h
include/node/eio.h
@@ -11,8 +10,11 @@ include/node/node_events.h
include/node/node_object_wrap.h
include/node/node_version.h
include/node/v8-debug.h
+include/node/v8-preparser.h
include/node/v8-profiler.h
+include/node/v8-testing.h
include/node/v8.h
+include/node/v8stdint.h
lib/node/wafadmin/Build.py
lib/node/wafadmin/Configure.py
lib/node/wafadmin/Constants.py
@@ -62,6 +64,7 @@ lib/node/wafadmin/__init__.py
lib/node/wafadmin/ansiterm.py
lib/node/wafadmin/pproc.py
lib/node/wafadmin/py3kfixes.py
+libdata/pkgconfig/nodejs.pc
@dirrm lib/node/wafadmin/Tools
@dirrm lib/node/wafadmin
@dirrm lib/node