aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2009-07-17 06:12:47 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2009-07-17 06:12:47 +0000
commite77f838b4aef2616fb9d9f01ed4c97d0b12e1f8b (patch)
treebda67afa136069a7b06242ffcd413255e2caa640 /www
parentadd8b98a2393130b732d071e7f50ab861b9792b4 (diff)
downloadports-e77f838b4aef2616fb9d9f01ed4c97d0b12e1f8b.tar.gz
ports-e77f838b4aef2616fb9d9f01ed4c97d0b12e1f8b.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile18
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_http_notice_module.c11
3 files changed, 35 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 106a6b64e31a..718f7ea70b9b 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -45,6 +45,8 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_EVAL_MODULE "3rd party eval module" off \
HTTP_FANCYINDEX_MODULE "3rd party http_fancyindex module" off \
HTTP_MOGILEFS_MODULE "3rd party mogilefs module" off \
+ HTTP_MP4_H264_MODULE "3rd party mp4/h264 module" off \
+ HTTP_NOTICE_MODULE "3rd party notice module" off \
HTTP_RESPONSE_MODULE "3rd party http_response module" off \
HTTP_UPLOAD_MODULE "3rd party upload module" off \
HTTP_UPLOAD_PROGRESS "3rd party upload_progress module" off \
@@ -163,6 +165,18 @@ DISTFILES+= nginx_mogilefs_module-${NGINX_MOGILEFS_MODULE_VERSION}.tar.gz:mogile
CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_mogilefs_module-${NGINX_MOGILEFS_MODULE_VERSION}
.endif
+.if defined(WITH_HTTP_MP4_H264_MODULE)
+MASTER_SITES+= http://i.6.cn/:mp4streaming
+DISTFILES+= nginx_mp4_streaming_public_20081229.tar.bz2:mp4streaming
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_mp4_streaming_public
+.endif
+
+.if defined(WITH_HTTP_NOTICE_MODULE)
+MASTER_SITES+= http://xph.us/dist/nginx-notice/:notice2
+DISTFILES+= nginx-notice-2.tar.gz:notice2
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-notice-2
+.endif
+
.if defined(WITH_HTTP_PERL_MODULE)
CATEGORIES+= perl5
CONFIGURE_ARGS+=--with-http_perl_module
@@ -321,6 +335,10 @@ post-patch:
@${PATCH} ${PATCH_ARGS} < \
${PATCHDIR}/extra-patch-ngx_http_fancyindex_module.c
.endif
+.if defined(WITH_HTTP_NOTICE_MODULE)
+ @${PATCH} ${PATCH_ARGS} < \
+ ${PATCHDIR}/extra-patch-ngx_http_notice_module.c
+.endif
.if defined(WITH_PASSENGER_MODULE)
@${REINPLACE_CMD} 's!g++!${CXX}!' \
${WRKDIR}/passenger-${PASSENGER_VERSION}/Rakefile
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 5632aaba00b7..2918faf107a5 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -13,6 +13,12 @@ SIZE (nginx-fancyindex-0.1_beta5.tar.bz2) = 12211
MD5 (nginx_mogilefs_module-1.0.1.tar.gz) = c45947ec9aebe83398d4c9604e843023
SHA256 (nginx_mogilefs_module-1.0.1.tar.gz) = f862d48e50683a808bb8e305474d1b9800800bd0ea64ebcc258a4c7f3ecd9bfb
SIZE (nginx_mogilefs_module-1.0.1.tar.gz) = 6834
+MD5 (nginx_mp4_streaming_public_20081229.tar.bz2) = 45787a69ac1b6bbe09fc31a6cd058857
+SHA256 (nginx_mp4_streaming_public_20081229.tar.bz2) = 4908709c50f73d73cb1c16136eaca4b280d8abb60dfd302e79c48f71a68c5d3e
+SIZE (nginx_mp4_streaming_public_20081229.tar.bz2) = 9469
+MD5 (nginx-notice-2.tar.gz) = 7253bdd2b88cc981867b72efdc484772
+SHA256 (nginx-notice-2.tar.gz) = 682824a9f5187831ee49e5828bafebde5c25706e681d361804f96308f24e58c2
+SIZE (nginx-notice-2.tar.gz) = 3253
MD5 (ngx_http_response-0.3.tar.gz) = 178a8f13a41388ef50b3726fa9fede50
SHA256 (ngx_http_response-0.3.tar.gz) = 0835584029f053051c624adbe33a826ab0205c9d85a02af6019e6b57607e9045
SIZE (ngx_http_response-0.3.tar.gz) = 2244
diff --git a/www/nginx-devel/files/extra-patch-ngx_http_notice_module.c b/www/nginx-devel/files/extra-patch-ngx_http_notice_module.c
new file mode 100644
index 000000000000..851c7392a4f3
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-ngx_http_notice_module.c
@@ -0,0 +1,11 @@
+--- ../nginx-notice-2/ngx_http_notice_module.c.orig 2009-07-16 18:37:57.000000000 +0200
++++ ../nginx-notice-2/ngx_http_notice_module.c 2009-07-16 08:09:38.000000000 +0200
+@@ -153,7 +153,7 @@
+ return NGX_HTTP_NOT_ALLOWED;
+ }
+
+- rc = ngx_http_discard_body(r);
++ rc = ngx_http_discard_request_body(r);
+
+ if (rc != NGX_OK && rc != NGX_AGAIN) {
+ return rc;