aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-08-18 16:15:10 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-08-18 16:15:10 +0000
commitefb928619b234d49b326a13f59a6e2ee354bf902 (patch)
treec62bd82140831e81442480b9cefc699e0c08f08d /www
parentdfc14c855f8ec76c9bd42bc90e325a160cc5d6cf (diff)
downloadports-efb928619b234d49b326a13f59a6e2ee354bf902.tar.gz
ports-efb928619b234d49b326a13f59a6e2ee354bf902.zip
Notes
Diffstat (limited to 'www')
-rw-r--r--www/analog/Makefile3
-rw-r--r--www/http-analyze/Makefile2
-rw-r--r--www/mgstat/Makefile4
-rw-r--r--www/webalizer/Makefile10
4 files changed, 8 insertions, 11 deletions
diff --git a/www/analog/Makefile b/www/analog/Makefile
index 0a255671b14b..c7158035d10b 100644
--- a/www/analog/Makefile
+++ b/www/analog/Makefile
@@ -7,6 +7,7 @@
PORTNAME= analog
PORTVERSION= 5.32
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://www.analog.cx/ \
@@ -24,7 +25,7 @@ MASTER_SITES= http://www.analog.cx/ \
MAINTAINER= mharo@FreeBSD.org
COMMENT= An extremely fast program for analysing WWW logfiles
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2 \
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
diff --git a/www/http-analyze/Makefile b/www/http-analyze/Makefile
index a3497a9b97f2..7d26c5ac65b9 100644
--- a/www/http-analyze/Makefile
+++ b/www/http-analyze/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= todd@thisisa.com
COMMENT= A fast Log-Analyzer for web servers
BUILD_DEPENDS= gif2png:${PORTSDIR}/graphics/gif2png
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
MAN1= http-analyze.1
diff --git a/www/mgstat/Makefile b/www/mgstat/Makefile
index 0040cdb1f2ba..77626937f546 100644
--- a/www/mgstat/Makefile
+++ b/www/mgstat/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mgstat
PORTVERSION= 0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://wizard.ae.krakow.pl/~mike/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Produce graphs from mod_gzip log files
-LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
diff --git a/www/webalizer/Makefile b/www/webalizer/Makefile
index 2c186dfe72bc..5d0b54fe9aee 100644
--- a/www/webalizer/Makefile
+++ b/www/webalizer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webalizer
PORTVERSION= 2.1.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= www
MASTER_SITES= ftp://ftp.mrunix.net/pub/webalizer/ \
ftp://ftp.dinoex.de/pub/FreeBSD/distfiles/
@@ -17,17 +17,13 @@ MAINTAINER?= dinoex@FreeBSD.org
COMMENT= A web server log file analysis program
.if !defined(LIB_DEPENDS)
-LIB_DEPENDS= gd.4:${PORTSDIR}/${GD_PORT}
-.if defined(WEBALIZER_WITH_GD2)
-GD_PORT?= graphics/gd2
-.endif
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
.endif
USE_BZIP2= yes
GNU_CONFIGURE= yes
DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR?= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
-GD_PORT?= graphics/gd-nox11
.if defined(BATCH)
# no cosmetique spaces allowed
@@ -39,7 +35,7 @@ WEBALIZER_LANG?=english
CONFIGURE_ARGS+= --enable-dns \
--with-etcdir=${PREFIX}/etc \
--with-gdlib=${PREFIX}/lib \
- --with-gd=${PREFIX}/include/gd
+ --with-gd=${PREFIX}/include
CONFIGURE_ENV+= LDFLAGS="-L${PREFIX}/lib"
CFLAGS+= -DLINKLIST_MAX_STRING=256
MAKE_ARGS+= CFLAGS="${CFLAGS}"