aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/wmblueclock
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-28 10:49:47 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-28 10:49:47 +0000
commit1d2ee28244f6f01e1bde23480131b2e22323dda4 (patch)
tree08dd667e890fab7b4f9e48bb8e84b1b59ef8a5c7 /x11-clocks/wmblueclock
parent8031032c1689dbf2912ca8583e9c549f97d46ad8 (diff)
downloadports-1d2ee28244f6f01e1bde23480131b2e22323dda4.tar.gz
ports-1d2ee28244f6f01e1bde23480131b2e22323dda4.zip
New port: wmblueclock (simple dockable clock application)
Submitted by: Alexey Dokuchaev
Notes
Notes: svn path=/head/; revision=79780
Diffstat (limited to 'x11-clocks/wmblueclock')
-rw-r--r--x11-clocks/wmblueclock/Makefile27
-rw-r--r--x11-clocks/wmblueclock/distinfo1
-rw-r--r--x11-clocks/wmblueclock/files/patch-Makefile66
-rw-r--r--x11-clocks/wmblueclock/files/patch-timing.c13
-rw-r--r--x11-clocks/wmblueclock/pkg-descr2
-rw-r--r--x11-clocks/wmblueclock/pkg-plist1
6 files changed, 110 insertions, 0 deletions
diff --git a/x11-clocks/wmblueclock/Makefile b/x11-clocks/wmblueclock/Makefile
new file mode 100644
index 000000000000..303dbed1c6c6
--- /dev/null
+++ b/x11-clocks/wmblueclock/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: wmblueclock
+# Date created: 25 Apr 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wmblueclock
+PORTVERSION= 0.0
+CATEGORIES= x11-clocks windowmaker
+MASTER_SITES= http://ibiblio.org/pub/linux/X11/xutils/ \
+ ftp://ftp.ibiblio.org/pub/linux/X11/xutils/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= Simple dockable clock application
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+MAN1= ${PORTNAME}.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/wmblueclock/distinfo b/x11-clocks/wmblueclock/distinfo
new file mode 100644
index 000000000000..9cd298e8a86e
--- /dev/null
+++ b/x11-clocks/wmblueclock/distinfo
@@ -0,0 +1 @@
+MD5 (wmblueclock-0.0.tar.bz2) = 3ee93b4736de7bd6fd67b74c97bb3b26
diff --git a/x11-clocks/wmblueclock/files/patch-Makefile b/x11-clocks/wmblueclock/files/patch-Makefile
new file mode 100644
index 000000000000..a15735ee0605
--- /dev/null
+++ b/x11-clocks/wmblueclock/files/patch-Makefile
@@ -0,0 +1,66 @@
+--- Makefile.orig Fri Apr 25 04:37:15 2003
++++ Makefile Fri Apr 25 04:40:57 2003
+@@ -1,54 +1,13 @@
+-# WMBlueClock - a clock dockapp
+-#
+-# Copyright (C) 2003 Draghicioiu Mihai Andrei <misuceldestept@go.ro>
+-#
+-# This program is free software; you can redistribute it and/or modify
+-# it under the terms of the GNU General Public License as published by
+-# the Free Software Foundation; either version 2 of the License, or
+-# (at your option) any later version.
++CC ?= cc
++LDIR = -L${X11BASE}/lib
++IDIR = -I${X11BASE}/include
+
+-# This program is distributed in the hope that it will be useful,
+-# but WITHOUT ANY WARRANTY; without even the implied warranty of
+-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+-# GNU General Public License for more details.
++LIBS = -lX11 -lXpm -lXext -lkvm
+
+-# You should have received a copy of the GNU General Public License
+-# along with this program; if not, write to the Free Software
+-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
++OBJS = dockapp.o draw.o options.o timing.o wmblueclock.o
+
+-PROG=wmblueclock
+-OBJS=dockapp.o draw.o options.o timing.o wmblueclock.o
++.c.o:
++ ${CC} ${CFLAGS} ${IDIR} ${DEFS} -c $< -o $*.o
+
+-PREFIX=/usr/local
+-BINDIR=$(PREFIX)/bin
+-MANUALDIR=$(PREFIX)/share/man/man1
+-CC=gcc
+-STRIP=strip
+-FLAGS=-Wall -O2
+-RM=rm -rf
+-INST=install
+-MANUAL=$(PROG).1
+-LIBS=-L/usr/X11R6/lib -lX11 -lXext -lXpm
+-
+-all: $(PROG)
+-
+-$(PROG): $(OBJS)
+- $(CC) -o $(PROG) $(OBJS) $(LIBS)
+- $(STRIP) $(PROG)
+-%.o: %.c
+- $(CC) $(FLAGS) -c $< -o $@
+-clean:
+- $(RM) $(OBJS) $(PROG) .xvpics xpm/.xvpics
+-install: $(PROG)
+- $(INST) -m 755 $(PROG) $(BINDIR)
+- $(INST) -m 644 $(MANUAL) $(MANUALDIR)
+-uninstall:
+- $(RM) $(BINDIR)/$(PROG)
+- $(RM) $(MANUALDIR)/$(MANUAL)
+-
+-dockapp.o: dockapp.c wmblueclock.h options.h draw.h timing.h xpm/bg.xpm \
+- xpm/bignums.xpm xpm/letters.xpm xpm/numbers.xpm xpm/panel.xpm
+-draw.o: draw.c dockapp.h options.h
+-options.o: options.c wmblueclock.h options.h
+-timing.o: timing.c draw.h options.h
+-wmblueclock.o: wmblueclock.c options.h dockapp.h timing.h
++all: ${OBJS}
++ ${CC} ${CFLAGS} -o wmblueclock ${OBJS} ${LDIR} ${LIBS}
diff --git a/x11-clocks/wmblueclock/files/patch-timing.c b/x11-clocks/wmblueclock/files/patch-timing.c
new file mode 100644
index 000000000000..fa4d692a27b9
--- /dev/null
+++ b/x11-clocks/wmblueclock/files/patch-timing.c
@@ -0,0 +1,13 @@
+--- timing.c.orig Fri Apr 25 04:34:40 2003
++++ timing.c Fri Apr 25 04:35:03 2003
+@@ -38,8 +38,8 @@
+ signal(SIGALRM, handle_timer);
+ itv.it_value.tv_sec = 2;
+ itv.it_value.tv_usec = 0;
+- itv.it_interval.tv_sec = 0;
+- itv.it_interval.tv_usec = opt_milisecs * 1000;
++ itv.it_interval.tv_sec = opt_milisecs / 1000;
++ itv.it_interval.tv_usec = (opt_milisecs % 1000) * 1000;
+ setitimer(ITIMER_REAL, &itv, NULL);
+ }
+
diff --git a/x11-clocks/wmblueclock/pkg-descr b/x11-clocks/wmblueclock/pkg-descr
new file mode 100644
index 000000000000..0c9aaf9d7356
--- /dev/null
+++ b/x11-clocks/wmblueclock/pkg-descr
@@ -0,0 +1,2 @@
+WMBlueClock is a simple clock dockapp. It displays current date and time
+in "blue" fashion.
diff --git a/x11-clocks/wmblueclock/pkg-plist b/x11-clocks/wmblueclock/pkg-plist
new file mode 100644
index 000000000000..4ecfd3d7bbd3
--- /dev/null
+++ b/x11-clocks/wmblueclock/pkg-plist
@@ -0,0 +1 @@
+bin/wmblueclock