aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/wmfishtime
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-27 07:31:02 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-27 07:31:02 +0000
commit3d0436f49d3f1db546a14a77835b279edc685989 (patch)
tree621efcfe5ed68a85033a0d080773315d1b258a9b /x11-clocks/wmfishtime
parentbe06d571183335eec43b60a8bd4b13d1b73c6468 (diff)
downloadports-3d0436f49d3f1db546a14a77835b279edc685989.tar.gz
ports-3d0436f49d3f1db546a14a77835b279edc685989.zip
Update to 1.23.
PR: 27671 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=43109
Diffstat (limited to 'x11-clocks/wmfishtime')
-rw-r--r--x11-clocks/wmfishtime/Makefile11
-rw-r--r--x11-clocks/wmfishtime/distinfo2
-rw-r--r--x11-clocks/wmfishtime/files/patch-Makefile21
3 files changed, 29 insertions, 5 deletions
diff --git a/x11-clocks/wmfishtime/Makefile b/x11-clocks/wmfishtime/Makefile
index 69fad6da2302..db52e7af2f6a 100644
--- a/x11-clocks/wmfishtime/Makefile
+++ b/x11-clocks/wmfishtime/Makefile
@@ -6,19 +6,22 @@
#
PORTNAME= wmfishtime
-PORTVERSION= 1.21
+PORTVERSION= 1.23
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/ \
http://www.freenix.no/~anders/
MAINTAINER= anders@fix.no
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
USE_GTK= yes
USE_X_PREFIX= yes
-pre-build:
- ${PERL} -pi -e "s@gcc@${CC}@g; s@-O3@${CFLAGS}@g; \
- s@gtk-config@${GTK_CONFIG}@g; s@-lgtk@-lgtk12@g" ${WRKSRC}/Makefile
+GTK_LIBS?= `${GTK_CONFIG} --libs`
+GTK_CFLAGS?= `${GTK_CONFIG} --cflags`
+MAKE_ARGS+= CFLAGS="${CFLAGS} -Wall -I${LOCALBASE}/include ${GTK_CFLAGS}" \
+ GTK_LIBS="${GTK_LIBS}"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmfishtime ${PREFIX}/bin
diff --git a/x11-clocks/wmfishtime/distinfo b/x11-clocks/wmfishtime/distinfo
index b4314ad88a42..aabcdf6b0946 100644
--- a/x11-clocks/wmfishtime/distinfo
+++ b/x11-clocks/wmfishtime/distinfo
@@ -1 +1 @@
-MD5 (wmfishtime-1.21.tar.gz) = a9f690aff8bf188f6e9bfab4f008623c
+MD5 (wmfishtime-1.23.tar.gz) = ec10376dfb9b43eb7b519b20a1da71e6
diff --git a/x11-clocks/wmfishtime/files/patch-Makefile b/x11-clocks/wmfishtime/files/patch-Makefile
new file mode 100644
index 000000000000..5443503f902f
--- /dev/null
+++ b/x11-clocks/wmfishtime/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Sat May 26 22:49:41 2001
++++ Makefile Sun May 27 00:14:26 2001
+@@ -6,17 +6,15 @@
+
+ # no user serviceable parts below this line
+ # optimization cflags
+-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
+ # profiling cflags
+ # CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
+ # test coverage cflags
+ # CFLAGS=-fprofile-arcs -ftest-coverage -Wall -ansi -pedantic -g `gtk-config --cflags` ${EXTRA} -DPRO
+
+
+-CC = gcc
+ SHELL = sh
+ OBJS = fishmon.o
+-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
++LIBS = `echo $(GTK_LIBS) | sed "s/-lgtk12//g"` -lgnugetopt
+ INSTALL = -m 755
+
+ all: wmfishtime