aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2020-08-30 03:11:46 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2020-08-30 03:11:46 +0000
commit1cbce2fe1571269350caa91f028c521e5f5e69af (patch)
tree5560f1382ff91fec04c38459208b10c7ea42342a /x11-clocks
parent8ccd925b80fc1cdd6ef3d9d03c9dd1d2971f07d6 (diff)
downloadports-1cbce2fe1571269350caa91f028c521e5f5e69af.tar.gz
ports-1cbce2fe1571269350caa91f028c521e5f5e69af.zip
Patch source code to fix the problem -fno-common tripped over
Along the way take maintainership. I have a soft spot for WM Fixing this was faster than replying to the thread caused by r546907
Notes
Notes: svn path=/head/; revision=546968
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/wmtime/Makefile10
-rw-r--r--x11-clocks/wmtime/files/patch-wmgeneral.h11
-rw-r--r--x11-clocks/wmtime/files/patch-wmtime.c (renamed from x11-clocks/wmtime/files/patch-wmtime.c2)12
3 files changed, 23 insertions, 10 deletions
diff --git a/x11-clocks/wmtime/Makefile b/x11-clocks/wmtime/Makefile
index 886e24023db4..c1041f616756 100644
--- a/x11-clocks/wmtime/Makefile
+++ b/x11-clocks/wmtime/Makefile
@@ -3,21 +3,15 @@
PORTNAME= wmtime
PORTVERSION= 1.0b2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://web.cs.mun.ca/~gstarkes/wmaker/dockapps/files/ \
http://freebsd.unixfreunde.de/sources/ \
http://mirror2.unixfreunde.de/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= Time/Date applet for WindowMaker
-# Fix build with llvm 11
-CFLAGS+= -fcommon
-
-DEPRECATED= Unmaintained and dead upstream
-EXPIRATION_DATE=2020-09-30
-
WRKSRC= ${WRKDIR}/wmtime.app/wmtime
USES= imake xorg
USE_XORG= xpm
diff --git a/x11-clocks/wmtime/files/patch-wmgeneral.h b/x11-clocks/wmtime/files/patch-wmgeneral.h
new file mode 100644
index 000000000000..a4ca25cee304
--- /dev/null
+++ b/x11-clocks/wmtime/files/patch-wmgeneral.h
@@ -0,0 +1,11 @@
+--- ../wmgeneral/wmgeneral.h.orig 2020-08-29 19:54:52.707315000 -0700
++++ ../wmgeneral/wmgeneral.h 2020-08-29 19:55:08.284120000 -0700
+@@ -28,7 +28,7 @@
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-clocks/wmtime/files/patch-wmtime.c2 b/x11-clocks/wmtime/files/patch-wmtime.c
index b60722ad0c97..2259697a508a 100644
--- a/x11-clocks/wmtime/files/patch-wmtime.c2
+++ b/x11-clocks/wmtime/files/patch-wmtime.c
@@ -1,5 +1,5 @@
---- wmtime.c Wed May 20 06:34:53 1998
-+++ wmtime.c2 Sat Nov 28 18:44:59 1998
+--- wmtime.c.orig 1998-05-19 21:04:53 UTC
++++ wmtime.c
@@ -89,7 +89,7 @@
char *ProgName;
int digital = 0;
@@ -9,3 +9,11 @@
/* functions */
void usage(void);
+@@ -166,6 +166,7 @@ void get_lang(){
+ char *left_action = NULL;
+ char *right_action = NULL;
+ char *middle_action = NULL;
++Display *display;
+
+ void DrawTime(int, int, int);
+ void DrawWijzer(int, int, int);