aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-mouse
diff options
context:
space:
mode:
authorRobert Noland <rnoland@FreeBSD.org>2009-01-29 15:49:02 +0000
committerRobert Noland <rnoland@FreeBSD.org>2009-01-29 15:49:02 +0000
commit107ff50220074f82d33e9f3723e121e64dc91b73 (patch)
tree6cea9bb2dad2e90f327e06eadc3697b3904f09dc /x11-drivers/xf86-input-mouse
parentd98fbe1fb4ccf9fa205125e496f6720a9d0411d3 (diff)
downloadports-107ff50220074f82d33e9f3723e121e64dc91b73.tar.gz
ports-107ff50220074f82d33e9f3723e121e64dc91b73.zip
Take a crack at resolving the mouse blocking issues.
Notes
Notes: svn path=/head/; revision=227092
Diffstat (limited to 'x11-drivers/xf86-input-mouse')
-rw-r--r--x11-drivers/xf86-input-mouse/Makefile1
-rw-r--r--x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c17
2 files changed, 13 insertions, 5 deletions
diff --git a/x11-drivers/xf86-input-mouse/Makefile b/x11-drivers/xf86-input-mouse/Makefile
index b3cd5b4e4463..a0d57399107c 100644
--- a/x11-drivers/xf86-input-mouse/Makefile
+++ b/x11-drivers/xf86-input-mouse/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xf86-input-mouse
PORTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
index b3258c653ad4..c2c8cade92f6 100644
--- a/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
+++ b/x11-drivers/xf86-input-mouse/files/patch-src-bsd_mouse.c
@@ -1,11 +1,20 @@
---- src/bsd_mouse.c.orig 2008-12-13 18:24:06.000000000 -0500
-+++ src/bsd_mouse.c 2008-12-14 22:50:40.000000000 -0500
+--- src/bsd_mouse.c.orig 2008-11-26 23:11:36.000000000 -0500
++++ src/bsd_mouse.c 2009-01-28 12:52:12.000000000 -0500
@@ -1,4 +1,3 @@
-
/*
* Copyright (c) 1999-2003 by The XFree86 Project, Inc.
*
-@@ -75,11 +74,15 @@
+@@ -28,6 +27,8 @@
+
+ #include <xorg-server.h>
+
++#define XPS2_SUPPORT
++
+ #include <X11/X.h>
+ #include "xf86.h"
+ #include "xf86Priv.h"
+@@ -75,11 +76,13 @@
#define DEFAULT_MOUSE_DEV "/dev/mouse"
#define DEFAULT_SYSMOUSE_DEV "/dev/sysmouse"
#define DEFAULT_PS2_DEV "/dev/psm0"
@@ -14,10 +23,8 @@
static const char *mouseDevs[] = {
DEFAULT_MOUSE_DEV,
DEFAULT_SYSMOUSE_DEV,
-+#ifndef CONFIG_HAL
DEFAULT_PS2_DEV,
+ DEFAULT_USB_DEV,
-+#endif
NULL
};
#elif (defined(__OpenBSD__) || defined(__NetBSD__)) && defined(WSCONS_SUPPORT)