aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-input-wacom
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-03-22 11:03:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-03-22 11:03:02 +0000
commit13f75ca8fd653f5e5bfb8e7cd62389fc3c717459 (patch)
tree88b403433df60b2e770da96798dfcfa5b0061d54 /x11-drivers/xf86-input-wacom
parent081fa90429d347dfc319f3415575d499fca10408 (diff)
downloadports-13f75ca8fd653f5e5bfb8e7cd62389fc3c717459.tar.gz
ports-13f75ca8fd653f5e5bfb8e7cd62389fc3c717459.zip
- Update to 0.29.0
- Convert to load_kld as 8.4R lacks kldload -n [1] - Provide _stop command useful for testing - Reword pkg-message to nudge looking inside rc.d/wacom Suggested by: flo (via D1595) [1]
Notes
Notes: svn path=/head/; revision=381903
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/Makefile2
-rw-r--r--x11-drivers/xf86-input-wacom/distinfo4
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-configure29
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c12
-rw-r--r--x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c2
-rw-r--r--x11-drivers/xf86-input-wacom/files/pkg-message.in7
-rw-r--r--x11-drivers/xf86-input-wacom/files/wacom.in10
7 files changed, 23 insertions, 43 deletions
diff --git a/x11-drivers/xf86-input-wacom/Makefile b/x11-drivers/xf86-input-wacom/Makefile
index cb2ff8359653..745fde27a9ba 100644
--- a/x11-drivers/xf86-input-wacom/Makefile
+++ b/x11-drivers/xf86-input-wacom/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-input-wacom
-PORTVERSION= 0.28.0
+PORTVERSION= 0.29.0
CATEGORIES= x11-drivers
MASTER_SITES= SF/linuxwacom/${PORTNAME}
diff --git a/x11-drivers/xf86-input-wacom/distinfo b/x11-drivers/xf86-input-wacom/distinfo
index babf95753895..039201256271 100644
--- a/x11-drivers/xf86-input-wacom/distinfo
+++ b/x11-drivers/xf86-input-wacom/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-input-wacom-0.28.0.tar.bz2) = 7c19008ef727a5437d300fc297325953ad2b30a23163fba19adda2aa9ad6243b
-SIZE (xorg/driver/xf86-input-wacom-0.28.0.tar.bz2) = 595621
+SHA256 (xorg/driver/xf86-input-wacom-0.29.0.tar.bz2) = 88507e76f1eb98a20c4381806e03c694adcff88ac0028f93892019a7a6fc8b96
+SIZE (xorg/driver/xf86-input-wacom-0.29.0.tar.bz2) = 589495
diff --git a/x11-drivers/xf86-input-wacom/files/patch-configure b/x11-drivers/xf86-input-wacom/files/patch-configure
deleted file mode 100644
index a7c15fdfe3cf..000000000000
--- a/x11-drivers/xf86-input-wacom/files/patch-configure
+++ /dev/null
@@ -1,29 +0,0 @@
-To workaround the following error
-
- $ clang conftest.c -I/usr/local/include/xorg
- In file included from conftest.c:3:
- In file included from /usr/local/include/xorg/xf86Optionstr.h:27:
- /usr/local/include/xorg/list.h:216:15: error: unknown type name 'Bool'; did you mean
- '_Bool'?
- static inline Bool
- ^~~~
- _Bool
- 1 error generated.
-
- $ gcc conftest.c -I/usr/local/include/xorg
- In file included from /usr/local/include/xorg/xf86Optionstr.h:27,
- from conftest.c:3:
- /usr/local/include/xorg/list.h:217: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'xorg_list_is_empty'
-
-cf. http://cgit.freedesktop.org/xorg/xserver/commit/?id=13b5074
-
---- configure~
-+++ configure
-@@ -18788,6 +18788,7 @@ CFLAGS="$XORG_CFLAGS $CFLAGS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
-+ typedef int Bool;
- #include <xf86Optionstr.h>
- int
- main ()
diff --git a/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c b/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c
index 85c3dd206146..0d6aaa3ccbf9 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-src-wcmISDV4.c
@@ -1,6 +1,6 @@
--- src/wcmISDV4.c~
+++ src/wcmISDV4.c
-@@ -24,11 +24,16 @@
+@@ -24,14 +24,19 @@
#include "xf86Wacom.h"
#include <xf86_OSproc.h>
#include "wcmFilter.h"
@@ -8,16 +8,20 @@
#include "isdv4.h"
#include <unistd.h>
#include <fcntl.h>
-+
+-#include <libudev.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+#ifdef __linux__
+#include <linux/serial.h>
- #include <libudev.h>
++#include <libudev.h>
+#else
+#include <termios.h>
+#endif
-
++
#define RESET_RELATIVE(ds) do { (ds).relwheel = 0; } while (0)
+ /* resolution in points/m */
@@ -192,10 +197,15 @@ static int wcmSerialValidate(InputInfoPt
static Bool isdv4Detect(InputInfoPtr pInfo)
diff --git a/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
index 434afaf0dc84..38f72b713dc6 100644
--- a/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
+++ b/x11-drivers/xf86-input-wacom/files/patch-test-fake-symbols.c
@@ -48,7 +48,7 @@
@@ -506,6 +518,7 @@ xf86UnblockSIGIO (int wasset)
/* This is not the same as the X server one, but it'll do for the tests */
- #if HAVE_XF86OPTIONPTR
+ #if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
+#define InputOption InputOption_custom
typedef struct _InputOption {
struct _InputOption *next;
diff --git a/x11-drivers/xf86-input-wacom/files/pkg-message.in b/x11-drivers/xf86-input-wacom/files/pkg-message.in
index f3c3350647e5..c0505094ffa8 100644
--- a/x11-drivers/xf86-input-wacom/files/pkg-message.in
+++ b/x11-drivers/xf86-input-wacom/files/pkg-message.in
@@ -12,7 +12,6 @@ into xorg.conf and add the following lines to ServerLayout section
InputDevice "wacom touch"
InputDevice "wacom pad"
-If moused(8) interferes with tablet input try adding the following
-line to /etc/rc.conf
-
- wacom_enable="YES"
+moused(8) may interfere with tablet input by attaching to fake /dev/ums*.
+To prevent that add a usb_quirk(4) then detach and attach the tablet.
+%%PREFIX%%/etc/rc.d/wacom is an example how preserve quirks across reboot.
diff --git a/x11-drivers/xf86-input-wacom/files/wacom.in b/x11-drivers/xf86-input-wacom/files/wacom.in
index e4ee87bdbff7..94639fd5ab53 100644
--- a/x11-drivers/xf86-input-wacom/files/wacom.in
+++ b/x11-drivers/xf86-input-wacom/files/wacom.in
@@ -22,11 +22,11 @@ load_rc_config "$name"
start_precmd="wacom_prepare"
start_cmd="wacom_start"
-stop_cmd=":"
+stop_cmd="wacom_stop"
wacom_prepare()
{
- kldload -n usb_quirk
+ load_kld -e usb_quirk usb_quirk
}
wacom_start()
@@ -36,4 +36,10 @@ wacom_start()
usbconfig add_dev_quirk_vplh 0x056a 0 0 0xffff UQ_UMS_IGNORE
}
+wacom_stop()
+{
+ usbconfig remove_dev_quirk_vplh 0x056a 0 0 0xffff UQ_MATCH_VENDOR_ONLY
+ usbconfig remove_dev_quirk_vplh 0x056a 0 0 0xffff UQ_UMS_IGNORE
+}
+
run_rc_command "$1"