aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-ati
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-09-29 17:01:41 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-09-29 17:01:41 +0000
commit5a4c543c2b0f538631aea8379ce384d5defee89d (patch)
tree108a55d148b3bc801facab0fb03b8666659c1136 /x11-drivers/xf86-video-ati
parent7231ff2710fcc89472994d2e2d235e74e9c8704c (diff)
downloadports-5a4c543c2b0f538631aea8379ce384d5defee89d.tar.gz
ports-5a4c543c2b0f538631aea8379ce384d5defee89d.zip
The FreeBSD graphics/x11 team proudly presents
a kwm, zeising production: MESA 9.1.6 Starring: Mesa 9.1.6, including libGL, libGLU and dri (new xorg only) Addition of libEGL and libglesv2 KMS support for ATI graphics cards in 10-current (new xorg only) Improved sparc64 support for new xorg. [1] pixman 0.30.2, including shlib bump and portrevision bumps libX11 1.6.2 Make absolute pointing devices work with x11-drivers/xf86-input-mouse x11-drivers/xf86-video-ati 7.2.0 for 10-current (KMS aware ati driver) Also starring: Updates to drivers and other libraries and utilities Additional notes: When updating MESA related ports (libGL, dri) you need to remove old versions first. See UPDATING for details. PR: ports/181962 [2] Submitted by: marius [1] zeising [2] Exp-run by: bdrewery Approved by: portmgr (bdrewery) Thanks to all who helped testing!
Notes
Notes: svn path=/head/; revision=328711
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/Makefile17
-rw-r--r--x11-drivers/xf86-video-ati/distinfo2
-rw-r--r--x11-drivers/xf86-video-ati/files/extra-src__radeon_kms.c20
-rw-r--r--x11-drivers/xf86-video-ati/files/patch-src__radeon_dri2.c11
-rw-r--r--x11-drivers/xf86-video-ati/pkg-plist14
5 files changed, 54 insertions, 10 deletions
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 8c2c583bb91d..d5e31957aa1a 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-ati
-PORTVERSION= 6.14.6
+PORTVERSION= ${ATI_VERSION}
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -12,7 +12,18 @@ XORG_CAT= driver
USE_XORG= xf86driproto xineramaproto xf86miscproto glproto
MAN4= ati.4x radeon.4x
+NO_STAGE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000051
+ATI_VERSION= 6.14.6
CONFIGURE_ARGS+=--disable-kms
+PLIST_SUB+= OLD=""
+.else
+ATI_VERSION= 7.2.0
+CONFIGURE_ARGS+=--disable-udev
+EXTRA_PATCHES+= ${FILESDIR}/extra-src__radeon_kms.c
+PLIST_SUB+= OLD="@comment "
+.endif
-NO_STAGE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-ati/distinfo b/x11-drivers/xf86-video-ati/distinfo
index baa6ed57a8e1..08cd56201512 100644
--- a/x11-drivers/xf86-video-ati/distinfo
+++ b/x11-drivers/xf86-video-ati/distinfo
@@ -1,2 +1,4 @@
SHA256 (xorg/driver/xf86-video-ati-6.14.6.tar.bz2) = aa5286b3e4f0187d7df14785c06dd800255d9405205dbf061da5d77df86bec36
SIZE (xorg/driver/xf86-video-ati-6.14.6.tar.bz2) = 1139495
+SHA256 (xorg/driver/xf86-video-ati-7.2.0.tar.bz2) = f30f5efdc8d7d18d06eda7ef2f91a8b7290f1cfbf6ff26362cd47ab8969daec4
+SIZE (xorg/driver/xf86-video-ati-7.2.0.tar.bz2) = 824613
diff --git a/x11-drivers/xf86-video-ati/files/extra-src__radeon_kms.c b/x11-drivers/xf86-video-ati/files/extra-src__radeon_kms.c
new file mode 100644
index 000000000000..c8ed5680a9ef
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/extra-src__radeon_kms.c
@@ -0,0 +1,20 @@
+--- src/radeon_kms.c.orig 2013-08-07 10:44:09.000000000 +0200
++++ src/radeon_kms.c 2013-08-31 01:20:44.370468797 +0200
+@@ -270,7 +270,7 @@
+ radeon_dirty_update(ScreenPtr screen)
+ {
+ RegionPtr region;
+- PixmapDirtyUpdatePtr ent;
++ PixmapDirtyUpdatePtr ent = NULL;
+
+ if (xorg_list_is_empty(&screen->pixmap_dirty_list))
+ return;
+@@ -606,7 +606,7 @@
+ dev->domain, dev->bus, dev->dev, dev->func);
+ #endif
+
+- info->dri2.drm_fd = drmOpen("radeon", busid);
++ info->dri2.drm_fd = drmOpen("radeonkms", busid);
+ if (info->dri2.drm_fd == -1) {
+
+ xf86DrvMsg(pScrn->scrnIndex, X_ERROR,
diff --git a/x11-drivers/xf86-video-ati/files/patch-src__radeon_dri2.c b/x11-drivers/xf86-video-ati/files/patch-src__radeon_dri2.c
new file mode 100644
index 000000000000..3de34a1b60ae
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/patch-src__radeon_dri2.c
@@ -0,0 +1,11 @@
+--- src/radeon_dri2.c.orig 2013-02-22 19:31:34.000000000 +0000
++++ src/radeon_dri2.c 2013-02-22 19:31:47.000000000 +0000
+@@ -578,7 +578,7 @@
+ radeon_dri2_client_state_changed(CallbackListPtr *ClientStateCallback, pointer data, pointer calldata)
+ {
+ DRI2ClientEventsPtr pClientEventsPriv;
+- DRI2FrameEventPtr ref;
++ DRI2FrameEventPtr ref = NULL;
+ NewClientInfoRec *clientinfo = calldata;
+ ClientPtr pClient = clientinfo->client;
+ pClientEventsPriv = GetDRI2ClientEvents(pClient);
diff --git a/x11-drivers/xf86-video-ati/pkg-plist b/x11-drivers/xf86-video-ati/pkg-plist
index 52b142182bbd..1c0799ff6e61 100644
--- a/x11-drivers/xf86-video-ati/pkg-plist
+++ b/x11-drivers/xf86-video-ati/pkg-plist
@@ -2,13 +2,13 @@ lib/xorg/modules/drivers/ati_drv.la
lib/xorg/modules/drivers/ati_drv.so
lib/xorg/modules/drivers/radeon_drv.la
lib/xorg/modules/drivers/radeon_drv.so
-lib/xorg/modules/multimedia/theatre200_drv.la
-lib/xorg/modules/multimedia/theatre200_drv.so
-lib/xorg/modules/multimedia/theatre_detect_drv.la
-lib/xorg/modules/multimedia/theatre_detect_drv.so
-lib/xorg/modules/multimedia/theatre_drv.la
-lib/xorg/modules/multimedia/theatre_drv.so
+%%OLD%%lib/xorg/modules/multimedia/theatre200_drv.la
+%%OLD%%lib/xorg/modules/multimedia/theatre200_drv.so
+%%OLD%%lib/xorg/modules/multimedia/theatre_detect_drv.la
+%%OLD%%lib/xorg/modules/multimedia/theatre_detect_drv.so
+%%OLD%%lib/xorg/modules/multimedia/theatre_drv.la
+%%OLD%%lib/xorg/modules/multimedia/theatre_drv.so
@dirrmtry lib/xorg/modules/drivers
-@dirrmtry lib/xorg/modules/multimedia
+%%OLD%%@dirrmtry lib/xorg/modules/multimedia
@dirrmtry lib/xorg/modules
@dirrmtry lib/xorg