aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-r128
diff options
context:
space:
mode:
authorMatthew Rezny <rezny@FreeBSD.org>2017-02-11 14:17:58 +0000
committerMatthew Rezny <rezny@FreeBSD.org>2017-02-11 14:17:58 +0000
commit3f87b5cb51a9164076426ff318d5d77c12b0ced3 (patch)
treef850017ca906c1f973d599485b77a7dceb60e2fc /x11-drivers/xf86-video-r128
parentce75c0657853608ceeaeda9f2d28dc0d2c634129 (diff)
downloadports-3f87b5cb51a9164076426ff318d5d77c12b0ced3.tar.gz
ports-3f87b5cb51a9164076426ff318d5d77c12b0ced3.zip
Notes
Diffstat (limited to 'x11-drivers/xf86-video-r128')
-rw-r--r--x11-drivers/xf86-video-r128/Makefile4
-rw-r--r--x11-drivers/xf86-video-r128/distinfo6
-rw-r--r--x11-drivers/xf86-video-r128/files/patch-src_r128__dri.c94
3 files changed, 99 insertions, 5 deletions
diff --git a/x11-drivers/xf86-video-r128/Makefile b/x11-drivers/xf86-video-r128/Makefile
index ef1475181fec..373b769092bb 100644
--- a/x11-drivers/xf86-video-r128/Makefile
+++ b/x11-drivers/xf86-video-r128/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-r128
-PORTVERSION= 6.10.1
+PORTVERSION= 6.10.2
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
@@ -12,6 +12,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GL= gl
XORG_CAT= driver
-USE_XORG= glproto xf86driproto xf86miscproto xineramaproto
+USE_XORG= xf86miscproto
.include <bsd.port.mk>
diff --git a/x11-drivers/xf86-video-r128/distinfo b/x11-drivers/xf86-video-r128/distinfo
index ea6992af9102..c27642f6b7db 100644
--- a/x11-drivers/xf86-video-r128/distinfo
+++ b/x11-drivers/xf86-video-r128/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484351416
-SHA256 (xorg/driver/xf86-video-r128-6.10.1.tar.bz2) = 5ebfef49831c9b12f7b7011c8314010596ac2ab0d5b9b7cfd17908e93d7de4ea
-SIZE (xorg/driver/xf86-video-r128-6.10.1.tar.bz2) = 495306
+TIMESTAMP = 1484717021
+SHA256 (xorg/driver/xf86-video-r128-6.10.2.tar.bz2) = 84da21517f3af7617fdf341e84ccb22444d6cdab1647e4808fa631528b9a77de
+SIZE (xorg/driver/xf86-video-r128-6.10.2.tar.bz2) = 504031
diff --git a/x11-drivers/xf86-video-r128/files/patch-src_r128__dri.c b/x11-drivers/xf86-video-r128/files/patch-src_r128__dri.c
new file mode 100644
index 000000000000..837ad0aa1047
--- /dev/null
+++ b/x11-drivers/xf86-video-r128/files/patch-src_r128__dri.c
@@ -0,0 +1,94 @@
+# Correct type in format strings
+#
+--- src/r128_dri.c.orig 2017-01-17 22:42:44 UTC
++++ src/r128_dri.c
+@@ -500,7 +500,7 @@ static Bool R128DRIAgpInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[agp] %d kB allocated with handle 0x%08x\n",
++ "[agp] %d kB allocated with handle 0x%08lx\n",
+ info->agpSize*1024, info->agpMemHandle);
+
+ if (drmAgpBind(info->drmFD, info->agpMemHandle, info->agpOffset) < 0) {
+@@ -540,7 +540,7 @@ static Bool R128DRIAgpInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[agp] ring handle = 0x%08x\n", info->ringHandle);
++ "[agp] ring handle = 0x%08lx\n", info->ringHandle);
+
+ if (drmMap(info->drmFD, info->ringHandle, info->ringMapSize,
+ &info->ring) < 0) {
+@@ -558,7 +558,7 @@ static Bool R128DRIAgpInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[agp] ring read ptr handle = 0x%08x\n",
++ "[agp] ring read ptr handle = 0x%08lx\n",
+ info->ringReadPtrHandle);
+
+ if (drmMap(info->drmFD, info->ringReadPtrHandle, info->ringReadMapSize,
+@@ -578,7 +578,7 @@ static Bool R128DRIAgpInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[agp] vertex/indirect buffers handle = 0x%08x\n",
++ "[agp] vertex/indirect buffers handle = 0x%08lx\n",
+ info->bufHandle);
+
+ if (drmMap(info->drmFD, info->bufHandle, info->bufMapSize,
+@@ -598,7 +598,7 @@ static Bool R128DRIAgpInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[agp] AGP texture map handle = 0x%08x\n",
++ "[agp] AGP texture map handle = 0x%08lx\n",
+ info->agpTexHandle);
+
+ if (drmMap(info->drmFD, info->agpTexHandle, info->agpTexMapSize,
+@@ -660,7 +660,7 @@ static Bool R128DRIPciInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[pci] %d kB allocated with handle 0x%08x\n",
++ "[pci] %d kB allocated with handle 0x%08lx\n",
+ info->agpSize*1024, info->pciMemHandle);
+
+ /* Initialize the CCE ring buffer data */
+@@ -684,7 +684,7 @@ static Bool R128DRIPciInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[pci] ring handle = 0x%08x\n", info->ringHandle);
++ "[pci] ring handle = 0x%08lx\n", info->ringHandle);
+
+ if (drmMap(info->drmFD, info->ringHandle, info->ringMapSize,
+ &info->ring) < 0) {
+@@ -705,7 +705,7 @@ static Bool R128DRIPciInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[pci] ring read ptr handle = 0x%08x\n",
++ "[pci] ring read ptr handle = 0x%08lx\n",
+ info->ringReadPtrHandle);
+
+ if (drmMap(info->drmFD, info->ringReadPtrHandle, info->ringReadMapSize,
+@@ -728,7 +728,7 @@ static Bool R128DRIPciInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[pci] vertex/indirect buffers handle = 0x%08x\n",
++ "[pci] vertex/indirect buffers handle = 0x%08lx\n",
+ info->bufHandle);
+
+ if (drmMap(info->drmFD, info->bufHandle, info->bufMapSize,
+@@ -829,7 +829,7 @@ static Bool R128DRIMapInit(R128InfoPtr i
+ return FALSE;
+ }
+ xf86DrvMsg(pScreen->myNum, X_INFO,
+- "[drm] register handle = 0x%08x\n", info->registerHandle);
++ "[drm] register handle = 0x%08lx\n", info->registerHandle);
+
+ return TRUE;
+ }