aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers/xf86-video-sis
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-10-13 07:45:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-10-13 07:45:08 +0000
commit1742c4fbeed8c5d75f7b54b49c5a7607e6453f40 (patch)
tree5c1588bcc55dc0d528b29233e0611c59fb10d358 /x11-drivers/xf86-video-sis
parentc783d50e7fee5084aebe410ba68270885f073586 (diff)
downloadports-1742c4fbeed8c5d75f7b54b49c5a7607e6453f40.tar.gz
ports-1742c4fbeed8c5d75f7b54b49c5a7607e6453f40.zip
Xorg-server update to 1.17.2 with related driver updates and bumps.
Update fontproto to 2.1.3. Update libXfont to 1.5.1. Update xf86-input-keyboard 1.8.1. Update xf86-input-vmmouse to 13.1.0. Update xf86-input-void to 1.4.1. Update xf86-video-chips to 1.2.6. Update xf86-video-cirrus to 1.5.3. Update xf86-video-mach64 to 6.9.5. Update xf86-video-neomagic to 1.2.9. Update xf86-video-r128 to 6.10.0. Update xf86-video-s3virge to 1.10.7. Update xf86-video-savage to 2.3.8. Update xf86-video-siliconmotion to 1.7.8. Update xf86-video-sis to 0.10.8. Update xf86-video-trident to 1.3.7. Update xf86-video-vesa to 2.3.4. * All other xf86-* drivers where bump and/or patched to allow them to compile and work with the new xorg-server. * The ATI-ums driver is removed because the API it depends on was removed from the xorg-server. * Add patch to sunffb to make the lack of XAA non-fatal (not build/run tested due to lack of hardware). * Remove the extra patches in xorg-server for arm. The code seems to support it now natively. Please file a bug if this is not the case. * Update the xorg-server support in virtualbox-ose-additions for vboxmouse. [1] Submitted by: jkim@ [1] Obtained from: Graphics devel repo
Notes
Notes: svn path=/head/; revision=399179
Diffstat (limited to 'x11-drivers/xf86-video-sis')
-rw-r--r--x11-drivers/xf86-video-sis/Makefile3
-rw-r--r--x11-drivers/xf86-video-sis/distinfo4
-rw-r--r--x11-drivers/xf86-video-sis/files/patch-src_sis__driver.c35
3 files changed, 6 insertions, 36 deletions
diff --git a/x11-drivers/xf86-video-sis/Makefile b/x11-drivers/xf86-video-sis/Makefile
index caf13364f693..60e1c9bebc11 100644
--- a/x11-drivers/xf86-video-sis/Makefile
+++ b/x11-drivers/xf86-video-sis/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= xf86-video-sis
-PORTVERSION= 0.10.7
-PORTREVISION= 5
+PORTVERSION= 0.10.8
CATEGORIES= x11-drivers
MAINTAINER= x11@FreeBSD.org
diff --git a/x11-drivers/xf86-video-sis/distinfo b/x11-drivers/xf86-video-sis/distinfo
index 7a8c42ed1fea..a3f0744fe587 100644
--- a/x11-drivers/xf86-video-sis/distinfo
+++ b/x11-drivers/xf86-video-sis/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/driver/xf86-video-sis-0.10.7.tar.bz2) = be2eb6acba081e88dabc5be9db379e3da89a4d4edeb68064f204bf343a411cd0
-SIZE (xorg/driver/xf86-video-sis-0.10.7.tar.bz2) = 699499
+SHA256 (xorg/driver/xf86-video-sis-0.10.8.tar.bz2) = c8f3f2577f69334dfcc4bf96477dce45161170555f3abdfa105599e61bc7d3fe
+SIZE (xorg/driver/xf86-video-sis-0.10.8.tar.bz2) = 734785
diff --git a/x11-drivers/xf86-video-sis/files/patch-src_sis__driver.c b/x11-drivers/xf86-video-sis/files/patch-src_sis__driver.c
index a42b69bce79f..df6ac872fab4 100644
--- a/x11-drivers/xf86-video-sis/files/patch-src_sis__driver.c
+++ b/x11-drivers/xf86-video-sis/files/patch-src_sis__driver.c
@@ -1,27 +1,6 @@
---- src/sis_driver.c.orig 2012-07-17 05:20:28 UTC
-+++ src/sis_driver.c
-@@ -57,7 +57,6 @@
- #include "fb.h"
- #include "micmap.h"
- #include "mipointer.h"
--#include "mibstore.h"
- #include "edid.h"
-
- #define SIS_NEED_inSISREG
-@@ -8859,7 +8858,6 @@ SISScreenInit(SCREEN_INIT_ARGS_DECL)
- }
- pSiS->SiSFastVidCopyDone = TRUE;
-
-- miInitializeBackingStore(pScreen);
- xf86SetBackingStore(pScreen);
- xf86SetSilkenMouse(pScreen);
-
-@@ -9351,11 +9349,12 @@ SISMergedPointerMoved(SCRN_ARG_TYPE arg,
- }
- }
- if(doit) {
-+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 20 /* screw it */
- sigstate = xf86BlockSIGIO();
+--- src/sis_driver.c.orig 2015-09-23 09:54:07.196489000 +0200
++++ src/sis_driver.c 2015-09-23 09:56:45.740035000 +0200
+@@ -9390,7 +9390,7 @@ SISMergedPointerMoved(SCRN_ARG_TYPE arg,
#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 15
{
double dx = x, dy = y;
@@ -30,11 +9,3 @@
x = (int)dx;
y = (int)dy;
}
-@@ -9368,6 +9367,7 @@ SISMergedPointerMoved(SCRN_ARG_TYPE arg,
- miPointerAbsoluteCursor(x, y, currentTime.milliseconds);
- #endif
- xf86UnblockSIGIO(sigstate);
-+#endif
- return;
- }
- }