aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-07-26 21:25:17 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-07-26 21:25:17 +0000
commit9a1e4f44e6b0bfcd42949abe6e197b45137b937a (patch)
treeea3d426aec4a67d0aa7e66163010c9c9d98e3be4 /x11-drivers
parent13700c66d03426f4e893a690e25d2140e633ff63 (diff)
downloadports-9a1e4f44e6b0bfcd42949abe6e197b45137b937a.tar.gz
ports-9a1e4f44e6b0bfcd42949abe6e197b45137b937a.zip
Build xorg AMD video drivers on aarch64
They build and work fine with drm-devel-kmod Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=543498
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-amdgpu/Makefile4
-rw-r--r--x11-drivers/xf86-video-ati/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/Makefile b/x11-drivers/xf86-video-amdgpu/Makefile
index 61f7053b4b25..424b53f77018 100644
--- a/x11-drivers/xf86-video-amdgpu/Makefile
+++ b/x11-drivers/xf86-video-amdgpu/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= libdrm_amdgpu.so:graphics/libdrm
USES= gl xorg-cat:driver
USE_GL= gbm
# No amdgpu kernel driver on non-x86 and PC98.
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86
+ONLY_FOR_ARCHS= aarch64 i386 amd64
+ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86/arm64
CONFIGURE_ARGS+=--disable-udev
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 654000f33577..7e24b8e57612 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -19,8 +19,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
# No Radeon kernel driver on non-x86.
-ONLY_FOR_ARCHS= amd64 i386 powerpc64
-ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86
+ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc64
+ONLY_FOR_ARCHS_REASON= KMS is required and currently only available on x86/arm64/powerpc64
LIB_DEPENDS= libpciaccess.so:devel/libpciaccess \
libdrm_radeon.so:graphics/libdrm