aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-01 04:46:24 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-10-01 04:46:24 +0000
commit150dd1538274905c47174fa748d393461d8cec39 (patch)
tree10910389af9375839bfd51ed910ec36241265a55 /x11-fm/thunar
parent4f0d956d5c072d95fa6342dfd365a3fcff6fd536 (diff)
downloadports-150dd1538274905c47174fa748d393461d8cec39.tar.gz
ports-150dd1538274905c47174fa748d393461d8cec39.zip
x11-fm/thunar: fix build on GCC architectures
Use C11 compiler: In file included from /usr/local/include/xfce4/libxfce4util/libxfce4util.h:33, from /usr/local/include/exo-2/exo/exo-enum-types.h:6, from /usr/local/include/exo-2/exo/exo.h:39, from ../thunar/thunar-enum-types.h:24, from ../thunar/thunar-file.h:28, from ../thunar/thunar-chooser-button.h:23, from thunar-chooser-button.c:27: /usr/local/include/xfce4/libxfce4util/xfce-kiosk.h:37: error: redefinition of typedef 'XfceKiosk' Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=513452
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index c2fdb0bbb656..2656cd3460f6 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -18,8 +18,8 @@ LICENSE_FILE_LGPL20= ${WRKSRC}/COPYING.LIB
LIB_DEPENDS= libtumbler-1.so:deskutils/xfce4-tumbler
RUN_DEPENDS= pkexec:sysutils/polkit
-USES= desktop-file-utils gettext-tools gmake gnome libtool pathfix \
- perl5 pkgconfig tar:bzip2 xfce xorg
+USES= compiler:c11 desktop-file-utils gettext-tools gmake gnome \
+ libtool pathfix perl5 pkgconfig tar:bzip2 xfce xorg
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool
USE_LDCONFIG= yes
USE_XFCE= libexo