aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-07-16 13:25:15 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-07-16 13:25:15 +0000
commit50d41959418b9db38b190b3951b74a734972afde (patch)
tree7518e4f9f0646ac0d61086f50ec09566fdf6ac53 /x11-fm/thunar
parent446bef763b1a025b3a4fe1a9502790b975f6917c (diff)
downloadports-50d41959418b9db38b190b3951b74a734972afde.tar.gz
ports-50d41959418b9db38b190b3951b74a734972afde.zip
Import patch merged upstream to fix sporadic crashes caused by an
incorrect assertion in the cose. PR: 247961 Submitted by: rozhuk.im@gmail.com MFH: 2020Q3
Notes
Notes: svn path=/head/; revision=542357
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile1
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-list-model.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index ec9c74d28654..acc82d24bd2f 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunar
DISTVERSION= 1.8.15
+PORTREVISION= 1
CATEGORIES= x11-fm xfce
MASTER_SITES= XFCE
DIST_SUBDIR= xfce4
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-list-model.c b/x11-fm/thunar/files/patch-thunar_thunar-list-model.c
new file mode 100644
index 000000000000..723de73686b0
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-list-model.c
@@ -0,0 +1,11 @@
+--- thunar/thunar-list-model.c.orig 2020-05-24 12:27:08 UTC
++++ thunar/thunar-list-model.c
+@@ -705,7 +705,7 @@ thunar_list_model_get_value (GtkTreeModel *model,
+ _thunar_return_if_fail (iter->stamp == (THUNAR_LIST_MODEL (model))->stamp);
+
+ file = g_sequence_get (iter->user_data);
+- _thunar_assert (THUNAR_IS_FILE (file));
++ _thunar_return_if_fail (THUNAR_IS_FILE (file));
+
+ switch (column)
+ {