aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-03-05 22:52:30 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-03-05 22:52:30 +0000
commit86e4cb7cb047c17951de23b2ebea9c14d0f76af2 (patch)
tree0f1a4d58acfbb6944387e341f218a018154dc4ad /x11-fm/thunar
parent507a1eba6aabfd52efceabca5986a46398cfa02f (diff)
downloadports-86e4cb7cb047c17951de23b2ebea9c14d0f76af2.tar.gz
ports-86e4cb7cb047c17951de23b2ebea9c14d0f76af2.zip
The FreeBSD Xfce team proudly presents Xfce 4.12.
Announce: http://www.xfce.org/about/news/?post=1425081600 Global changes: - Switch to USES= xfce (D677) - Reorganize options helper - Fix USES= gettext-* when NLS option is not set [1], [2] - Add LICENSE (when missing) Update: - to 4.12 (core components) - audio/xfce4-mpc-plugin to 0.4.5 - deskutils/xfce4-tumbler to 0.1.31 - deskutils/xfce4-xkb-plugin to 0.7.1 - editors/mousepad to 0.4.0 - graphics/ristretto to 0.8.0 - multimedia/xfce4-parole to 0.8.0 - sysutils/garcon to 0.4.0 - sysutils/xfce4-diskperf-plugin to 2.5.5 [3] - sysutils/xfce4-fsguard-plugin to 1.0.2 - sysutils/xfce4-power-manager to 1.4.3 - sysutils/xfce4-wavelan-plugin to 0.5.12 - x11/libexo to 0.10.3 - x11-fm/thunar to 1.6.6 - x11-themes/gtk-xfce-engine to 3.2.0 PR: 196003 [1], 197251 [2], 198132 Differential Revision: https://reviews.freebsd.org/D677 Submitted by: Kamil Szczesny [1], amdmi3@ [2], myself Exp-run by: antoine@ Approved by: danilo@ (maintainer) [3] Tested by: Ivan <enitarzi@gmail.com>
Notes
Notes: svn path=/head/; revision=380565
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile99
-rw-r--r--x11-fm/thunar/distinfo4
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-launcher.c34
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c13
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-standard-view.c13
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-templates-action.c21
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-tree-view.c25
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-window.c15
-rw-r--r--x11-fm/thunar/pkg-plist14
9 files changed, 30 insertions, 208 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 302b557ff2c7..e8a39103c0d3 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= Thunar
-PORTVERSION= 1.6.4
-PORTREVISION= 1
+PORTVERSION= 1.6.6
CATEGORIES= x11-fm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR= src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
@@ -24,15 +22,15 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_GNOME= gtk20 intltool intlhack gdkpixbuf2
USE_LDCONFIG= yes
-USE_XFCE= configenv libexo libmenu libutil xfconf
+USE_XFCE= libexo
USE_XORG= sm x11
USES= desktop-file-utils gmake pathfix perl5 libtool pkgconfig \
- tar:bzip2
+ gettext-tools xfce tar:bzip2
OPTIONS_DEFINE= GVFS NLS NOTIFY STARTUP
OPTIONS_GROUP= PLUGINS
OPTIONS_GROUP_PLUGINS= PLUG_APR PLUG_SBR PLUG_TPA PLUG_UCA PLUG_WALL
-OPTIONS_DEFAULT= GVFS NOTIFY PLUG_APR PLUG_SBR PLUG_UCA PLUG_TPA STARTUP
+OPTIONS_DEFAULT= GVFS NOTIFY PLUG_APR PLUG_SBR PLUG_UCA PLUG_TPA PLUG_WALL STARTUP
# Override NOTIFY_DESC
NOTIFY_DESC= Display notifications
@@ -43,83 +41,28 @@ PLUG_TPA_DESC= Trash Panel Applet plugin
PLUG_UCA_DESC= User Customizable Actions plugin
PLUG_WALL_DESC= Wallpaper plugin
+GVF_USE= gnome=gvfs
+NLS_USES= gettext-runtime
+NLS_CONFIGURE_ENABLE= nls
+NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+NOTIFY_CONFIGURE_ENABLE= notifications
+STARTUP_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
+STARTUP_CONFIGURE_ENABLE= startup-notification
+PLUG_APR_LIB_DEPENDS= libexif.so:${PORTSDIR}/graphics/libexif
+PLUG_APR_CONFIGURE_ENABLE= apr-plugin exif
+PLUG_SBR_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
+PLUG_SBR_CONFIGURE_ENABLE= sbr-plugin pcre
+PLUG_TPA_USE= xfce=panel
+PLUG_TPA_CONFIGURE_ENABLE= tpa-plugin
+PLUG_UCA_CONFIGURE_ENABLE= uca-plugin
+PLUG_WALL_CONFIGURE_ENABLE= wallpaper-plugin
+OPTIONS_SUB= yes
+
CONFIGURE_ARGS+=--enable-gio-unix \
--disable-gudev \
--enable-dbus \
--without-html-dir
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
-CONFIGURE_ARGS+=--enable-notifications
-.else
-CONFIGURE_ARGS+=--disable-notifications
-.endif
-
-.if ${PORT_OPTIONS:MPLUG_APR}
-LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
-CONFIGURE_ARGS+=--enable-apr-plugin --enable-exif
-PLIST_SUB+= PLUGIN_APR=""
-.else
-CONFIGURE_ARGS+=--disable-apr-plugin --disable-exif
-PLIST_SUB+= PLUGIN_APR="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPLUG_SBR}
-LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
-CONFIGURE_ARGS+=--enable-sbr-plugin --enable-pcre
-PLIST_SUB+= PLUGIN_SBR=""
-.else
-CONFIGURE_ARGS+=--disable-sbr-plugin --disable-pcre
-PLIST_SUB+= PLUGIN_SBR="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPLUG_TPA}
-CONFIGURE_ARGS+=--enable-tpa-plugin
-PLIST_SUB+= PLUGIN_TPA=""
-USE_XFCE+= panel
-.else
-CONFIGURE_ARGS+=--disable-tpa-plugin
-PLIST_SUB+= PLUGIN_TPA="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPLUG_UCA}
-CONFIGURE_ARGS+=--enable-uca-plugin
-PLIST_SUB+= PLUGIN_UCA=""
-.else
-CONFIGURE_ARGS+=--disable-uca-plugin
-PLIST_SUB+= PLUGIN_UCA="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPLUG_WALL}
-CONFIGURE_ARGS+=--enable-wallpaper-plugin
-PLIST_SUB+= PLUGIN_WALL=""
-.else
-CONFIGURE_ARGS+=--disable-wallpaper-plugin
-PLIST_SUB+= PLUGIN_WALL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MSTARTUP}
-LIB_DEPENDS+= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
-CONFIGURE_ARGS+=--enable-startup-notification
-.else
-CONFIGURE_ARGS+=--disable-startup-notification
-.endif
-
-.if ${PORT_OPTIONS:MGVFS}
-USE_GNOME+=gvfs
-.endif
-
post-patch:
${REINPLACE_CMD} -e 's|internet-mail|mail-send|' \
${WRKSRC}/plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
diff --git a/x11-fm/thunar/distinfo b/x11-fm/thunar/distinfo
index 59711573ab06..6f2a0069fca3 100644
--- a/x11-fm/thunar/distinfo
+++ b/x11-fm/thunar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/Thunar-1.6.4.tar.bz2) = 40efc74349313c20cef2047842a06ad8dfc8522ed792a087e9fb4618ad309dae
-SIZE (xfce4/Thunar-1.6.4.tar.bz2) = 2064286
+SHA256 (xfce4/Thunar-1.6.6.tar.bz2) = b9a55104b18ae01c5190d7ea02cbd7ba56d7affed9df416bf7fec6dff2d889b2
+SIZE (xfce4/Thunar-1.6.6.tar.bz2) = 2160158
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-launcher.c b/x11-fm/thunar/files/patch-thunar_thunar-launcher.c
deleted file mode 100644
index 8fd8e1442a22..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-launcher.c
+++ /dev/null
@@ -1,34 +0,0 @@
-Right click context menu with wrong icon (bug #10652)
-
---- thunar/thunar-launcher.c.orig 2013-12-18 23:41:57 UTC
-+++ thunar/thunar-launcher.c
-@@ -815,8 +815,9 @@ thunar_launcher_update_idle (gpointer da
- ** - "Open", "Open in n New Windows" and "Open in n New Tabs" actions
- **/
-
-- /* Prepare "Open" label */
-+ /* Prepare "Open" label and icon */
- gtk_action_set_label (launcher->action_open, _("_Open"));
-+ gtk_action_set_stock_id (launcher->action_open, GTK_STOCK_OPEN);
-
- if (n_selected_files == n_directories && n_directories >= 1)
- {
-@@ -928,6 +929,7 @@ thunar_launcher_update_idle (gpointer da
- /* turn the "Open" action into "Execute" */
- g_object_set (G_OBJECT (launcher->action_open),
- "label", _("_Execute"),
-+ "stock-id", GTK_STOCK_EXECUTE,
- "tooltip", ngettext ("Execute the selected file", "Execute the selected files", n_selected_files),
- NULL);
- }
-@@ -945,6 +947,10 @@ thunar_launcher_update_idle (gpointer da
- g_free (tooltip);
- g_free (label);
-
-+ /* load default application icon */
-+ gtk_action_set_stock_id (launcher->action_open, NULL);
-+ gtk_action_set_gicon (launcher->action_open, g_app_info_get_icon (applications->data));
-+
- /* remember the default application for the "Open" action */
- g_object_set_qdata_full (G_OBJECT (launcher->action_open), thunar_launcher_handler_quark, applications->data, g_object_unref);
-
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c b/x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c
deleted file mode 100644
index ee60b455a521..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Right click context menu with wrong icon (bug #10652)
-
---- thunar/thunar-location-buttons.c.orig 2013-12-18 23:41:57 UTC
-+++ thunar/thunar-location-buttons.c
-@@ -175,7 +175,7 @@ static const GtkActionEntry action_entri
- { "location-buttons-open", GTK_STOCK_OPEN, N_("_Open"), "", NULL, G_CALLBACK (thunar_location_buttons_action_open), },
- { "location-buttons-open-in-new-tab", NULL, N_("Open in New Tab"), "", NULL, G_CALLBACK (thunar_location_buttons_action_open_in_new_tab), },
- { "location-buttons-open-in-new-window", NULL, N_("Open in New Window"), "", NULL, G_CALLBACK (thunar_location_buttons_action_open_in_new_window), },
-- { "location-buttons-create-folder", NULL, N_("Create _Folder..."), "", NULL, G_CALLBACK (thunar_location_buttons_action_create_folder), },
-+ { "location-buttons-create-folder", "folder-new", N_("Create _Folder..."), "", NULL, G_CALLBACK (thunar_location_buttons_action_create_folder), },
- { "location-buttons-empty-trash", NULL, N_("_Empty Trash"), "", N_("Delete all files and folders in the Trash"), G_CALLBACK (thunar_location_buttons_action_empty_trash), },
- { "location-buttons-paste-into-folder", GTK_STOCK_PASTE, N_("Paste Into Folder"), "", NULL, G_CALLBACK (thunar_location_buttons_action_paste_into_folder), },
- { "location-buttons-properties", GTK_STOCK_PROPERTIES, N_("_Properties..."), "", NULL, G_CALLBACK (thunar_location_buttons_action_properties), },
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-standard-view.c b/x11-fm/thunar/files/patch-thunar_thunar-standard-view.c
deleted file mode 100644
index 06659ae6fce9..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-standard-view.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Right click context menu with wrong icon (bug #10652)
-
---- thunar/thunar-standard-view.c.orig 2014-12-20 00:21:57 UTC
-+++ thunar/thunar-standard-view.c
-@@ -393,7 +393,7 @@ static const GtkActionEntry action_entri
- {
- { "file-context-menu", NULL, N_ ("File Context Menu"), NULL, NULL, NULL, },
- { "folder-context-menu", NULL, N_ ("Folder Context Menu"), NULL, NULL, NULL, },
-- { "create-folder", NULL, N_ ("Create _Folder..."), "<control><shift>N", N_ ("Create an empty folder within the current folder"), G_CALLBACK (thunar_standard_view_action_create_folder), },
-+ { "create-folder", "folder-new", N_ ("Create _Folder..."), "<control><shift>N", N_ ("Create an empty folder within the current folder"), G_CALLBACK (thunar_standard_view_action_create_folder), },
- { "properties", GTK_STOCK_PROPERTIES, N_ ("_Properties..."), "<alt>Return", N_ ("View the properties of the selected file"), G_CALLBACK (thunar_standard_view_action_properties), },
- { "cut", GTK_STOCK_CUT, N_ ("Cu_t"), NULL, NULL, G_CALLBACK (thunar_standard_view_action_cut), },
- { "copy", GTK_STOCK_COPY, N_ ("_Copy"), NULL, NULL, G_CALLBACK (thunar_standard_view_action_copy), },
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-templates-action.c b/x11-fm/thunar/files/patch-thunar_thunar-templates-action.c
deleted file mode 100644
index adc63072d5f6..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-templates-action.c
+++ /dev/null
@@ -1,21 +0,0 @@
-Right click context menu with wrong icon (bug #10652)
-
---- thunar/thunar-templates-action.c.orig 2013-12-18 23:41:57 UTC
-+++ thunar/thunar-templates-action.c
-@@ -477,7 +477,7 @@ thunar_templates_action_load_finished (T
- gtk_widget_show (item);
-
- /* add the icon for the emtpy file item */
-- image = gtk_image_new_from_stock (GTK_STOCK_NEW, GTK_ICON_SIZE_MENU);
-+ image = gtk_image_new_from_stock (GTK_STOCK_FILE, GTK_ICON_SIZE_MENU);
- gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM (item), image);
- }
-
-@@ -542,6 +542,7 @@ thunar_templates_action_new (const gchar
- "hide-if-empty", FALSE,
- "label", label,
- "name", name,
-+ "icon-name", "document-new",
- NULL);
- }
-
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-tree-view.c b/x11-fm/thunar/files/patch-thunar_thunar-tree-view.c
deleted file mode 100644
index 7ef0e67571ef..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-tree-view.c
+++ /dev/null
@@ -1,25 +0,0 @@
-Right click context menu with wrong icon (bug #10652)
-
---- thunar/thunar-tree-view.c.orig 2013-12-18 23:41:57 UTC
-+++ thunar/thunar-tree-view.c
-@@ -1093,6 +1093,7 @@ thunar_tree_view_context_menu (ThunarTre
- GtkWidget *menu;
- GtkWidget *item;
- GtkWidget *window;
-+ GIcon *icon;
- GList *providers, *lp;
- GList *actions = NULL, *tmp;
-
-@@ -1201,6 +1202,12 @@ thunar_tree_view_context_menu (ThunarTre
- g_signal_connect_swapped (G_OBJECT (item), "activate", G_CALLBACK (thunar_tree_view_action_create_folder), view);
- gtk_menu_shell_append (GTK_MENU_SHELL (menu), item);
- gtk_widget_show (item);
-+
-+ /* set the stock icon */
-+ icon = g_themed_icon_new ("folder-new");
-+ image = gtk_image_new_from_gicon (icon, GTK_ICON_SIZE_MENU);
-+ gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM (item), image);
-+ g_object_unref (icon);
-
- /* append a separator item */
- item = gtk_separator_menu_item_new ();
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-window.c b/x11-fm/thunar/files/patch-thunar_thunar-window.c
deleted file mode 100644
index acc4dbc6a31c..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-window.c
+++ /dev/null
@@ -1,15 +0,0 @@
-Right click context menu with wrong icon (bug #10652)
-
---- thunar/thunar-window.c.orig 2013-12-18 23:41:57 UTC
-+++ thunar/thunar-window.c
-@@ -345,8 +345,8 @@ struct _ThunarWindow
- static GtkActionEntry action_entries[] =
- {
- { "file-menu", NULL, N_ ("_File"), NULL, },
-- { "new-tab", NULL, N_ ("New _Tab"), "<control>T", N_ ("Open a new tab for the displayed location"), G_CALLBACK (thunar_window_action_open_new_tab), },
-- { "new-window", NULL, N_ ("New _Window"), "<control>N", N_ ("Open a new Thunar window for the displayed location"), G_CALLBACK (thunar_window_action_open_new_window), },
-+ { "new-tab", "tab-new", N_ ("New _Tab"), "<control>T", N_ ("Open a new tab for the displayed location"), G_CALLBACK (thunar_window_action_open_new_tab), },
-+ { "new-window", "window-new", N_ ("New _Window"), "<control>N", N_ ("Open a new Thunar window for the displayed location"), G_CALLBACK (thunar_window_action_open_new_window), },
- { "sendto-menu", NULL, N_ ("_Send To"), NULL, },
- { "empty-trash", NULL, N_ ("_Empty Trash"), NULL, N_ ("Delete all files and folders in the Trash"), G_CALLBACK (thunar_window_action_empty_trash), },
- { "detach-tab", NULL, N_ ("Detac_h Tab"), NULL, N_ ("Open current folder in a new window"), G_CALLBACK (thunar_window_action_detach_tab), },
diff --git a/x11-fm/thunar/pkg-plist b/x11-fm/thunar/pkg-plist
index 5650b1ea1752..f61a28bf1241 100644
--- a/x11-fm/thunar/pkg-plist
+++ b/x11-fm/thunar/pkg-plist
@@ -1,7 +1,7 @@
bin/Thunar
bin/thunar
bin/thunar-settings
-%%PLUGIN_UCA%%etc/xdg/Thunar/uca.xml
+%%PLUG_UCA%%etc/xdg/Thunar/uca.xml
include/thunarx-2/thunarx/thunarx-config.h
include/thunarx-2/thunarx/thunarx-file-info.h
include/thunarx-2/thunarx/thunarx-menu-provider.h
@@ -18,11 +18,11 @@ lib/Thunar/thunar-sendto-email
lib/libthunarx-2.so
lib/libthunarx-2.so.0
lib/libthunarx-2.so.0.0.0
-%%PLUGIN_APR%%lib/thunarx-2/thunar-apr.so
-%%PLUGIN_SBR%%lib/thunarx-2/thunar-sbr.so
-%%PLUGIN_UCA%%lib/thunarx-2/thunar-uca.so
-%%PLUGIN_WALL%%lib/thunarx-2/thunar-wallpaper-plugin.so
-%%PLUGIN_TPA%%lib/xfce4/panel/plugins/libthunar-tpa.so
+%%PLUG_APR%%lib/thunarx-2/thunar-apr.so
+%%PLUG_SBR%%lib/thunarx-2/thunar-sbr.so
+%%PLUG_UCA%%lib/thunarx-2/thunar-uca.so
+%%PLUG_WALL%%lib/thunarx-2/thunar-wallpaper-plugin.so
+%%PLUG_TPA%%lib/xfce4/panel/plugins/libthunar-tpa.so
libdata/pkgconfig/thunarx-2.pc
man/man1/Thunar.1.gz
share/Thunar/sendto/thunar-sendto-email.desktop
@@ -106,4 +106,4 @@ share/icons/hicolor/scalable/apps/Thunar.svg
%%NLS%%share/locale/zh_TW/LC_MESSAGES/Thunar.mo
share/pixmaps/Thunar/Thunar-about-logo.png
share/polkit-1/actions/org.xfce.thunar.policy
-%%PLUGIN_TPA%%share/xfce4/panel-plugins/thunar-tpa.desktop
+%%PLUG_TPA%%share/xfce4/panel/plugins/thunar-tpa.desktop