aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-05-23 04:42:03 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-05-23 04:42:03 +0000
commita4c01503541ca144f8cf00d9609161c42bb633ed (patch)
treee8e10d4e0780fa563e3121ca7e7d5a19098518ab /x11-fm/thunar
parent746bb1a44a56d167af5e3146b2ed48d40511e6b9 (diff)
downloadports-a4c01503541ca144f8cf00d9609161c42bb633ed.tar.gz
ports-a4c01503541ca144f8cf00d9609161c42bb633ed.zip
- Update to 1.6.10 (bugfix)
- Remove unneeded patches
Notes
Notes: svn path=/head/; revision=387092
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile2
-rw-r--r--x11-fm/thunar/distinfo4
-rw-r--r--x11-fm/thunar/files/patch-thunar_main.c95
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-dbus-service.c10
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-file.c60
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-file.h15
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-trash-action.c12
7 files changed, 3 insertions, 195 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 5b5717a17c14..19d943cc97a5 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Thunar
-PORTVERSION= 1.6.9
+PORTVERSION= 1.6.10
CATEGORIES= x11-fm xfce
MASTER_SITES= XFCE/src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
diff --git a/x11-fm/thunar/distinfo b/x11-fm/thunar/distinfo
index 8d998b46a0fb..0be3491d6999 100644
--- a/x11-fm/thunar/distinfo
+++ b/x11-fm/thunar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/Thunar-1.6.9.tar.bz2) = 75f3622cbe6ab6837f38d856faeac75a1191be8a08dc4c98ba35b61e312b94e5
-SIZE (xfce4/Thunar-1.6.9.tar.bz2) = 1947746
+SHA256 (xfce4/Thunar-1.6.10.tar.bz2) = 7e9d24067268900e5e44d3325e60a1a2b2f8f556ec238ec12574fbea15fdee8a
+SIZE (xfce4/Thunar-1.6.10.tar.bz2) = 1948762
diff --git a/x11-fm/thunar/files/patch-thunar_main.c b/x11-fm/thunar/files/patch-thunar_main.c
deleted file mode 100644
index 05346dfd186a..000000000000
--- a/x11-fm/thunar/files/patch-thunar_main.c
+++ /dev/null
@@ -1,95 +0,0 @@
-Revert fix for bug #9513
-
---- thunar/main.c.orig 2015-05-15 16:38:08 UTC
-+++ thunar/main.c
-@@ -53,7 +53,7 @@ static gboolean opt_daemon = FALSE;
- static gchar *opt_sm_client_id = NULL;
- static gboolean opt_quit = FALSE;
- static gboolean opt_version = FALSE;
--static ThunarFile *thunar_trash_file = NULL;
-+
-
-
- /* --- command line options --- */
-@@ -97,13 +97,6 @@ thunar_delayed_exit_check (gpointer user
- }
- else
- {
-- /* unref the trash bin */
-- if (thunar_trash_file != NULL)
-- {
-- g_object_unref (thunar_trash_file);
-- thunar_trash_file = NULL;
-- }
--
- /* no command line arguments opened in Thunar, exit now */
- gtk_main_quit ();
-
-@@ -115,38 +108,6 @@ thunar_delayed_exit_check (gpointer user
-
-
-
--static void
--thunar_force_spawn_trash (void)
--{
-- GFile *trash;
--
-- /* check that this has not happened yet */
-- if (thunar_trash_file != NULL)
-- return;
--
-- /* gvfs has no trash support */
-- if (!thunar_g_vfs_is_uri_scheme_supported ("trash"))
-- return;
--
-- trash = thunar_g_file_new_for_trash ();
-- thunar_trash_file = thunar_file_cache_lookup (trash);
-- if (thunar_trash_file == NULL)
-- {
-- thunar_trash_file = thunar_file_get (trash, NULL);
-- if (thunar_trash_file)
-- {
-- /* schedule a few reloads */
-- thunar_file_reload_idle (thunar_trash_file);
-- thunar_file_reload_idle_timeout (thunar_trash_file, 2000);
-- thunar_file_reload_idle_timeout (thunar_trash_file, 3000);
-- thunar_file_reload_idle_timeout (thunar_trash_file, 5000);
-- }
-- }
-- g_object_unref (trash);
--}
--
--
--
- int
- main (int argc, char **argv)
- {
-@@ -290,14 +251,6 @@ main (int argc, char **argv)
- /* initialize the thunar stock items/icons */
- thunar_stock_init ();
-
-- /* For the trash state to be correct, gvfsd-trash needs to have been
-- * spawned. If the trash file is not in cache, this means we could
-- * access it the first time and the daemon might not have been
-- * spawned yet. So let's reload the trash later in idle, so that
-- * the state gets updated correctly (bug #9513).
-- */
-- thunar_force_spawn_trash ();
--
- /* acquire a reference on the global application */
- application = thunar_application_get ();
-
-@@ -363,13 +316,6 @@ error0:
- g_object_unref (G_OBJECT (dbus_service));
- #endif
-
-- /* unreference the trash file */
-- if (thunar_trash_file != NULL)
-- {
-- g_object_unref (thunar_trash_file);
-- thunar_trash_file = NULL;
-- }
--
- /* disconnect from the session manager */
- g_object_unref (G_OBJECT (session_client));
-
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-dbus-service.c b/x11-fm/thunar/files/patch-thunar_thunar-dbus-service.c
deleted file mode 100644
index 4015e717b3c5..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-dbus-service.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- thunar/thunar-dbus-service.c.orig 2015-05-14 17:33:17 UTC
-+++ thunar/thunar-dbus-service.c
-@@ -357,6 +357,7 @@ thunar_dbus_service_connect_trash_bin (T
- g_signal_connect_swapped (G_OBJECT (dbus_service->trash_bin), "changed",
- G_CALLBACK (thunar_dbus_service_trash_bin_changed),
- dbus_service);
-+ thunar_file_reload_idle (dbus_service->trash_bin);
- }
- g_object_unref (trash_bin_path);
- }
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-file.c b/x11-fm/thunar/files/patch-thunar_thunar-file.c
deleted file mode 100644
index e5df3a0e3f0c..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-file.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- thunar/thunar-file.c.orig 2015-05-16 14:25:55 UTC
-+++ thunar/thunar-file.c
-@@ -3910,8 +3910,12 @@ thunar_file_unwatch (ThunarFile *file)
- *
- * You must be able to handle the case that @file is
- * destroyed during the reload call.
-+ *
-+ * Return value: FALSE because if used as a callback function for
-+ * thunar_file_reload_idle it should be automatically removed from
-+ * the list of event sources so it is not called again.
- **/
--void
-+gboolean
- thunar_file_reload (ThunarFile *file)
- {
- _thunar_return_if_fail (THUNAR_IS_FILE (file));
-@@ -3923,12 +3927,13 @@ thunar_file_reload (ThunarFile *file)
- {
- /* destroy the file if we cannot query any file information */
- thunar_file_destroy (file);
-- return;
-+ return FALSE;
- }
-
- /* ... and tell others */
- thunar_file_changed (file);
--
-+
-+ return FALSE;
- }
-
-
-@@ -3952,27 +3957,6 @@ thunar_file_reload_idle (ThunarFile *fil
-
-
- /**
-- * thunar_file_reload_idle_timeout:
-- * @file : a #ThunarFile instance.
-- * @timeout : the timeout in ms after which the reload should happen
-- *
-- * Schedules a reload of the @file by calling thunar_file_reload in
-- * idle after @timeout milliseconds have passed.
-- *
-- **/
--void
--thunar_file_reload_idle_timeout (ThunarFile *file,
-- guint timeout)
--{
-- _thunar_return_if_fail (THUNAR_IS_FILE (file));
--
-- g_timeout_add_full (G_PRIORITY_DEFAULT_IDLE, timeout,
-- (GSourceFunc) thunar_file_reload, file, NULL);
--}
--
--
--
--/**
- * thunar_file_destroy:
- * @file : a #ThunarFile instance.
- *
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-file.h b/x11-fm/thunar/files/patch-thunar_thunar-file.h
deleted file mode 100644
index d0b6b6e187f1..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-file.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- thunar/thunar-file.h.orig 2015-05-15 16:38:08 UTC
-+++ thunar/thunar-file.h
-@@ -238,11 +238,8 @@ const gchar *thunar_file_get_icon_n
-
- void thunar_file_watch (ThunarFile *file);
- void thunar_file_unwatch (ThunarFile *file);
--
--void thunar_file_reload (ThunarFile *file);
-+gboolean thunar_file_reload (ThunarFile *file);
- void thunar_file_reload_idle (ThunarFile *file);
--void thunar_file_reload_idle_timeout (ThunarFile *file,
-- guint timeout);
- void thunar_file_reload_parent (ThunarFile *file);
-
- void thunar_file_destroy (ThunarFile *file);
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-trash-action.c b/x11-fm/thunar/files/patch-thunar_thunar-trash-action.c
deleted file mode 100644
index d25bd224f25c..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-trash-action.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- thunar/thunar-trash-action.c.orig 2015-05-15 08:57:43 UTC
-+++ thunar/thunar-trash-action.c
-@@ -88,6 +88,9 @@ thunar_trash_action_init (ThunarTrashAct
-
- /* initially update the stock icon */
- thunar_trash_action_changed (trash_action, trash_action->trash_bin);
-+
-+ /* schedule a reload in idle (fix for bug #9513) */
-+ thunar_file_reload_idle (trash_action->trash_bin);
- }
- }
-