aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/thunar
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2015-01-09 22:13:34 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2015-01-09 22:13:34 +0000
commitbb5eed1365ff90fc4bb0087ccc4a73143c377e45 (patch)
tree93ce31b022b8e159cd258cab6d83bf77f78ff0d3 /x11-fm/thunar
parent8b32ee97c6b4e6b72e8fb7c113deac3c02d8424f (diff)
downloadports-bb5eed1365ff90fc4bb0087ccc4a73143c377e45.tar.gz
ports-bb5eed1365ff90fc4bb0087ccc4a73143c377e45.zip
- Add patches, which fix various menu icons
- Bump PORTREVISION Obtained from: Upstream repository
Notes
Notes: svn path=/head/; revision=376664
Diffstat (limited to 'x11-fm/thunar')
-rw-r--r--x11-fm/thunar/Makefile1
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-launcher.c34
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c13
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-standard-view.c13
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-templates-action.c21
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-tree-view.c25
-rw-r--r--x11-fm/thunar/files/patch-thunar_thunar-window.c15
7 files changed, 122 insertions, 0 deletions
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 3d6e4972d0b9..302b557ff2c7 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Thunar
PORTVERSION= 1.6.4
+PORTREVISION= 1
CATEGORIES= x11-fm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-launcher.c b/x11-fm/thunar/files/patch-thunar_thunar-launcher.c
new file mode 100644
index 000000000000..8fd8e1442a22
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-launcher.c
@@ -0,0 +1,34 @@
+Right click context menu with wrong icon (bug #10652)
+
+--- thunar/thunar-launcher.c.orig 2013-12-18 23:41:57 UTC
++++ thunar/thunar-launcher.c
+@@ -815,8 +815,9 @@ thunar_launcher_update_idle (gpointer da
+ ** - "Open", "Open in n New Windows" and "Open in n New Tabs" actions
+ **/
+
+- /* Prepare "Open" label */
++ /* Prepare "Open" label and icon */
+ gtk_action_set_label (launcher->action_open, _("_Open"));
++ gtk_action_set_stock_id (launcher->action_open, GTK_STOCK_OPEN);
+
+ if (n_selected_files == n_directories && n_directories >= 1)
+ {
+@@ -928,6 +929,7 @@ thunar_launcher_update_idle (gpointer da
+ /* turn the "Open" action into "Execute" */
+ g_object_set (G_OBJECT (launcher->action_open),
+ "label", _("_Execute"),
++ "stock-id", GTK_STOCK_EXECUTE,
+ "tooltip", ngettext ("Execute the selected file", "Execute the selected files", n_selected_files),
+ NULL);
+ }
+@@ -945,6 +947,10 @@ thunar_launcher_update_idle (gpointer da
+ g_free (tooltip);
+ g_free (label);
+
++ /* load default application icon */
++ gtk_action_set_stock_id (launcher->action_open, NULL);
++ gtk_action_set_gicon (launcher->action_open, g_app_info_get_icon (applications->data));
++
+ /* remember the default application for the "Open" action */
+ g_object_set_qdata_full (G_OBJECT (launcher->action_open), thunar_launcher_handler_quark, applications->data, g_object_unref);
+
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c b/x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c
new file mode 100644
index 000000000000..ee60b455a521
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-location-buttons.c
@@ -0,0 +1,13 @@
+Right click context menu with wrong icon (bug #10652)
+
+--- thunar/thunar-location-buttons.c.orig 2013-12-18 23:41:57 UTC
++++ thunar/thunar-location-buttons.c
+@@ -175,7 +175,7 @@ static const GtkActionEntry action_entri
+ { "location-buttons-open", GTK_STOCK_OPEN, N_("_Open"), "", NULL, G_CALLBACK (thunar_location_buttons_action_open), },
+ { "location-buttons-open-in-new-tab", NULL, N_("Open in New Tab"), "", NULL, G_CALLBACK (thunar_location_buttons_action_open_in_new_tab), },
+ { "location-buttons-open-in-new-window", NULL, N_("Open in New Window"), "", NULL, G_CALLBACK (thunar_location_buttons_action_open_in_new_window), },
+- { "location-buttons-create-folder", NULL, N_("Create _Folder..."), "", NULL, G_CALLBACK (thunar_location_buttons_action_create_folder), },
++ { "location-buttons-create-folder", "folder-new", N_("Create _Folder..."), "", NULL, G_CALLBACK (thunar_location_buttons_action_create_folder), },
+ { "location-buttons-empty-trash", NULL, N_("_Empty Trash"), "", N_("Delete all files and folders in the Trash"), G_CALLBACK (thunar_location_buttons_action_empty_trash), },
+ { "location-buttons-paste-into-folder", GTK_STOCK_PASTE, N_("Paste Into Folder"), "", NULL, G_CALLBACK (thunar_location_buttons_action_paste_into_folder), },
+ { "location-buttons-properties", GTK_STOCK_PROPERTIES, N_("_Properties..."), "", NULL, G_CALLBACK (thunar_location_buttons_action_properties), },
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-standard-view.c b/x11-fm/thunar/files/patch-thunar_thunar-standard-view.c
new file mode 100644
index 000000000000..06659ae6fce9
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-standard-view.c
@@ -0,0 +1,13 @@
+Right click context menu with wrong icon (bug #10652)
+
+--- thunar/thunar-standard-view.c.orig 2014-12-20 00:21:57 UTC
++++ thunar/thunar-standard-view.c
+@@ -393,7 +393,7 @@ static const GtkActionEntry action_entri
+ {
+ { "file-context-menu", NULL, N_ ("File Context Menu"), NULL, NULL, NULL, },
+ { "folder-context-menu", NULL, N_ ("Folder Context Menu"), NULL, NULL, NULL, },
+- { "create-folder", NULL, N_ ("Create _Folder..."), "<control><shift>N", N_ ("Create an empty folder within the current folder"), G_CALLBACK (thunar_standard_view_action_create_folder), },
++ { "create-folder", "folder-new", N_ ("Create _Folder..."), "<control><shift>N", N_ ("Create an empty folder within the current folder"), G_CALLBACK (thunar_standard_view_action_create_folder), },
+ { "properties", GTK_STOCK_PROPERTIES, N_ ("_Properties..."), "<alt>Return", N_ ("View the properties of the selected file"), G_CALLBACK (thunar_standard_view_action_properties), },
+ { "cut", GTK_STOCK_CUT, N_ ("Cu_t"), NULL, NULL, G_CALLBACK (thunar_standard_view_action_cut), },
+ { "copy", GTK_STOCK_COPY, N_ ("_Copy"), NULL, NULL, G_CALLBACK (thunar_standard_view_action_copy), },
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-templates-action.c b/x11-fm/thunar/files/patch-thunar_thunar-templates-action.c
new file mode 100644
index 000000000000..adc63072d5f6
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-templates-action.c
@@ -0,0 +1,21 @@
+Right click context menu with wrong icon (bug #10652)
+
+--- thunar/thunar-templates-action.c.orig 2013-12-18 23:41:57 UTC
++++ thunar/thunar-templates-action.c
+@@ -477,7 +477,7 @@ thunar_templates_action_load_finished (T
+ gtk_widget_show (item);
+
+ /* add the icon for the emtpy file item */
+- image = gtk_image_new_from_stock (GTK_STOCK_NEW, GTK_ICON_SIZE_MENU);
++ image = gtk_image_new_from_stock (GTK_STOCK_FILE, GTK_ICON_SIZE_MENU);
+ gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM (item), image);
+ }
+
+@@ -542,6 +542,7 @@ thunar_templates_action_new (const gchar
+ "hide-if-empty", FALSE,
+ "label", label,
+ "name", name,
++ "icon-name", "document-new",
+ NULL);
+ }
+
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-tree-view.c b/x11-fm/thunar/files/patch-thunar_thunar-tree-view.c
new file mode 100644
index 000000000000..7ef0e67571ef
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-tree-view.c
@@ -0,0 +1,25 @@
+Right click context menu with wrong icon (bug #10652)
+
+--- thunar/thunar-tree-view.c.orig 2013-12-18 23:41:57 UTC
++++ thunar/thunar-tree-view.c
+@@ -1093,6 +1093,7 @@ thunar_tree_view_context_menu (ThunarTre
+ GtkWidget *menu;
+ GtkWidget *item;
+ GtkWidget *window;
++ GIcon *icon;
+ GList *providers, *lp;
+ GList *actions = NULL, *tmp;
+
+@@ -1201,6 +1202,12 @@ thunar_tree_view_context_menu (ThunarTre
+ g_signal_connect_swapped (G_OBJECT (item), "activate", G_CALLBACK (thunar_tree_view_action_create_folder), view);
+ gtk_menu_shell_append (GTK_MENU_SHELL (menu), item);
+ gtk_widget_show (item);
++
++ /* set the stock icon */
++ icon = g_themed_icon_new ("folder-new");
++ image = gtk_image_new_from_gicon (icon, GTK_ICON_SIZE_MENU);
++ gtk_image_menu_item_set_image (GTK_IMAGE_MENU_ITEM (item), image);
++ g_object_unref (icon);
+
+ /* append a separator item */
+ item = gtk_separator_menu_item_new ();
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-window.c b/x11-fm/thunar/files/patch-thunar_thunar-window.c
new file mode 100644
index 000000000000..acc4dbc6a31c
--- /dev/null
+++ b/x11-fm/thunar/files/patch-thunar_thunar-window.c
@@ -0,0 +1,15 @@
+Right click context menu with wrong icon (bug #10652)
+
+--- thunar/thunar-window.c.orig 2013-12-18 23:41:57 UTC
++++ thunar/thunar-window.c
+@@ -345,8 +345,8 @@ struct _ThunarWindow
+ static GtkActionEntry action_entries[] =
+ {
+ { "file-menu", NULL, N_ ("_File"), NULL, },
+- { "new-tab", NULL, N_ ("New _Tab"), "<control>T", N_ ("Open a new tab for the displayed location"), G_CALLBACK (thunar_window_action_open_new_tab), },
+- { "new-window", NULL, N_ ("New _Window"), "<control>N", N_ ("Open a new Thunar window for the displayed location"), G_CALLBACK (thunar_window_action_open_new_window), },
++ { "new-tab", "tab-new", N_ ("New _Tab"), "<control>T", N_ ("Open a new tab for the displayed location"), G_CALLBACK (thunar_window_action_open_new_tab), },
++ { "new-window", "window-new", N_ ("New _Window"), "<control>N", N_ ("Open a new Thunar window for the displayed location"), G_CALLBACK (thunar_window_action_open_new_window), },
+ { "sendto-menu", NULL, N_ ("_Send To"), NULL, },
+ { "empty-trash", NULL, N_ ("_Empty Trash"), NULL, N_ ("Delete all files and folders in the Trash"), G_CALLBACK (thunar_window_action_empty_trash), },
+ { "detach-tab", NULL, N_ ("Detac_h Tab"), NULL, N_ ("Open current folder in a new window"), G_CALLBACK (thunar_window_action_detach_tab), },