aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/worker
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-08 19:59:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-02-08 19:59:12 +0000
commitf0bc0ef491c721f3e3eeb3e07a10e5d6ea1f145e (patch)
tree862195a5e7df58833d4db6184c235527d53a3286 /x11-fm/worker
parentc0fae57ca9889461a09d33973147bc4778b9317c (diff)
downloadports-f0bc0ef491c721f3e3eeb3e07a10e5d6ea1f145e.tar.gz
ports-f0bc0ef491c721f3e3eeb3e07a10e5d6ea1f145e.zip
Now that HAL support and associated dependencies had been removed in
r564687, expose D-Bus device handling support, which HAL option had previously implied, via dedicated option, DBUS, and make it default. While here, add a few missing FOO_CONFIGURE_OFF's, sort the knobs so that "on" knobs are listed before the "off" ones, and reindent them.
Notes
Notes: svn path=/head/; revision=564738
Diffstat (limited to 'x11-fm/worker')
-rw-r--r--x11-fm/worker/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index 04c6ab91710e..1694811ab8c1 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -22,26 +22,31 @@ SHEBANG_FILES= ${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/xeditor \
${WRKSRC}/scripts/find_file_by_chksum.py
-OPTIONS_DEFINE= AVFS INOTIFY LUA SSL XFT
-OPTIONS_DEFAULT= AVFS INOTIFY SSL XFT
+OPTIONS_DEFINE= AVFS DBUS INOTIFY LUA SSL XFT
+OPTIONS_DEFAULT= AVFS DBUS INOTIFY SSL XFT
OPTIONS_EXCLUDE_DragonFly= AVFS
INOTIFY_DESC= Monitor directory changes via libinotify
AVFS_DESC= Use AVFS library to access archives
+SSL_DESC= SHA-256 checksum support via OpenSSL
AVFS_LIB_DEPENDS= libavfs.so:sysutils/avfs
+AVFS_CONFIGURE_OFF= --without-avfs
+
+DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
+DBUS_CONFIGURE_OFF= --without-dbus
INOTIFY_LIB_DEPENDS= libinotify.so:devel/libinotify
+INOTIFY_CONFIGURE_OFF= --disable-inotify
+LUA_USES= lua
LUA_CONFIGURE_OFF= --disable-lua
-LUA_USES= lua
-SSL_DESC= SHA-256 checksum support via OpenSSL
+SSL_USES= ssl
SSL_CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
-SSL_USES= ssl
+XFT_USE= xorg=xft
XFT_CONFIGURE_OFF= --disable-xft
-XFT_USE= xorg=xft
.include <bsd.port.mk>