aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-02 23:20:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-02 23:20:27 +0000
commit2120f163392c16bd57ffdc4af4b48cf592df3b7b (patch)
treecb06724702de96fc7e67a2d3c9fc80af3826e58c /x11-fm
parent41f93dd4c4e5bfedebf6924ba83e8dea82a2bab6 (diff)
downloadports-2120f163392c16bd57ffdc4af4b48cf592df3b7b.tar.gz
ports-2120f163392c16bd57ffdc4af4b48cf592df3b7b.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/twander/Makefile32
-rw-r--r--x11-fm/twander/distinfo1
-rw-r--r--x11-fm/twander/files/patch-Makefile13
-rw-r--r--x11-fm/twander/pkg-descr24
-rw-r--r--x11-fm/twander/pkg-plist4
6 files changed, 75 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index 9f750169e05c..0bb7be6c4976 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -23,6 +23,7 @@
SUBDIR += rox-session
SUBDIR += systemg
SUBDIR += tkdesk
+ SUBDIR += twander
SUBDIR += vide
SUBDIR += worker
SUBDIR += workplace
diff --git a/x11-fm/twander/Makefile b/x11-fm/twander/Makefile
new file mode 100644
index 000000000000..4adb23ade46e
--- /dev/null
+++ b/x11-fm/twander/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: twander
+# Date Created: 17 February 2003
+# Whom: tundra
+#
+# $FreeBSD$
+#
+
+PORTNAME= twander
+PORTVERSION= 3.0
+CATEGORIES= x11-fm
+MASTER_SITES= http://www.tundraware.com/Software/twander/
+
+MAINTAINER= twander@tundraware.com
+COMMENT= A better filesystem browser
+
+BUILD_DEPENDS=${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+RUN_DEPENDS=${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
+
+USE_PYTHON= yes
+
+MANCOMPRESSED= yes
+MAN1= twander.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in .twander twander-license.txt
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fm/twander/distinfo b/x11-fm/twander/distinfo
new file mode 100644
index 000000000000..e2422ed7acab
--- /dev/null
+++ b/x11-fm/twander/distinfo
@@ -0,0 +1 @@
+MD5 (twander-3.0.tar.gz) = 450943214974ec54b962102044bb741b
diff --git a/x11-fm/twander/files/patch-Makefile b/x11-fm/twander/files/patch-Makefile
new file mode 100644
index 000000000000..01fdae7c87f3
--- /dev/null
+++ b/x11-fm/twander/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Sun Mar 2 15:15:34 2003
++++ Makefile Sun Mar 2 15:15:48 2003
+@@ -5,7 +5,7 @@
+
+ install:
+ install -c -o root -g wheel -m 755 ./twander.py ${PREFIX}/bin
+- mkdir ${PREFIX}/share/doc/twander
++# mkdir ${PREFIX}/share/doc/twander
+ install -c -o root -g wheel -m 644 ./twander.1.gz ${PREFIX}/man/man1
+- install -c -o root -g wheel -m 644 ./twander-license.txt ${PREFIX}/share/doc/twander
+- install -c -o root -g wheel -m 644 ./.twander ${PREFIX}/share/doc/twander
++# install -c -o root -g wheel -m 644 ./twander-license.txt ${PREFIX}/share/doc/twander
++# install -c -o root -g wheel -m 644 ./.twander ${PREFIX}/share/doc/twander
diff --git a/x11-fm/twander/pkg-descr b/x11-fm/twander/pkg-descr
new file mode 100644
index 000000000000..73af48f0eb41
--- /dev/null
+++ b/x11-fm/twander/pkg-descr
@@ -0,0 +1,24 @@
+"twander" is a Filesystem Browser which runs on both Unix-like systems
+as well as Win32 systems. It embraces the best ideas of both similar
+GUI-driven programs (Konqueror, Windows Explorer) as well as
+text-based interfaces (Midnight Commander, List, Sweep).
+
+While the "twander" interface is graphical, all the major navigation,
+selection, and execution commands can be entered from the keyboard,
+not just the mouse. This means Power Users who are strong typists can
+minimize dependency on the mouse and materially speed up their
+interactions with the system.
+
+Moreover, unlike the other programs, "twander" does not have a
+built-in set of commands (which typically cannot be changed).
+Instead, "twander" supports a rich macro configuration language for
+virtually limitless user-definition of commands. The configuration
+language provides a simple mechanism for communicating the list of
+items currently selected in the GUI to the user-defined commands.
+
+Each user is thus free to configure a command set unique and
+appropriate to their needs. As with the navigation commands,
+user-defined commands can be invoked with either the keyboard (a
+single keystroke) or the mouse (a menu selection).
+
+WWW: http://www.tundraware.com/Software/twander/
diff --git a/x11-fm/twander/pkg-plist b/x11-fm/twander/pkg-plist
new file mode 100644
index 000000000000..c1e4aae3ebbc
--- /dev/null
+++ b/x11-fm/twander/pkg-plist
@@ -0,0 +1,4 @@
+bin/twander.py
+%%PORTDOCS%%share/doc/twander/twander-license.txt
+%%PORTDOCS%%share/doc/twander/.twander
+%%PORTDOCS%%@dirrm share/doc/twander