aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-02 11:21:30 +0000
committerRene Ladan <rene@FreeBSD.org>2021-01-02 11:21:30 +0000
commit474895cdb67df33222fa2b2e67a4c6fc7dea0fa7 (patch)
tree88f0bd8b077f4fe5cb17646d5336161aa4610b11 /x11-fm
parent9729352622704f6096153cf167ef06a4d7085051 (diff)
downloadports-474895cdb67df33222fa2b2e67a4c6fc7dea0fa7.tar.gz
ports-474895cdb67df33222fa2b2e67a4c6fc7dea0fa7.zip
Upgrade the Cinnamon desktop environment to version 4.8
This version uses Python 3 instead of the expired Python 2.7 From the main PR (249856): " There are a couple known issues: * x11-fm/nemo crashes upon closing a window or tab. * x11/cinnamon-screensaver unlocking doesn't work, most likely due to a missing PAM (Linux-PAM?) integration. Both of these issues are being worked on. I've been dogfooding since Cinnamon 4.0, and apart from those issues, everything works." PR: 249771 PR: 249851 PR: 249855 PR: 249856 PR: 249857 PR: 249858 Submitted by: Charlie Li
Notes
Notes: svn path=/head/; revision=559925
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nemo/Makefile100
-rw-r--r--x11-fm/nemo/distinfo5
-rw-r--r--x11-fm/nemo/files/patch-autogen.sh10
-rw-r--r--x11-fm/nemo/files/patch-eel_eel-editable-label.c14
-rw-r--r--x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.c22
-rw-r--r--x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.h33
-rw-r--r--x11-fm/nemo/files/patch-libnemo-private_nemo-statx.c102
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-bookmark-list.c11
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-notebook.c15
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-view.c11
-rw-r--r--x11-fm/nemo/pkg-descr6
-rw-r--r--x11-fm/nemo/pkg-plist106
12 files changed, 221 insertions, 214 deletions
diff --git a/x11-fm/nemo/Makefile b/x11-fm/nemo/Makefile
index 0dac315a7160..154eaa8596d8 100644
--- a/x11-fm/nemo/Makefile
+++ b/x11-fm/nemo/Makefile
@@ -2,90 +2,68 @@
# $FreeBSD$
PORTNAME= nemo
-PORTVERSION= 2.4.5
-PORTREVISION= 5
+PORTVERSION= 4.8.2
CATEGORIES= x11-fm gnome
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= File manager for the Cinnamon desktop
+LICENSE= GPLv2 LGPL20
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL20= ${WRKSRC}/COPYING.LIB
+
BUILD_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme \
- gtkdocize:textproc/gtk-doc \
- ${PYTHON_PKGNAMEPREFIX}polib>=0:devel/py-polib@${PY_FLAVOR} \
- gnome-autogen.sh:devel/gnome-common \
gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
-LIB_DEPENDS= libexif.so:graphics/libexif \
- libcinnamon-desktop.so:x11/cinnamon-desktop \
+LIB_DEPENDS= libcinnamon-desktop.so:x11/cinnamon-desktop \
libnotify.so:devel/libnotify \
- libexempi.so:textproc/exempi
+ libxapp.so:x11/xapp
RUN_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme \
- gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
-
-USES= autoreconf:build compiler:c++11-lang desktop-file-utils gettext \
- gmake gnome libtool pathfix pkgconfig python:2.7 \
- shared-mime-info
-USE_GNOME= gnomedesktop3 gnomeprefix intlhack introspection:build \
- libxml2 pygobject3
-USE_GITHUB= yes
-GH_ACCOUNT= linuxmint
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lpthread
-INSTALL_TARGET= install-strip
-CONFIGURE_ARGS= --enable-static --disable-packagekit
+ gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
+ gvfs>0:devel/gvfs
-GLIB_SCHEMAS= org.nemo.gschema.xml
+USES= desktop-file-utils gettext gnome meson pkgconfig python:3.5+ \
+ shared-mime-info shebangfix xorg
-OPTIONS_SUB= yes
-OPTIONS_DEFINE= TRACKER
-OPTIONS_DEFAULT= TRACKER
-TRACKER_CONFIGURE_ENABLE= tracker
-TRACKER_LIB_DEPENDS= libtracker-sparql-2.0.so:sysutils/tracker
-TRACKER_DESC= Integration with tracker
+SHEBANG_FILES= generate_additional_file makepot
+SHEBANG_GLOB= *.py
-post-patch:
- @${MKDIR} ${WRKSRC}/files${PREFIX}
+USE_GITHUB= yes
+GH_ACCOUNT= linuxmint
- @${MV} ${WRKSRC}/files/usr/share ${WRKSRC}/files${PREFIX}
+USE_GNOME= cairo gdkpixbuf2 gtk30 intlhack introspection libxml2 pango pygobject3
- @${REINPLACE_CMD} -e 's|0.16|1.0|g' \
- ${WRKSRC}/configure.in
+USE_XORG= x11
- @${REINPLACE_CMD} -e 's|find|find ${WRKSRC}/files|g' \
- ${WRKSRC}/files/Makefile.in
+GLIB_SCHEMAS= org.nemo.gschema.xml
- @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
- -e 's|tracker-sparql-1.0|tracker-sparql-2.0|g' \
- ${WRKSRC}/configure.in
+INSTALLS_ICONS= yes
- @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
- ${WRKSRC}/src/nemo-properties-window.c
+USE_LDCONFIG= yes
- @${REINPLACE_CMD} -e 's|"-DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED"|""|g' \
- ${WRKSRC}/configure.in
+OPTIONS_DEFINE= DOCS EXEMPI EXIF TRACKER
+OPTIONS_DEFAULT= DOCS EXEMPI EXIF
+OPTIONS_SUB= yes
- @${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g ;\
- s|@INTROSPECTION_TYPELIBDIR@|$$(libdir)/girepository-1.0|g ;\
- s|@INTROSPECTION_GIRDIR@|$$(datadir)/gir-1.0|g' \
- ${WRKSRC}/libnemo-extension/Makefile.am
+EXEMPI_DESC= XMP support
+EXIF_DESC= Digital camera file meta-data support
+TRACKER_DESC= Integration with tracker
- @${REINPLACE_CMD} -e 's|x-gnome-saved-search|x-nemo-saved-search|g' \
- ${WRKSRC}/data/nemo.xml.in \
- ${WRKSRC}/libnemo-private/nemo-file-utilities.h
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= gtk_doc
- @${FIND} ${WRKSRC} -name \* | ${XARGS} ${EGREP} -l "#!.*\/usr\/bin\/python" | \
- ${XARGS} ${REINPLACE_CMD} -I "" -e "s|#!.*python.*|#!${PYTHON_CMD}|g"
+EXEMPI_LIB_DEPENDS= libexempi.so:textproc/exempi
+EXEMPI_MESON_TRUE= xmp
- @${REINPLACE_CMD} 's|\"/usr|\"${PREFIX}|g' \
- ${WRKSRC}/data/merge_action_strings
+EXIF_LIB_DEPENDS= libexif.so:graphics/libexif
+EXIF_MESON_TRUE= exif
- @${REINPLACE_CMD} 's|"files", "usr"|"files", "${PREFIX}".strip("/")|g' \
- ${WRKSRC}/data/merge_action_strings
+TRACKER_LIB_DEPENDS= libtracker-sparql-2.0.so:sysutils/tracker
+TRACKER_MESON_TRUE= tracker
-pre-configure:
- cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ${SH} ./autogen.sh
+post-patch:
+ # malloc.h is deprecated
+ @${REINPLACE_CMD} -e "/malloc.h/d" ${WRKSRC}/meson.build
.include <bsd.port.mk>
diff --git a/x11-fm/nemo/distinfo b/x11-fm/nemo/distinfo
index 06ce382a790b..2b2e7dc44532 100644
--- a/x11-fm/nemo/distinfo
+++ b/x11-fm/nemo/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome3/linuxmint-nemo-2.4.5_GH0.tar.gz) = a4eae743f25d1a66cbb5b28675d78aee1d57224c825d6baebdf88068dc1d8d04
-SIZE (gnome3/linuxmint-nemo-2.4.5_GH0.tar.gz) = 1356445
+TIMESTAMP = 1608879573
+SHA256 (gnome/linuxmint-nemo-4.8.2_GH0.tar.gz) = e4225b7c4736abe49e106595c770f2c2ea137b15f0b09c9f9ae05c1556fb42a4
+SIZE (gnome/linuxmint-nemo-4.8.2_GH0.tar.gz) = 1463134
diff --git a/x11-fm/nemo/files/patch-autogen.sh b/x11-fm/nemo/files/patch-autogen.sh
deleted file mode 100644
index 245362b24ad7..000000000000
--- a/x11-fm/nemo/files/patch-autogen.sh
+++ /dev/null
@@ -1,10 +0,0 @@
---- autogen.sh.orig 2013-07-20 21:14:17.454775429 +0000
-+++ autogen.sh 2013-07-20 21:14:26.096159846 +0000
-@@ -4,6 +4,7 @@
- test -z "$srcdir" && srcdir=.
-
- PKG_NAME="nemo"
-+REQUIRED_AUTOMAKE_VERSION=1.14
-
- which gnome-autogen.sh || {
- echo "You need to install gnome-common from GNOME Git (or from"
diff --git a/x11-fm/nemo/files/patch-eel_eel-editable-label.c b/x11-fm/nemo/files/patch-eel_eel-editable-label.c
deleted file mode 100644
index 4818520a49f8..000000000000
--- a/x11-fm/nemo/files/patch-eel_eel-editable-label.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- eel/eel-editable-label.c.orig 2014-04-03 11:36:31.849369101 +0000
-+++ eel/eel-editable-label.c 2014-04-03 11:37:01.819371871 +0000
-@@ -36,6 +36,11 @@
- #include <gtk/gtk.h>
- #include <gdk/gdkkeysyms.h>
-
-+/* g_memmove is removed in glib 2.40 */
-+#if GLIB_CHECK_VERSION (2, 39, 0)
-+#define g_memmove memmove
-+#endif
-+
- enum {
- MOVE_CURSOR,
- POPULATE_POPUP,
diff --git a/x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.c b/x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.c
deleted file mode 100644
index 2fc46ab9776a..000000000000
--- a/x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- libnemo-private/nemo-global-preferences.c.orig 2020-08-30 07:04:30 UTC
-+++ libnemo-private/nemo-global-preferences.c
-@@ -36,6 +36,19 @@
-
- static gboolean ignore_view_metadata = FALSE;
-
-+GSettings *nemo_preferences;
-+GSettings *nemo_icon_view_preferences;
-+GSettings *nemo_list_view_preferences;
-+GSettings *nemo_compact_view_preferences;
-+GSettings *nemo_desktop_preferences;
-+GSettings *nemo_tree_sidebar_preferences;
-+GSettings *nemo_window_state;
-+GSettings *gnome_lockdown_preferences;
-+GSettings *gnome_background_preferences;
-+GSettings *gnome_media_handling_preferences;
-+GSettings *gnome_terminal_preferences;
-+GSettings *cinnamon_privacy_preferences;
-+
- /*
- * Public functions
- */
diff --git a/x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.h b/x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.h
deleted file mode 100644
index bb9c8514658d..000000000000
--- a/x11-fm/nemo/files/patch-libnemo-private_nemo-global-preferences.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- libnemo-private/nemo-global-preferences.h.orig 2020-08-30 07:04:30 UTC
-+++ libnemo-private/nemo-global-preferences.h
-@@ -239,18 +239,18 @@ char *nemo_global_preferences_get_default_folder_viewe
- gboolean nemo_global_preferences_get_ignore_view_metadata (void);
- gint nemo_global_preferences_get_tooltip_flags (void);
-
--GSettings *nemo_preferences;
--GSettings *nemo_icon_view_preferences;
--GSettings *nemo_list_view_preferences;
--GSettings *nemo_compact_view_preferences;
--GSettings *nemo_desktop_preferences;
--GSettings *nemo_tree_sidebar_preferences;
--GSettings *nemo_window_state;
--GSettings *gnome_lockdown_preferences;
--GSettings *gnome_background_preferences;
--GSettings *gnome_media_handling_preferences;
--GSettings *gnome_terminal_preferences;
--GSettings *cinnamon_privacy_preferences;
-+extern GSettings *nemo_preferences;
-+extern GSettings *nemo_icon_view_preferences;
-+extern GSettings *nemo_list_view_preferences;
-+extern GSettings *nemo_compact_view_preferences;
-+extern GSettings *nemo_desktop_preferences;
-+extern GSettings *nemo_tree_sidebar_preferences;
-+extern GSettings *nemo_window_state;
-+extern GSettings *gnome_lockdown_preferences;
-+extern GSettings *gnome_background_preferences;
-+extern GSettings *gnome_media_handling_preferences;
-+extern GSettings *gnome_terminal_preferences;
-+extern GSettings *cinnamon_privacy_preferences;
-
- G_END_DECLS
-
diff --git a/x11-fm/nemo/files/patch-libnemo-private_nemo-statx.c b/x11-fm/nemo/files/patch-libnemo-private_nemo-statx.c
new file mode 100644
index 000000000000..6f627d0f0da9
--- /dev/null
+++ b/x11-fm/nemo/files/patch-libnemo-private_nemo-statx.c
@@ -0,0 +1,102 @@
+--- libnemo-private/nemo-statx.c.orig 2018-12-15 14:00:45 UTC
++++ libnemo-private/nemo-statx.c
+@@ -21,16 +21,17 @@
+ #define _ATFILE_SOURCE
+ #include <config.h>
+ #include <time.h>
+-#include <linux/fcntl.h> // for AT_FDCWD, AT_NO_AUTOMOUNT
+-#include <linux/stat.h> // for statx, STATX_BTIME, statx_timestamp
+ #include <string.h> // for memset
+-#include <syscall.h> // for __NR_statx
+ #include <unistd.h> // for syscall, ssize_t
+ #include <stdio.h>
+ #include <errno.h>
+
+ #if NATIVE_STATX
+ /* native statx call */
++#include <linux/fcntl.h> // for AT_FDCWD, AT_NO_AUTOMOUNT
++#include <linux/stat.h> // for statx, STATX_BTIME, statx_timestamp
++#include <syscall.h> // for __NR_statx
++
+ static __attribute__((unused))
+ ssize_t statx (int dfd, const char *filename, unsigned flags,
+ unsigned int mask, struct statx *buffer)
+@@ -41,6 +42,11 @@ ssize_t statx (int dfd, const char *filename, unsigned
+ #else
+ /* statx wrapper/compatibility */
+
++#define AT_FDCWD -100 /* Special value used to indicate
++ openat should use the current
++ working directory. */
++#define AT_NO_AUTOMOUNT 0x800 /* Suppress terminal automount traversal */
++
+ /* this code works ony with x86 and x86_64 */
+ #if __x86_64__
+ #define __NR_statx 332
+@@ -51,39 +57,39 @@ ssize_t statx (int dfd, const char *filename, unsigned
+ #define STATX_BTIME 0x00000800U /* Want/got stx_btime */
+
+ struct statx_timestamp {
+- __s64 tv_sec;
+- __u32 tv_nsec;
+- __s32 __reserved;
++ int64_t tv_sec;
++ uint32_t tv_nsec;
++ int32_t __reserved;
+ };
+
+ struct statx {
+ /* 0x00 */
+- __u32 stx_mask; /* What results were written [uncond] */
+- __u32 stx_blksize; /* Preferred general I/O size [uncond] */
+- __u64 stx_attributes; /* Flags conveying information about the file [uncond] */
++ uint32_t stx_mask; /* What results were written [uncond] */
++ uint32_t stx_blksize; /* Preferred general I/O size [uncond] */
++ uint64_t stx_attributes; /* Flags conveying information about the file [uncond] */
+ /* 0x10 */
+- __u32 stx_nlink; /* Number of hard links */
+- __u32 stx_uid; /* User ID of owner */
+- __u32 stx_gid; /* Group ID of owner */
+- __u16 stx_mode; /* File mode */
+- __u16 __spare0[1];
++ uint32_t stx_nlink; /* Number of hard links */
++ uint32_t stx_uid; /* User ID of owner */
++ uint32_t stx_gid; /* Group ID of owner */
++ uint16_t stx_mode; /* File mode */
++ uint16_t __spare0[1];
+ /* 0x20 */
+- __u64 stx_ino; /* Inode number */
+- __u64 stx_size; /* File size */
+- __u64 stx_blocks; /* Number of 512-byte blocks allocated */
+- __u64 stx_attributes_mask; /* Mask to show what's supported in stx_attributes */
++ uint64_t stx_ino; /* Inode number */
++ uint64_t stx_size; /* File size */
++ uint64_t stx_blocks; /* Number of 512-byte blocks allocated */
++ uint64_t stx_attributes_mask; /* Mask to show what's supported in stx_attributes */
+ /* 0x40 */
+ struct statx_timestamp stx_atime; /* Last access time */
+ struct statx_timestamp stx_btime; /* File creation time */
+ struct statx_timestamp stx_ctime; /* Last attribute change time */
+ struct statx_timestamp stx_mtime; /* Last data modification time */
+ /* 0x80 */
+- __u32 stx_rdev_major; /* Device ID of special file [if bdev/cdev] */
+- __u32 stx_rdev_minor;
+- __u32 stx_dev_major; /* ID of device containing file [uncond] */
+- __u32 stx_dev_minor;
++ uint32_t stx_rdev_major; /* Device ID of special file [if bdev/cdev] */
++ uint32_t stx_rdev_minor;
++ uint32_t stx_dev_major; /* ID of device containing file [uncond] */
++ uint32_t stx_dev_minor;
+ /* 0x90 */
+- __u64 __spare2[14]; /* Spare space for future expansion */
++ uint64_t __spare2[14]; /* Spare space for future expansion */
+ /* 0x100 */
+ };
+
+@@ -129,4 +135,4 @@ get_file_btime (const char *path)
+ btime = (&stxbuf)->stx_btime.tv_sec;
+
+ return btime;
+-}
+\ No newline at end of file
++}
diff --git a/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c b/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c
deleted file mode 100644
index 6b7d5a5f16ba..000000000000
--- a/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/nemo-bookmark-list.c.orig 2014-11-25 08:21:31.872596499 +0100
-+++ src/nemo-bookmark-list.c 2014-11-25 08:22:26.313236268 +0100
-@@ -448,7 +448,7 @@
- nemo_bookmark_list_get_for_uri (NemoBookmarkList *bookmarks,
- const char *uri)
- {
-- g_return_if_fail (NEMO_IS_BOOKMARK_LIST (bookmarks));
-+ g_return_val_if_fail (NEMO_IS_BOOKMARK_LIST (bookmarks), NULL);
-
- GList *iter;
- GList *results = NULL;
diff --git a/x11-fm/nemo/files/patch-src_nemo-notebook.c b/x11-fm/nemo/files/patch-src_nemo-notebook.c
deleted file mode 100644
index 5b26b3391cab..000000000000
--- a/x11-fm/nemo/files/patch-src_nemo-notebook.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/nemo-notebook.c.orig 2014-11-25 08:15:15.798622291 +0100
-+++ src/nemo-notebook.c 2014-11-25 08:15:25.754624581 +0100
-@@ -51,12 +51,6 @@
- static void nemo_notebook_remove (GtkContainer *container,
- GtkWidget *tab_widget);
-
--static const GtkTargetEntry url_drag_types[] =
--{
-- { NEMO_ICON_DND_GNOME_ICON_LIST_TYPE, 0, NEMO_ICON_DND_GNOME_ICON_LIST },
-- { NEMO_ICON_DND_URI_LIST_TYPE, 0, NEMO_ICON_DND_URI_LIST },
--};
--
- enum
- {
- TAB_CLOSE_REQUEST,
diff --git a/x11-fm/nemo/files/patch-src_nemo-view.c b/x11-fm/nemo/files/patch-src_nemo-view.c
deleted file mode 100644
index b50b32d24a44..000000000000
--- a/x11-fm/nemo/files/patch-src_nemo-view.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/nemo-view.orig.c 2013-03-02 09:17:03.405569034 +0100
-+++ src/nemo-view.c 2013-03-02 09:17:16.902582392 +0100
-@@ -680,7 +680,7 @@
- NemoZoomLevel
- nemo_view_get_default_zoom_level (NemoView *view)
- {
-- g_return_if_fail (NEMO_IS_VIEW (view));
-+ g_return_val_if_fail (NEMO_IS_VIEW (view), NEMO_ZOOM_LEVEL_STANDARD);
-
- if (!nemo_view_supports_zooming (view)) {
- return -1;
diff --git a/x11-fm/nemo/pkg-descr b/x11-fm/nemo/pkg-descr
index b4f3fd678e8f..9dc0d1a170ed 100644
--- a/x11-fm/nemo/pkg-descr
+++ b/x11-fm/nemo/pkg-descr
@@ -1,5 +1,3 @@
-Nautilus is a file manager tightly integrated into the GNOME destkop.
-It is also responsible for desktop and icon management, and provides
-an intuitive interface for accessing files and webpages.
+Nemo, forked from Nautilus, is the file manager of Cinnamon.
-WWW: http://www.gnome.org/projects/nautilus/
+WWW: http://cinnamon.linuxmint.com/
diff --git a/x11-fm/nemo/pkg-plist b/x11-fm/nemo/pkg-plist
index e975acbb1052..cc92b89e6f4d 100644
--- a/x11-fm/nemo/pkg-plist
+++ b/x11-fm/nemo/pkg-plist
@@ -1,9 +1,11 @@
bin/nemo
bin/nemo-autorun-software
bin/nemo-connect-server
+bin/nemo-desktop
bin/nemo-open-with
include/nemo/libnemo-extension/nemo-column-provider.h
include/nemo/libnemo-extension/nemo-column.h
+include/nemo/libnemo-extension/nemo-desktop-preferences.h
include/nemo/libnemo-extension/nemo-extension-types.h
include/nemo/libnemo-extension/nemo-file-info.h
include/nemo/libnemo-extension/nemo-info-provider.h
@@ -11,66 +13,108 @@ include/nemo/libnemo-extension/nemo-location-widget-provider.h
include/nemo/libnemo-extension/nemo-menu-item.h
include/nemo/libnemo-extension/nemo-menu-provider.h
include/nemo/libnemo-extension/nemo-menu.h
+include/nemo/libnemo-extension/nemo-name-and-desc-provider.h
include/nemo/libnemo-extension/nemo-property-page-provider.h
include/nemo/libnemo-extension/nemo-property-page.h
include/nemo/libnemo-extension/nemo-simple-button.h
lib/girepository-1.0/Nemo-3.0.typelib
-lib/libnemo-extension.a
lib/libnemo-extension.so
lib/libnemo-extension.so.1
lib/libnemo-extension.so.1.4.0
libdata/pkgconfig/libnemo-extension.pc
libexec/nemo-convert-metadata
+libexec/nemo-extensions-list
man/man1/nemo-connect-server.1.gz
man/man1/nemo.1.gz
share/applications/nemo-autorun-software.desktop
share/applications/nemo-autostart.desktop
share/applications/nemo.desktop
-share/dbus-1/services/org.Nemo.service
-share/dbus-1/services/org.freedesktop.NemoFileManager1.service
+share/dbus-1/services/nemo.service
+share/dbus-1/services/nemo.FileManager1.service
share/gir-1.0/Nemo-3.0.gir
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoColumn.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoColumnProvider.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoFileInfo.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoInfoProvider.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoLocationWidgetProvider.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoMenu.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoMenuProvider.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoPropertyPage.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoPropertyPageProvider.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/NemoSimpleButton.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/ch02.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/home.png
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/index.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/ix01.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/left.png
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/libnemo-extension-Types-and-Enums.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/libnemo-extension.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/pt01.html
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/right.png
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/style.css
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/libnemo-extension/up.png
share/gtksourceview-2.0/language-specs/nemo_action.lang
share/gtksourceview-3.0/language-specs/nemo_action.lang
+share/icons/hicolor/16x16/actions/menu-bullet.png
+share/icons/hicolor/16x16/actions/menu-none.png
+share/icons/hicolor/16x16/actions/menu-sort-down-free.png
+share/icons/hicolor/16x16/actions/menu-sort-down.png
+share/icons/hicolor/16x16/actions/menu-sort-left-free.png
+share/icons/hicolor/16x16/actions/menu-sort-left.png
+share/icons/hicolor/16x16/actions/menu-sort-right-free.png
+share/icons/hicolor/16x16/actions/menu-sort-right.png
+share/icons/hicolor/16x16/actions/menu-sort-up-free.png
+share/icons/hicolor/16x16/actions/menu-sort-up.png
share/icons/hicolor/16x16/actions/nemo-eject.png
share/icons/hicolor/16x16/apps/nemo.png
share/icons/hicolor/22x22/apps/nemo.png
share/icons/hicolor/24x24/apps/nemo.png
share/icons/hicolor/32x32/actions/nemo-eject.png
share/icons/hicolor/32x32/apps/nemo.png
+share/icons/hicolor/48x48/status/progress-0.png
+share/icons/hicolor/48x48/status/progress-10.png
+share/icons/hicolor/48x48/status/progress-100.png
+share/icons/hicolor/48x48/status/progress-20.png
+share/icons/hicolor/48x48/status/progress-30.png
+share/icons/hicolor/48x48/status/progress-40.png
+share/icons/hicolor/48x48/status/progress-50.png
+share/icons/hicolor/48x48/status/progress-60.png
+share/icons/hicolor/48x48/status/progress-70.png
+share/icons/hicolor/48x48/status/progress-80.png
+share/icons/hicolor/48x48/status/progress-90.png
share/icons/hicolor/scalable/actions/location-symbolic.svg
+share/icons/hicolor/scalable/actions/mount-archive-symbolic.svg
+share/icons/hicolor/scalable/actions/nemo-auto-arrange-symbolic.svg
+share/icons/hicolor/scalable/actions/nemo-desktop-scale-symbolic.svg
+share/icons/hicolor/scalable/actions/nemo-horizontal-layout-symbolic.svg
+share/icons/hicolor/scalable/actions/nemo-horizontal-layout-wide-symbolic.svg
+share/icons/hicolor/scalable/actions/nemo-vertical-layout-symbolic.svg
+share/icons/hicolor/scalable/actions/nemo-vertical-layout-wide-symbolic.svg
share/icons/hicolor/scalable/actions/sidebar-hide-symbolic.svg
share/icons/hicolor/scalable/actions/sidebar-places-symbolic.svg
share/icons/hicolor/scalable/actions/sidebar-show-symbolic.svg
share/icons/hicolor/scalable/actions/sidebar-tree-symbolic.svg
share/icons/hicolor/scalable/actions/view-compact-symbolic.svg
-share/icons/hicolor/scalable/status/progress-0-symbolic.svg
-share/icons/hicolor/scalable/status/progress-10-symbolic.svg
-share/icons/hicolor/scalable/status/progress-100-symbolic.svg
-share/icons/hicolor/scalable/status/progress-20-symbolic.svg
-share/icons/hicolor/scalable/status/progress-30-symbolic.svg
-share/icons/hicolor/scalable/status/progress-40-symbolic.svg
-share/icons/hicolor/scalable/status/progress-50-symbolic.svg
-share/icons/hicolor/scalable/status/progress-60-symbolic.svg
-share/icons/hicolor/scalable/status/progress-70-symbolic.svg
-share/icons/hicolor/scalable/status/progress-80-symbolic.svg
-share/icons/hicolor/scalable/status/progress-90-symbolic.svg
share/icons/hicolor/scalable/apps/nemo.svg
-share/mime/application/nemo-action.xml
-share/mime/application/x-nemo-saved-search.xml
+share/icons/hicolor/scalable/devices/drive-removable-media-usb-symbolic.svg
+share/icons/hicolor/scalable/status/nemo-bookmark-not-found-symbolic.svg
share/mime/packages/nemo.xml
-share/nemo/actions/90_new-workspace.nemo_action
-share/nemo/actions/91_delete-workspace.nemo_action
-share/nemo/actions/92_show-expo.nemo_action
-share/nemo/actions/add-desklets.nemo_action
-share/nemo/actions/change-background.nemo_action
-share/nemo/actions/mount-archive.nemo_action
-share/nemo/actions/myaction.py
-share/nemo/actions/new-launcher.nemo_action
-share/nemo/actions/sample.nemo_action
-share/nemo/actions/set-as-background.nemo_action
-share/nemo/icons/hicolor/16x16/emblems/emblem-note.png
-share/nemo/icons/hicolor/24x24/emblems/emblem-note.png
-share/nemo/icons/hicolor/48x48/emblems/emblem-note.png
-share/nemo/nemo-extras.placeholder
-share/nemo/nemo-suggested.placeholder
+%%DATADIR%%/actions/90_new-workspace.nemo_action
+%%DATADIR%%/actions/91_delete-workspace.nemo_action
+%%DATADIR%%/actions/92_show-expo.nemo_action
+%%DATADIR%%/actions/add-desklets.nemo_action
+%%DATADIR%%/actions/change-background.nemo_action
+%%DATADIR%%/actions/mount-archive.nemo_action
+%%DATADIR%%/actions/myaction.py
+%%DATADIR%%/actions/new-launcher.nemo_action
+%%DATADIR%%/actions/sample.nemo_action
+%%DATADIR%%/actions/set-as-background.nemo_action
+%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-note.png
+%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-note.png
+%%DATADIR%%/icons/hicolor/48x48/emblems/emblem-note.png
+%%DATADIR%%/script-info.md
share/polkit-1/actions/org.nemo.root.policy