aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2021-12-27 09:20:14 +0000
committerDima Panov <fluffy@FreeBSD.org>2021-12-27 09:24:11 +0000
commit53cb979642b065331d26cd25a566b30ed88170a4 (patch)
treedb0ed962f61104f75898e99eaaab0a3003bbb337 /x11-fm
parent7ad35a668ddb040e0b96cfa5d208ac89f0909fce (diff)
downloadports-53cb979642b065331d26cd25a566b30ed88170a4.tar.gz
ports-53cb979642b065331d26cd25a566b30ed88170a4.zip
x11-fm/nautilus: unbreak build after deskutils/libportal upgrade (+)
The portal-gtk3.h header has been moved into a separate subdir. Backport patch from upstream. Reported by: poudriere With hat: desktop Sponsored by: Netzkommune GmbH
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nautilus/Makefile1
-rw-r--r--x11-fm/nautilus/files/patch-git-55cfd66ccca391fc144f5863ff6bfc1f3b137e2d41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-fm/nautilus/Makefile b/x11-fm/nautilus/Makefile
index 7a96e3e40c71..3ca17bbf89e4 100644
--- a/x11-fm/nautilus/Makefile
+++ b/x11-fm/nautilus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= nautilus
PORTVERSION= 41.1
+PORTREVISION= 1
CATEGORIES= x11-fm gnome
MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
DIST_SUBDIR= gnome
diff --git a/x11-fm/nautilus/files/patch-git-55cfd66ccca391fc144f5863ff6bfc1f3b137e2d b/x11-fm/nautilus/files/patch-git-55cfd66ccca391fc144f5863ff6bfc1f3b137e2d
new file mode 100644
index 000000000000..f3ea5fbf66c6
--- /dev/null
+++ b/x11-fm/nautilus/files/patch-git-55cfd66ccca391fc144f5863ff6bfc1f3b137e2d
@@ -0,0 +1,41 @@
+diff --git meson.build meson.build
+index 927216636a21bfc0a4de3336e084c4d0084b6624..4626fa0bb7f69f84a3ba79f13bd869b641bad428 100644
+--- meson.build
++++ meson.build
+@@ -122,8 +122,10 @@ gnome_desktop = dependency('gnome-desktop-3.0', version: '>= 3.0.0')
+ gtk = dependency('gtk+-3.0', version: '>= 3.22.27')
+ libhandy = dependency('libhandy-1', version: '>= 1.1.90')
+ libportal = []
++libportal_gtk3 = []
+ if get_option('libportal')
+- libportal = dependency('libportal', version: '>= 0.3')
++ libportal = dependency('libportal', version: '>= 0.5')
++ libportal_gtk3 = dependency('libportal-gtk3', version: '>= 0.5')
+ endif
+ selinux = []
+ if get_option('selinux')
+diff --git src/meson.build src/meson.build
+index 682d6f3a3cd0899985ddd7a8b2a9479e5f1a5d79..d7fb76d53d5f3e6e28931734a7c55bf5443c06f7 100644
+--- src/meson.build
++++ src/meson.build
+@@ -285,6 +285,7 @@ nautilus_deps = [
+ libgd_dep,
+ libhandy,
+ libportal,
++ libportal_gtk3,
+ nautilus_extension,
+ selinux,
+ tracker_sparql,
+diff --git src/nautilus-files-view.c src/nautilus-files-view.c
+index dfb7fb26c0c8d2c55d76c1d4fc3a2b39fbec817b..a24005a110c40c9a1dd4954aa2d6beccd9b17182 100644
+--- src/nautilus-files-view.c
++++ src/nautilus-files-view.c
+@@ -93,7 +93,7 @@
+
+ #ifdef HAVE_LIBPORTAL
+ #include <libportal/portal.h>
+-#include <libportal/portal-gtk3.h>
++#include <libportal-gtk3/portal-gtk3.h>
+ #endif
+
+ /* Minimum starting update inverval */