aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-12 11:02:44 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-12 11:02:44 +0000
commit6725624678d5ec63a1318d4f46ef225a3056a526 (patch)
tree9cc2a1845c4e1855a33547fa51bca2e5fea499fb /x11-fm
parentbd8021cacf335a3a89a0487f8e765a80674258b8 (diff)
downloadports-6725624678d5ec63a1318d4f46ef225a3056a526.tar.gz
ports-6725624678d5ec63a1318d4f46ef225a3056a526.zip
x11-fm/doublecmd: multiple instances fix
* Fix fatal error when multiple instances of the app are executed PR: 253432 Submitted by: bbtruk@users.sourceforge.net (maintainer) MFH: 2021Q1 (runtime fix)
Notes
Notes: svn path=/head/; revision=565005
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/doublecmd/Makefile2
-rw-r--r--x11-fm/doublecmd/files/patch-src_platform_unix_upipeserver.pas44
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-fm/doublecmd/Makefile b/x11-fm/doublecmd/Makefile
index 98699ca7ef0d..a07abaf95893 100644
--- a/x11-fm/doublecmd/Makefile
+++ b/x11-fm/doublecmd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= doublecmd
PORTVERSION= 0.9.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-fm
MASTER_SITES= SF/${PORTNAME}/Double%20Commander%20Source
PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
diff --git a/x11-fm/doublecmd/files/patch-src_platform_unix_upipeserver.pas b/x11-fm/doublecmd/files/patch-src_platform_unix_upipeserver.pas
new file mode 100644
index 000000000000..c252924b38b9
--- /dev/null
+++ b/x11-fm/doublecmd/files/patch-src_platform_unix_upipeserver.pas
@@ -0,0 +1,44 @@
+--- src/platform/unix/upipeserver.pas.orig 2020-12-31 11:38:58 UTC
++++ src/platform/unix/upipeserver.pas
+@@ -30,9 +30,13 @@ function GetPipeFileName(const FileName: String; Globa
+
+ implementation
+
++{$IF DEFINED(LINUX) OR DEFINED(FREEBSD)}
++ {$DEFINE USE_XDG}
++{$ENDIF}
++
+ uses
+ SimpleIPC, BaseUnix, uPollThread
+-{$IF DEFINED(LINUX)}
++{$IF DEFINED(USE_XDG)}
+ , uXdg
+ {$ENDIF}
+ ;
+@@ -65,7 +69,7 @@ Type
+
+ function GetPipeFileName(const FileName: String; Global : Boolean): String;
+ begin
+-{$IF DEFINED(LINUX)}
++{$IF DEFINED(USE_XDG)}
+ Result:= IncludeTrailingBackslash(GetUserRuntimeDir) + FileName;
+ {$ELSE}
+ Result:= GetTempDir(Global) + ApplicationName + '-' + IntToStr(fpGetUID) + PathDelim + FileName;
+@@ -89,7 +93,7 @@ begin
+ end;
+
+ constructor TPipeServerComm.Create(AOWner: TSimpleIPCServer);
+-{$IF NOT DEFINED(LINUX)}
++{$IF NOT DEFINED(USE_XDG)}
+ var
+ Info: TStat;
+ Directory: String;
+@@ -101,7 +105,7 @@ begin
+ FFileName:= FFileName + '-' + IntToStr(fpGetPID);
+ if FFileName[1] <> '/' then
+ FFileName:= GetPipeFileName(FFileName, Owner.Global);
+-{$IF NOT DEFINED(LINUX)}
++{$IF NOT DEFINED(USE_XDG)}
+ // Verify directory owner
+ Directory:= ExtractFileDir(FFileName);
+ if not DirectoryExists(Directory) then