aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-30 01:30:32 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-30 01:30:32 +0000
commita9a5fdf462c40addda65b2c192d6f35c84501da5 (patch)
treeeb6fcfc1771696c3b35a357583f7f821eab7bd7a /x11-fm
parent35a2d544d692136c0361264bb555aaffc83200b0 (diff)
The purpose of this project is to create a multi-platform open
source file manager (Windows, Linux, FreeBSD, OS X) mimicking the look-n-feel of Far Manager. Features: * Mimic look-n-feel (including editor and shortcuts) of Far Manager * Built-in terminal * Built-in text editor with syntax highlighting * Built-in text viewer * Virtual file system (smb, ftp, sftp) * Very fast user interface WWW: https://github.com/corporateshark/WalCommander
Notes
Notes: svn path=/head/; revision=366585
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/walcommander/Makefile50
-rw-r--r--x11-fm/walcommander/distinfo2
-rw-r--r--x11-fm/walcommander/files/patch-wcm__CMakeLists.txt26
-rw-r--r--x11-fm/walcommander/files/patch-wcm__vfs.cpp43
-rw-r--r--x11-fm/walcommander/files/patch-wcm__wcm.desktop22
-rw-r--r--x11-fm/walcommander/pkg-descr14
7 files changed, 158 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index b4b01d1e3afa..8cfbd4fe3b89 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -31,6 +31,7 @@
SUBDIR += thunar-vfs
SUBDIR += twander
SUBDIR += ultracopier
+ SUBDIR += walcommander
SUBDIR += worker
SUBDIR += xcruise
SUBDIR += xdiskusage
diff --git a/x11-fm/walcommander/Makefile b/x11-fm/walcommander/Makefile
new file mode 100644
index 000000000000..2aea2f71142b
--- /dev/null
+++ b/x11-fm/walcommander/Makefile
@@ -0,0 +1,50 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= walcommander
+PORTVERSION= 0.16.1.git20140829
+CATEGORIES= x11-fm
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Multi-platform open source file manager
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= corporateshark
+GH_PROJECT= WalCommander
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 7038a3e
+
+USES= cmake:outsource
+USE_XORG= x11
+
+CMAKE_SOURCE_PATH=${WRKSRC}/wcm
+
+PORTDOCS= CHANGELOG CHANGELOG.GitHub README.md readme_eng.txt
+
+PLIST_FILES= bin/wcm \
+ share/applications/wcm.desktop \
+ share/pixmaps/wcm.ico
+
+OPTIONS_DEFINE= FREETYPE SMB SSH DOCS
+OPTIONS_DEFAULT=FREETYPE SMB SSH
+
+FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+FREETYPE_CMAKE_ON= -DWITH_FREETYPE=ON
+FREETYPE_CMAKE_OFF= -DWITH_FREETYPE=OFF
+SMB_LIB_DEPENDS= libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
+SMB_CMAKE_ON= -DWITH_SMBCLIENT=ON
+SMB_CMAKE_OFF= -DWITH_SMBCLIENT=OFF
+SSH_LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
+SSH_CMAKE_ON= -DWITH_LIBSSH2=ON
+SSH_CMAKE_OFF= -DWITH_LIBSSH2=OFF
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/x11-fm/walcommander/distinfo b/x11-fm/walcommander/distinfo
new file mode 100644
index 000000000000..0614a4249b41
--- /dev/null
+++ b/x11-fm/walcommander/distinfo
@@ -0,0 +1,2 @@
+SHA256 (walcommander-0.16.1.git20140829.tar.gz) = 379f48382878f0d435374f299ad1bce7f2438208127f643abe5f694e38a429ea
+SIZE (walcommander-0.16.1.git20140829.tar.gz) = 4795287
diff --git a/x11-fm/walcommander/files/patch-wcm__CMakeLists.txt b/x11-fm/walcommander/files/patch-wcm__CMakeLists.txt
new file mode 100644
index 000000000000..844ab10bf867
--- /dev/null
+++ b/x11-fm/walcommander/files/patch-wcm__CMakeLists.txt
@@ -0,0 +1,26 @@
+--- wcm/CMakeLists.txt.orig 2014-08-29 02:25:10.000000000 +0400
++++ wcm/CMakeLists.txt 2014-08-29 19:32:52.178444785 +0400
+@@ -28,12 +28,12 @@
+ SET(wcm_LIBS ${wcm_LIBS} ${FREETYPE_LIBRARIES})
+ ENDIF(WITH_FREETYPE)
+
+-IF(WITH_SSH2)
++IF(WITH_LIBSSH2)
+ FIND_PACKAGE(SSH2 REQUIRED)
+ ADD_DEFINITIONS(-DLIBSSH2_EXIST)
+ INCLUDE_DIRECTORIES(${SSH2_INCLUDE_DIR})
+ SET(wcm_LIBS ${wcm_LIBS} ${SSH2_LIBRARY})
+-ENDIF(WITH_SSH2)
++ENDIF(WITH_LIBSSH2)
+
+ IF(WITH_SMBCLIENT)
+ FIND_PACKAGE(SMBClient REQUIRED)
+@@ -174,3 +174,8 @@
+ # targets
+ ADD_EXECUTABLE(wcm ${wcm_SOURCES} ${wcm_HEADERS})
+ TARGET_LINK_LIBRARIES(wcm ${wcm_LIBS})
++
++# install
++INSTALL(TARGETS wcm RUNTIME DESTINATION bin)
++INSTALL(FILES wcm.desktop DESTINATION share/applications)
++INSTALL(FILES small.ico DESTINATION share/pixmaps RENAME wcm.ico)
diff --git a/x11-fm/walcommander/files/patch-wcm__vfs.cpp b/x11-fm/walcommander/files/patch-wcm__vfs.cpp
new file mode 100644
index 000000000000..45adc0706c90
--- /dev/null
+++ b/x11-fm/walcommander/files/patch-wcm__vfs.cpp
@@ -0,0 +1,43 @@
+--- wcm/vfs.cpp.orig 2014-08-29 02:25:10.000000000 +0400
++++ wcm/vfs.cpp 2014-08-29 19:14:40.984519553 +0400
+@@ -988,7 +988,14 @@
+ #include <sys/types.h>
+ #include <dirent.h>
+ #include <sys/time.h>
+-#include <sys/statfs.h>
++
++// for statfs()
++#ifdef __linux__
++# include <sys/statfs.h>
++#elif defined __FreeBSD__
++# include <sys/param.h>
++# include <sys/mount.h>
++#endif
+
+ #ifdef __linux__
+ # define OPENFLAG_LARGEFILE (O_LARGEFILE)
+@@ -1211,6 +1218,7 @@
+
+ int64 FSSys::GetFileSystemFreeSpace( FSPath& path, int* err )
+ {
++#ifdef __linux__
+ struct statfs64 s;
+
+ if ( statfs64( path.GetUtf8(), &s ) == -1 )
+@@ -1218,6 +1226,16 @@
+ SetError( err, errno );
+ return -1;
+ }
++#else
++ // FreeBSD and probably other systems have 64 bit support in regular statfs
++ struct statfs s;
++
++ if ( statfs( path.GetUtf8(), &s ) == -1 )
++ {
++ SetError( err, errno );
++ return -1;
++ }
++#endif
+
+ return ( int64 )( s.f_bfree ) * ( int64 )( s.f_bsize );
+ }
diff --git a/x11-fm/walcommander/files/patch-wcm__wcm.desktop b/x11-fm/walcommander/files/patch-wcm__wcm.desktop
new file mode 100644
index 000000000000..9c3e2bcfd87c
--- /dev/null
+++ b/x11-fm/walcommander/files/patch-wcm__wcm.desktop
@@ -0,0 +1,22 @@
+--- wcm/wcm.desktop.orig 2014-08-29 19:26:29.543471554 +0400
++++ wcm/wcm.desktop 2014-08-29 19:27:05.317468198 +0400
+@@ -0,0 +1,19 @@
++[Desktop Entry]
++Version=1.0
++Encoding=UTF-8
++Name=Wal Commander
++GenericName=file manager
++Comment=2-pane file manager
++Comment[fr]=2-gestionnaire de fichiers à panneaux
++Comment[de]=2-Fenster Dateimanager
++Comment[ja]=2-ペイン ファイル manager
++Comment[ru]=2-панельный файловый менеджер
++Comment[pl]=2-okno menedżer plików
++Comment[zh_CN]=2-面板 文件管理器
++Type=Application
++Exec=wcm
++TryExec=wcm
++Icon=wcm
++Terminal=false
++StartupNotify=false
++Categories=System;Utility;Core;FileTools;FileManager;
diff --git a/x11-fm/walcommander/pkg-descr b/x11-fm/walcommander/pkg-descr
new file mode 100644
index 000000000000..560b01201c9b
--- /dev/null
+++ b/x11-fm/walcommander/pkg-descr
@@ -0,0 +1,14 @@
+The purpose of this project is to create a multi-platform open
+source file manager (Windows, Linux, FreeBSD, OS X) mimicking the
+look-n-feel of Far Manager.
+
+Features:
+
+ * Mimic look-n-feel (including editor and shortcuts) of Far Manager
+ * Built-in terminal
+ * Built-in text editor with syntax highlighting
+ * Built-in text viewer
+ * Virtual file system (smb, ftp, sftp)
+ * Very fast user interface
+
+WWW: https://github.com/corporateshark/WalCommander