aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-28 18:32:45 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-28 18:32:45 +0000
commitbc087374d35aa9c841dd63d44e9c9697702921ed (patch)
tree9bfffecdf0e79fc2f3af0e2a2f1044536ad164ca /x11-fm
parent3689fb2140698b1b4eff0933fe730262b161f533 (diff)
downloadports-bc087374d35aa9c841dd63d44e9c9697702921ed.tar.gz
ports-bc087374d35aa9c841dd63d44e9c9697702921ed.zip
Update to use Tcl/Tk version 8.2.
Submitted by: Ade Lovett <ade@lovett.com>
Notes
Notes: svn path=/head/; revision=23474
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/x-files/Makefile8
-rw-r--r--x11-fm/x-files/files/patch-aa2
-rw-r--r--x11-fm/x-files/scripts/mktclIndex2
3 files changed, 6 insertions, 6 deletions
diff --git a/x11-fm/x-files/Makefile b/x11-fm/x-files/Makefile
index 6376efcd20b6..adc7a18b7be9 100644
--- a/x11-fm/x-files/Makefile
+++ b/x11-fm/x-files/Makefile
@@ -8,20 +8,20 @@
DISTNAME= X-Files-2.00b1
PKGNAME= x-files-2.00b1
-CATEGORIES= x11-fm tk80
+CATEGORIES= x11-fm tk82
MASTER_SITES= http://www.hut.fi/~mkivinie/X-Files/data/
MAINTAINER= dmaddox@conterra.com
-BUILD_DEPENDS= tclsh8.0:${PORTSDIR}/lang/tcl80
-RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
+BUILD_DEPENDS= tclsh8.2:${PORTSDIR}/lang/tcl82
+RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
WRKSRC= ${WRKDIR}/X-Files
NO_BUILD= yes
USE_X_PREFIX= yes
pre-install:
- @tclsh8.0 ${SCRIPTDIR}/mktclIndex ${WRKSRC}
+ @tclsh8.2 ${SCRIPTDIR}/mktclIndex ${WRKSRC}
@${RM} -f ${WRKSRC}/xfinstall.tcl
@${SED} s#@X11BASE@#${X11BASE}# <${WRKSRC}/X-Files.tcl >${WRKSRC}/tmpfile
@${MV} ${WRKSRC}/tmpfile ${WRKSRC}/X-Files.tcl
diff --git a/x11-fm/x-files/files/patch-aa b/x11-fm/x-files/files/patch-aa
index 23235b79535b..6b163d2fed05 100644
--- a/x11-fm/x-files/files/patch-aa
+++ b/x11-fm/x-files/files/patch-aa
@@ -4,7 +4,7 @@
+#!/bin/sh
+# The main file for the X-Files
+# The next line is executed by /bin/sh, but not Tcl \
-+exec wish8.0 $0 ${1+"$@"}
++exec wish8.2 $0 ${1+"$@"}
+set xf(xf_home) "@X11BASE@/lib/X11/X-Files/"
proc MAIN {argc argv} {
global xf xf_image env menu tk_version
diff --git a/x11-fm/x-files/scripts/mktclIndex b/x11-fm/x-files/scripts/mktclIndex
index 7307c7db1460..879a5bb403c7 100644
--- a/x11-fm/x-files/scripts/mktclIndex
+++ b/x11-fm/x-files/scripts/mktclIndex
@@ -1,3 +1,3 @@
-#!tclsh8.0
+#!tclsh8.2
pkg_mkIndex $argv be.tcl bgexec.tcl ee.tcl fae.tcl ftpl.tcl re.tcl vfs.tcl xf_sel.tcl
exit