aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-02-08 10:39:07 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2015-02-08 10:39:07 +0000
commitd2f807025e3f9c0baeb656f78588c978b1a42e51 (patch)
tree5dd5186800002819f522604efa4a7f0c70fbcbcc /x11-fm
parentb024bf4540b707009350aaaacb497423ab8bc2d2 (diff)
downloadports-d2f807025e3f9c0baeb656f78588c978b1a42e51.tar.gz
ports-d2f807025e3f9c0baeb656f78588c978b1a42e51.zip
Notes
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/worker/Makefile23
-rw-r--r--x11-fm/worker/distinfo4
-rw-r--r--x11-fm/worker/files/patch-src_dmcacheentrynwc.hh10
-rw-r--r--x11-fm/worker/files/patch-src_pathjumpui.hh11
-rw-r--r--x11-fm/worker/pkg-plist2
5 files changed, 38 insertions, 12 deletions
diff --git a/x11-fm/worker/Makefile b/x11-fm/worker/Makefile
index 3299b9047d1b..c15790435829 100644
--- a/x11-fm/worker/Makefile
+++ b/x11-fm/worker/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= worker
-PORTVERSION= 3.5.2
+PORTVERSION= 3.6.0
CATEGORIES= x11-fm
MASTER_SITES= http://www.boomerangsworld.de/cms/worker/downloads/
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= mp39590@gmail.com
COMMENT= X11 File Manager based on Directory Opus
@@ -16,21 +15,25 @@ RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
USE_XORG= x11
-USE_GCC= yes
USES= shebangfix tar:bzip2
SHEBANG_FILES= ${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/xeditor
-CFLAGS+= ${PTHREAD_CFLAGS}
-
-OPTIONS_DEFINE= XFT
+OPTIONS_DEFINE= XFT AVFS
+AVFS_DESC= Use AVFS library to access an archives
+AVFS_LIB_DEPENDS= libavfs.so:${PORTSDIR}/sysutils/avfs
XFT_CONFIGURE_ENABLE= xft
XFT_USE= XORG=xft
-pre-configure:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000024
+USE_GCC= 4.6+
+.else
+CONFIGURE_ARGS+= --disable-cxx-check
+CXXFLAGS+= -std=c++11
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-fm/worker/distinfo b/x11-fm/worker/distinfo
index 0d930287d105..fa381dbd25da 100644
--- a/x11-fm/worker/distinfo
+++ b/x11-fm/worker/distinfo
@@ -1,2 +1,2 @@
-SHA256 (worker-3.5.2.tar.bz2) = 9619edd29359d9e107aeb666208e379852cd462857fcfbf6f4507a8923226af6
-SIZE (worker-3.5.2.tar.bz2) = 1488217
+SHA256 (worker-3.6.0.tar.bz2) = 3b8f5451523fe73cd81317689ee61e3f8ed43a8f2087c945970cfb369110f735
+SIZE (worker-3.6.0.tar.bz2) = 1495468
diff --git a/x11-fm/worker/files/patch-src_dmcacheentrynwc.hh b/x11-fm/worker/files/patch-src_dmcacheentrynwc.hh
new file mode 100644
index 000000000000..f8adb74a4a94
--- /dev/null
+++ b/x11-fm/worker/files/patch-src_dmcacheentrynwc.hh
@@ -0,0 +1,10 @@
+--- src/dmcacheentrynwc.hh.orig 2015-01-08 18:44:53.000000000 +0300
++++ src/dmcacheentrynwc.hh 2015-01-20 14:58:29.000000000 +0300
+@@ -25,6 +25,7 @@
+ #include "wdefines.h"
+ #include "nwc_dir.hh"
+ #include <aguix/refcount.hh>
++#include <functional>
+
+ class DirBookmarksSettings;
+ class DirFilterSettings;
diff --git a/x11-fm/worker/files/patch-src_pathjumpui.hh b/x11-fm/worker/files/patch-src_pathjumpui.hh
new file mode 100644
index 000000000000..08d0dd7aa06d
--- /dev/null
+++ b/x11-fm/worker/files/patch-src_pathjumpui.hh
@@ -0,0 +1,11 @@
+--- src/pathjumpui.hh.orig 2015-01-08 18:44:53.000000000 +0300
++++ src/pathjumpui.hh 2015-01-20 00:01:56.000000000 +0300
+@@ -101,7 +101,7 @@
+ m_always_ignore( false )
+ {}
+
+- bool operator<( const pathjump_entry &rhs )
++ bool operator<( const pathjump_entry &rhs ) const
+ {
+ if ( m_blockcount < rhs.m_blockcount ) return true;
+ else if ( m_blockcount == rhs.m_blockcount ) {
diff --git a/x11-fm/worker/pkg-plist b/x11-fm/worker/pkg-plist
index 424d2eeeea61..1eae6aaa5d7a 100644
--- a/x11-fm/worker/pkg-plist
+++ b/x11-fm/worker/pkg-plist
@@ -96,3 +96,5 @@ share/applications/worker.desktop
%%DATADIR%%/config-updates/update-3.3.3.conf
%%DATADIR%%/config-updates/update-3.4.0-utf8.conf
%%DATADIR%%/config-updates/update-3.4.0.conf
+%%DATADIR%%/config-updates/update-3.6.0-utf8.conf
+%%DATADIR%%/config-updates/update-3.6.0.conf