aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fntsample
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-17 19:21:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-17 19:21:53 +0000
commit82f7361c9ae4add681d2cc0feb482671c0209638 (patch)
tree39fcaaeecdc692c759f0182c3802186d9b6c4909 /x11-fonts/fntsample
parentb8c1fa861d0e6ec1bd48dd7a9be9dac3eae1ed3d (diff)
downloadports-82f7361c9ae4add681d2cc0feb482671c0209638.tar.gz
ports-82f7361c9ae4add681d2cc0feb482671c0209638.zip
Update to 5.3
- Update MASTER_SITES - Update WWW Changes: https://github.com/eugmes/fntsample/releases
Notes
Notes: svn path=/head/; revision=490591
Diffstat (limited to 'x11-fonts/fntsample')
-rw-r--r--x11-fonts/fntsample/Makefile37
-rw-r--r--x11-fonts/fntsample/distinfo11
-rw-r--r--x11-fonts/fntsample/files/patch-CMakeLists.txt23
-rw-r--r--x11-fonts/fntsample/files/patch-po-CMakeLists.txt11
-rw-r--r--x11-fonts/fntsample/pkg-descr2
5 files changed, 59 insertions, 25 deletions
diff --git a/x11-fonts/fntsample/Makefile b/x11-fonts/fntsample/Makefile
index b47f9c2f1206..c14d7330371b 100644
--- a/x11-fonts/fntsample/Makefile
+++ b/x11-fonts/fntsample/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= fntsample
-PORTVERSION= 4.1
+PORTVERSION= 5.3
+DISTVERSIONPREFIX= release/
CATEGORIES= x11-fonts
-MASTER_SITES= SF/fntsample/fntsample/${PORTVERSION} \
- http://unicode.org/Public/6.0.0/ucd/:unidata
+MASTER_SITES= https://unicode.org/Public/12.0.0/ucd/:unidata
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- Blocks.txt:unidata
+ Blocks-12.0.0d1.txt:unidata
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= sunpoet@FreeBSD.org
@@ -16,27 +16,24 @@ COMMENT= Show Unicode coverage of a font
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
RUN_DEPENDS= pdfoutline:textproc/pdfoutline
-CONFIGURE_ARGS= --with-unicode-blocks=${WRKSRC}/Blocks.txt
-GNU_CONFIGURE= yes
-USE_GNOME= pango
-USE_PERL5= run
-USES= gettext gnome iconv perl5 pkgconfig
+USES= cmake gettext gnome iconv pkgconfig
+USE_GNOME= cairo glib20 pango
-PLIST_FILES= bin/${PORTNAME} \
- man/man1/${PORTNAME}.1.gz \
- share/locale/uk/LC_MESSAGES/${PORTNAME}.mo
+CMAKE_ARGS= -DUNICODE_BLOCKS=${WRKSRC}/Blocks-12.0.0d1.txt
+LDFLAGS+= -L${LOCALBASE}/lib
-post-extract:
- @${CP} ${DISTDIR}/${DIST_SUBDIR}/Blocks.txt ${WRKSRC}/
+PLIST_FILES= bin/fntsample \
+ man/man1/fntsample.1.gz \
+ share/locale/uk/LC_MESSAGES/fntsample.mo
-post-patch:
- @${REINPLACE_CMD} -e '/^bin_SCRIPTS/d' ${WRKSRC}/Makefile.in
+GH_ACCOUNT= eugmes
+USE_GITHUB= yes
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1/
- ${INSTALL_DATA} ${WRKSRC}/po/uk.gmo ${STAGEDIR}${PREFIX}/share/locale/uk/LC_MESSAGES/${PORTNAME}.mo
+post-extract:
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/Blocks-12.0.0d1.txt ${WRKSRC}/
.include <bsd.port.mk>
diff --git a/x11-fonts/fntsample/distinfo b/x11-fonts/fntsample/distinfo
index 2c75c85c413a..3eb462bdb5a4 100644
--- a/x11-fonts/fntsample/distinfo
+++ b/x11-fonts/fntsample/distinfo
@@ -1,4 +1,7 @@
-SHA256 (fntsample-4.1.tar.gz) = 1824f7e452b56671cf451819a46af70db549213e5c189e6b3cda273cd05e2411
-SIZE (fntsample-4.1.tar.gz) = 190420
-SHA256 (Blocks.txt) = bddae53925efebe265e170e9dfd34811a584e5f59d2b18e3d9f9c7f5c8eb9c08
-SIZE (Blocks.txt) = 7119
+TIMESTAMP = 1547659022
+SHA256 (eugmes-fntsample-release-5.3_GH0.tar.gz) = e4e8b50b0a5e984cfdaa32b7d133bd3bf0c62edb14f752f7df1190176023972b
+SIZE (eugmes-fntsample-release-5.3_GH0.tar.gz) = 56508
+SHA256 (Blocks-12.0.0d1.txt) = a1a3ca4381eb91f7b65afe7cb7df615cdcf67993fef4b486585f66b349993a10
+SIZE (Blocks-12.0.0d1.txt) = 10086
+SHA256 (eugmes-fntsample-release-5.3_GH0.tar.gz) = e4e8b50b0a5e984cfdaa32b7d133bd3bf0c62edb14f752f7df1190176023972b
+SIZE (eugmes-fntsample-release-5.3_GH0.tar.gz) = 56508
diff --git a/x11-fonts/fntsample/files/patch-CMakeLists.txt b/x11-fonts/fntsample/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..214c58167999
--- /dev/null
+++ b/x11-fonts/fntsample/files/patch-CMakeLists.txt
@@ -0,0 +1,23 @@
+--- CMakeLists.txt.orig 2018-12-26 07:13:37 UTC
++++ CMakeLists.txt
+@@ -44,8 +44,6 @@ add_compile_options(-Wall -W -Wwrite-str
+
+ configure_file(config.h.in config.h @ONLY)
+ configure_file(fntsample.1.in fntsample.1 @ONLY)
+-configure_file(pdfoutline.1.in pdfoutline.1 @ONLY)
+-configure_file(pdfoutline.pl pdfoutline @ONLY)
+
+ include_directories(fntsample
+ ${CMAKE_CURRENT_BINARY_DIR}
+@@ -81,11 +79,7 @@ target_link_libraries(fntsample
+
+ install(TARGETS fntsample DESTINATION ${CMAKE_INSTALL_BINDIR})
+
+-install(PROGRAMS "${CMAKE_CURRENT_BINARY_DIR}/pdfoutline"
+- DESTINATION ${CMAKE_INSTALL_BINDIR})
+-
+ install(FILES "${PROJECT_BINARY_DIR}/fntsample.1"
+- "${PROJECT_BINARY_DIR}/pdfoutline.1"
+ DESTINATION "${CMAKE_INSTALL_MANDIR}/man1")
+
+ add_subdirectory(po)
diff --git a/x11-fonts/fntsample/files/patch-po-CMakeLists.txt b/x11-fonts/fntsample/files/patch-po-CMakeLists.txt
new file mode 100644
index 000000000000..ff058c624e73
--- /dev/null
+++ b/x11-fonts/fntsample/files/patch-po-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- po/CMakeLists.txt.orig 2018-12-26 07:13:37 UTC
++++ po/CMakeLists.txt
+@@ -6,7 +6,7 @@ function(process_po_files _langs)
+ foreach(_lang ${_langs})
+ set(_po_file "${CMAKE_CURRENT_SOURCE_DIR}/${_lang}.po")
+ set(_gmo_file "${CMAKE_CURRENT_BINARY_DIR}/${_lang}.gmo")
+- set(_gmo_file_tgt "${_lang}.gmo")
++ set(_gmo_file_tgt "${_lang}_gmo")
+
+ add_custom_command(OUTPUT ${_gmo_file}
+ COMMAND ${GETTEXT_MSGFMT_EXECUTABLE} ${_po_file} -o ${_gmo_file}
diff --git a/x11-fonts/fntsample/pkg-descr b/x11-fonts/fntsample/pkg-descr
index 44b726b6b657..bea32f6e6d64 100644
--- a/x11-fonts/fntsample/pkg-descr
+++ b/x11-fonts/fntsample/pkg-descr
@@ -2,4 +2,4 @@ A program for making font samples that show Unicode coverage of the font and are
similar in appearance to Unicode charts. Samples can be saved as PDF or
PostScript files.
-WWW: http://fntsample.sourceforge.net/
+WWW: https://github.com/eugmes/fntsample