aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/fontmatrix
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-09-13 20:51:29 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-09-13 20:51:29 +0000
commit3e372319e23473218d6ce653530788002a2a9e8b (patch)
tree3c87f8dfeb0534ab4a373c70d0de0e42970863d1 /x11-fonts/fontmatrix
parent69946a41c80b11a24a58fa889bfb046cb29b7430 (diff)
downloadports-3e372319e23473218d6ce653530788002a2a9e8b.tar.gz
ports-3e372319e23473218d6ce653530788002a2a9e8b.zip
Resurrect x11-fonts/fontmatrix. Upstream project has been forked and ported from
Qt4 to the Qt5 framework. Take maintainership.
Notes
Notes: svn path=/head/; revision=511991
Diffstat (limited to 'x11-fonts/fontmatrix')
-rw-r--r--x11-fonts/fontmatrix/Makefile25
-rw-r--r--x11-fonts/fontmatrix/distinfo3
-rw-r--r--x11-fonts/fontmatrix/files/patch-CMakeLists.txt11
-rw-r--r--x11-fonts/fontmatrix/files/patch-src_fmutils.cpp18
-rw-r--r--x11-fonts/fontmatrix/pkg-descr8
-rw-r--r--x11-fonts/fontmatrix/pkg-plist139
6 files changed, 204 insertions, 0 deletions
diff --git a/x11-fonts/fontmatrix/Makefile b/x11-fonts/fontmatrix/Makefile
new file mode 100644
index 000000000000..fcde9856781e
--- /dev/null
+++ b/x11-fonts/fontmatrix/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= fontmatrix
+DISTVERSION= g20190429
+CATEGORIES= x11-fonts
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Graphical font manager
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= cmake qt:5
+
+USE_GITHUB= yes
+USE_QT= buildtools core gui linguisttools network printsupport \
+ qmake_build sql svg webkit widgets xml
+
+GH_ACCOUNT= fcoiffie
+GH_TAGNAME= 51dd8f2
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/fontmatrix/distinfo b/x11-fonts/fontmatrix/distinfo
new file mode 100644
index 000000000000..945728567203
--- /dev/null
+++ b/x11-fonts/fontmatrix/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568052852
+SHA256 (fcoiffie-fontmatrix-g20190429-51dd8f2_GH0.tar.gz) = a302e2ce1cad6c669e529f7fe95368d7bc0ecf1c8aa9685757f70efdaec0f6e5
+SIZE (fcoiffie-fontmatrix-g20190429-51dd8f2_GH0.tar.gz) = 1985176
diff --git a/x11-fonts/fontmatrix/files/patch-CMakeLists.txt b/x11-fonts/fontmatrix/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d5343768946c
--- /dev/null
+++ b/x11-fonts/fontmatrix/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2019-04-29 07:46:55 UTC
++++ CMakeLists.txt
+@@ -209,7 +209,7 @@ ADD_SUBDIRECTORY(src)
+
+ IF(UNIX AND NOT APPLE)
+ SET(DESKTOPDIR "share/applications/")
+- SET(MANDIR "share/man/")
++ SET(MANDIR "man/")
+ SET(ICONDIR "share/icons/hicolor/48x48/apps/")
+ SET(RESOURCESDIR "share/fontmatrix/resources/")
+ SET(HELPDIR "share/fontmatrix/help/")
diff --git a/x11-fonts/fontmatrix/files/patch-src_fmutils.cpp b/x11-fonts/fontmatrix/files/patch-src_fmutils.cpp
new file mode 100644
index 000000000000..1b7739abfa1a
--- /dev/null
+++ b/x11-fonts/fontmatrix/files/patch-src_fmutils.cpp
@@ -0,0 +1,18 @@
+--- src/fmutils.cpp.orig 2019-04-29 07:46:55 UTC
++++ src/fmutils.cpp
+@@ -12,7 +12,7 @@
+
+ #include "fmutils.h"
+
+-#if !defined(_WIN32) && !defined(Q_OS_MAC)
++#if !defined(_WIN32) && !defined(Q_OS_MAC) && !defined(__FreeBSD__)
+ #include <execinfo.h>
+ #include <cxxabi.h>
+ #include <cstdlib>
+@@ -68,4 +68,4 @@ void printBacktrace ( int frames )
+ }
+
+
+-#endif
+\ No newline at end of file
++#endif
diff --git a/x11-fonts/fontmatrix/pkg-descr b/x11-fonts/fontmatrix/pkg-descr
new file mode 100644
index 000000000000..8bb39020011e
--- /dev/null
+++ b/x11-fonts/fontmatrix/pkg-descr
@@ -0,0 +1,8 @@
+Fontmatrix is a graphical font manager. Targeted audience are mostly
+adventurous graphic designers and typesetters who deal with hundreds
+and even more fonts during their work - browsing the endless lists
+of font dialogs. Basically, the Fontmatrix helps doing three things:
+activation and deactivation of fonts, tagging fonts and fontbook
+generation.
+
+WWW: https://github.com/fcoiffie/fontmatrix
diff --git a/x11-fonts/fontmatrix/pkg-plist b/x11-fonts/fontmatrix/pkg-plist
new file mode 100644
index 000000000000..deb962bbdd5e
--- /dev/null
+++ b/x11-fonts/fontmatrix/pkg-plist
@@ -0,0 +1,139 @@
+bin/fontmatrix
+man/man1/fontmatrix.1.gz
+share/applications/fontmatrix.desktop
+%%DATADIR%%/help/en/additional.html
+%%DATADIR%%/help/en/additional_db_check.html
+%%DATADIR%%/help/en/additional_editing_panose.html
+%%DATADIR%%/help/en/additional_export_for_packaging.html
+%%DATADIR%%/help/en/additional_extracting_fonts.html
+%%DATADIR%%/help/en/additional_ttf_tables.html
+%%DATADIR%%/help/en/basics.html
+%%DATADIR%%/help/en/comparisons.html
+%%DATADIR%%/help/en/comparisons_fonts.html
+%%DATADIR%%/help/en/comparisons_glyphs.html
+%%DATADIR%%/help/en/contributing.html
+%%DATADIR%%/help/en/contributing_programming.html
+%%DATADIR%%/help/en/contributing_testing.html
+%%DATADIR%%/help/en/contributing_translating.html
+%%DATADIR%%/help/en/creating_font_books.html
+%%DATADIR%%/help/en/export_fonts.html
+%%DATADIR%%/help/en/external_tools.html
+%%DATADIR%%/help/en/font_book_templates.html
+%%DATADIR%%/help/en/font_books.html
+%%DATADIR%%/help/en/images/browse-fonts-folders-tab.png
+%%DATADIR%%/help/en/images/browse-fonts-names-tab.png
+%%DATADIR%%/help/en/images/browse-fonts-previews-tab.png
+%%DATADIR%%/help/en/images/close_to_system_tray_warning.png
+%%DATADIR%%/help/en/images/extracted-font-compact-encoding.png
+%%DATADIR%%/help/en/images/extracted-font-copyright-info.png
+%%DATADIR%%/help/en/images/extracted-font-editing.png
+%%DATADIR%%/help/en/images/font_book_export_dialog.png
+%%DATADIR%%/help/en/images/font_book_in_evince.png
+%%DATADIR%%/help/en/images/glyphs_comparison_metrics.png
+%%DATADIR%%/help/en/images/glyphs_comparison_offset_to_line_up.png
+%%DATADIR%%/help/en/images/glyphs_comparison_offset_to_line_up_2.png
+%%DATADIR%%/help/en/images/glyphs_comparison_points_and_controls.png
+%%DATADIR%%/help/en/images/glyphs_comparison_two_glyphs_of_same_font.png
+%%DATADIR%%/help/en/images/glyphs_comparison_typical_view.png
+%%DATADIR%%/help/en/images/glyphs_comparison_typical_view_th.png
+%%DATADIR%%/help/en/images/imported_fonts_list.png
+%%DATADIR%%/help/en/images/importing_set_tags_1.png
+%%DATADIR%%/help/en/images/importing_set_tags_2.png
+%%DATADIR%%/help/en/images/list_of_tags.png
+%%DATADIR%%/help/en/images/splash-screen.png
+%%DATADIR%%/help/en/index.html
+%%DATADIR%%/help/en/interface.html
+%%DATADIR%%/help/en/management.html
+%%DATADIR%%/help/en/management_activation.html
+%%DATADIR%%/help/en/management_importing.html
+%%DATADIR%%/help/en/management_tags.html
+%%DATADIR%%/help/en/menu.xml
+%%DATADIR%%/help/en/news.html
+%%DATADIR%%/help/en/output.html
+%%DATADIR%%/help/en/printing_fonts.html
+%%DATADIR%%/help/en/resources.html
+%%DATADIR%%/help/en/scripting.html
+%%DATADIR%%/help/en/search.html
+%%DATADIR%%/help/en/search_in_generic_metadata.html
+%%DATADIR%%/help/en/search_in_panose.html
+%%DATADIR%%/help/en/search_using_bitmap_samples.html
+%%DATADIR%%/help/en/setting_up.html
+%%DATADIR%%/help/en/setting_up_layout_engine_options.html
+%%DATADIR%%/help/en/setting_up_preferences.html
+%%DATADIR%%/help/en/setting_up_preferences_display.html
+%%DATADIR%%/help/en/setting_up_preferences_files_and_folders.html
+%%DATADIR%%/help/en/setting_up_preferences_general.html
+%%DATADIR%%/help/en/setting_up_preferences_samples_collection.html
+%%DATADIR%%/help/en/setting_up_preferences_service.html
+%%DATADIR%%/help/en/setting_up_preferences_shortcuts.html
+%%DATADIR%%/help/en/setting_up_preferences_system_tray.html
+%%DATADIR%%/help/en/style.css
+%%DATADIR%%/help/en/viewing.html
+%%DATADIR%%/help/en/viewing_glyphs_chart.html
+%%DATADIR%%/help/en/viewing_overview.html
+%%DATADIR%%/help/en/viewing_sample_text.html
+%%DATADIR%%/help/en/what_fonts_are.html
+%%DATADIR%%/help/en/why_fontmatrix.html
+%%DATADIR%%/help/en/why_management.html
+%%DATADIR%%/qm/fontmatrix-cs.qm
+%%DATADIR%%/qm/fontmatrix-da.qm
+%%DATADIR%%/qm/fontmatrix-de.qm
+%%DATADIR%%/qm/fontmatrix-en.qm
+%%DATADIR%%/qm/fontmatrix-fi.qm
+%%DATADIR%%/qm/fontmatrix-fr.qm
+%%DATADIR%%/qm/fontmatrix-hi.qm
+%%DATADIR%%/qm/fontmatrix-nb.qm
+%%DATADIR%%/qm/fontmatrix-nl.qm
+%%DATADIR%%/qm/fontmatrix-no.qm
+%%DATADIR%%/qm/fontmatrix-ru.qm
+%%DATADIR%%/qm/fontmatrix-sr.qm
+%%DATADIR%%/qm/fontmatrix-sv.qm
+%%DATADIR%%/qm/fontmatrix-uk.qm
+%%DATADIR%%/qm/fontmatrix-zh_CN.qm
+%%DATADIR%%/qm/fontmatrix-zh_TW.qm
+%%DATADIR%%/resources/Samples/bn/sample
+%%DATADIR%%/resources/Samples/de/sample
+%%DATADIR%%/resources/Samples/fr/Mamere
+%%DATADIR%%/resources/Samples/gu/sample
+%%DATADIR%%/resources/Samples/he/sample
+%%DATADIR%%/resources/Samples/hi/sample
+%%DATADIR%%/resources/Samples/kn/sample
+%%DATADIR%%/resources/Samples/ml/sample
+%%DATADIR%%/resources/Samples/mr/sample
+%%DATADIR%%/resources/Samples/or/sample
+%%DATADIR%%/resources/Samples/pa/sample
+%%DATADIR%%/resources/Samples/ru/Гоголь
+%%DATADIR%%/resources/Samples/ta/sample
+%%DATADIR%%/resources/Samples/te/sample
+%%DATADIR%%/resources/Samples/udm/sample
+%%DATADIR%%/resources/Scripts/fontforge_subset.py
+%%DATADIR%%/resources/Scripts/fonttools_showxml.py
+%%DATADIR%%/resources/Scripts/import_tags.py
+%%DATADIR%%/resources/Scripts/xetex_fontbook.py
+%%DATADIR%%/resources/css-info-property.png
+%%DATADIR%%/resources/css-info-propertyname.png
+%%DATADIR%%/resources/css-shadow.png
+%%DATADIR%%/resources/css-tech-info.png
+%%DATADIR%%/resources/fontmatrix.js
+%%DATADIR%%/resources/info.css
+%%DATADIR%%/resources/template_default.png
+%%DATADIR%%/resources/template_default.xml
+%%DATADIR%%/resources/template_oneline.png
+%%DATADIR%%/resources/template_oneline.xml
+%%DATADIR%%/resources/welcome_cs.html
+%%DATADIR%%/resources/welcome_da.html
+%%DATADIR%%/resources/welcome_de.html
+%%DATADIR%%/resources/welcome_en.html
+%%DATADIR%%/resources/welcome_fi.html
+%%DATADIR%%/resources/welcome_fr.html
+%%DATADIR%%/resources/welcome_hi.html
+%%DATADIR%%/resources/welcome_nb.html
+%%DATADIR%%/resources/welcome_nl.html
+%%DATADIR%%/resources/welcome_no.html
+%%DATADIR%%/resources/welcome_ru.html
+%%DATADIR%%/resources/welcome_sr.html
+%%DATADIR%%/resources/welcome_sv.html
+%%DATADIR%%/resources/welcome_uk.html
+%%DATADIR%%/resources/welcome_zh_CN.html
+%%DATADIR%%/resources/welcome_zh_TW.html
+share/icons/hicolor/48x48/apps/fontmatrix.png