aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/geminifonts
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2005-07-11 16:47:36 +0000
committerMikhail Teterin <mi@FreeBSD.org>2005-07-11 16:47:36 +0000
commitd547be1c47669e324b64bed6e0d30b01d454b3b4 (patch)
tree4adc150ecee9212be210e1382ccc7a601149dd77 /x11-fonts/geminifonts
parentd5a8ad9d477e44e7edec30b4f6061444c86eac6b (diff)
downloadports-d547be1c47669e324b64bed6e0d30b01d454b3b4.tar.gz
ports-d547be1c47669e324b64bed6e0d30b01d454b3b4.zip
Change the software's Makefile to run `mkfontdir' in the destination
directory after install instead of the ${WRKSRC} after build. This works around a bug in Xorg's mkfontdir, which lists both -- the bdf-sources and the pcf-binary fonts -- in the generated fonts.dir.
Notes
Notes: svn path=/head/; revision=138920
Diffstat (limited to 'x11-fonts/geminifonts')
-rw-r--r--x11-fonts/geminifonts/Makefile1
-rw-r--r--x11-fonts/geminifonts/files/patch-gz18
2 files changed, 18 insertions, 1 deletions
diff --git a/x11-fonts/geminifonts/Makefile b/x11-fonts/geminifonts/Makefile
index 6b00723ca67f..3f87749b6351 100644
--- a/x11-fonts/geminifonts/Makefile
+++ b/x11-fonts/geminifonts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gemini
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://www.brama.com/compute/unix/
PKGNAMEPREFIX= koi8-u-
diff --git a/x11-fonts/geminifonts/files/patch-gz b/x11-fonts/geminifonts/files/patch-gz
index fff0a7159118..9ca25d421b66 100644
--- a/x11-fonts/geminifonts/files/patch-gz
+++ b/x11-fonts/geminifonts/files/patch-gz
@@ -1,5 +1,21 @@
--- Makefile Sun Dec 31 11:22:34 1995
-+++ Makefile Sun Jan 21 11:54:00 2001
++++ Makefile Mon Jul 11 12:37:08 2005
+@@ -53,5 +53,4 @@
+
+ all: $(SRC) $(ROMAN) $(SLANT) $(BOLD) $(BSLANT) $(FIXED)
+- mkfontdir .
+
+ src: $(SRC)
+@@ -63,6 +62,7 @@
+ install:
+ -mkdir $(DESTDIR)
+- for i in $(ROMAN) $(SLANT) $(BOLD) $(BSLANT) $(FIXED) fonts.dir fonts.alias;\
+- do install -c -m 444 $$i $(DESTDIR)/$$i; done
++ ${BSD_INSTALL_DATA} $(ROMAN) $(SLANT) $(BOLD) $(BSLANT) $(FIXED) \
++ fonts.alias $(DESTDIR)/
++ mkfontdir $(DESTDIR)
+
+ package:
@@ -75 +75 @@
- bdftopcf -t $< | compress > $@
+ bdftopcf -t $< | gzip -9 > $@