aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/libXfont
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2013-05-25 14:37:02 +0000
commit92ea0d614b10bd99ce43a611721c7c4003cd79a5 (patch)
treecf13f962932aab3646f0af684b2923c4e0f0825b /x11-fonts/libXfont
parentffbb85145227efbc987e5d09cab804f896bf37f5 (diff)
downloadports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.tar.gz
ports-92ea0d614b10bd99ce43a611721c7c4003cd79a5.zip
The FreeBSD x11 team proudly presents
an zeising, kwm, miwi, bapt, eadler production: Xorg 7.7 Starring: xserver 1.12.4 (new xorg only) Mesa 8.0.4, including libGL, libGLU and dri (new xorg only) libX11 1.5.0 libxcb 1.9 libdrm 2.4.42 (new xorg only) freeglut 2.8.1 Also starring: Updates to drivers and other libraries and utilities Additional notes: Change pkgconf to be a build dependency. Add a new USE_XORG, xcb, to depend on libxcb and update all ports to use this. Trim makefile headers. Take maintanership of x11/xcb-proto, ok'd by ashish. If you are running WITH_NEW_XORG=, you need to rebuild all installed drivers, see UPDATING for more information. Various fixes to make ports compile. PR: ports/177942 Exp-run by: miwi Approved by: portmgr (miwi) Thanks to all who helped testing!
Notes
Notes: svn path=/head/; revision=319055
Diffstat (limited to 'x11-fonts/libXfont')
-rw-r--r--x11-fonts/libXfont/Makefile9
-rw-r--r--x11-fonts/libXfont/distinfo4
-rw-r--r--x11-fonts/libXfont/files/patch-src_fontfile_decompress.c101
3 files changed, 4 insertions, 110 deletions
diff --git a/x11-fonts/libXfont/Makefile b/x11-fonts/libXfont/Makefile
index 841f08226709..922cce5de158 100644
--- a/x11-fonts/libXfont/Makefile
+++ b/x11-fonts/libXfont/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: libXfont
-# Date Created: 29 Oct, 2003
-# Whom: Eric Anholt <anholt@FreeBSD.org>
-#
+# Created by: Eric Anholt <anholt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libXfont
-PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTVERSION= 1.4.5
PORTEPOCH= 1
CATEGORIES= x11-fonts
diff --git a/x11-fonts/libXfont/distinfo b/x11-fonts/libXfont/distinfo
index 41f79caa5bf5..caac3e2a6446 100644
--- a/x11-fonts/libXfont/distinfo
+++ b/x11-fonts/libXfont/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/lib/libXfont-1.4.4.tar.bz2) = a2065f5f66882f7a9cb0eb674e16d284da48e449af443eda272e99832be8239a
-SIZE (xorg/lib/libXfont-1.4.4.tar.bz2) = 440022
+SHA256 (xorg/lib/libXfont-1.4.5.tar.bz2) = bbf96fb80b6b95cdb1dc968085082a6e668193a54cd9d6e2af669909c0cb7170
+SIZE (xorg/lib/libXfont-1.4.5.tar.bz2) = 470879
diff --git a/x11-fonts/libXfont/files/patch-src_fontfile_decompress.c b/x11-fonts/libXfont/files/patch-src_fontfile_decompress.c
deleted file mode 100644
index 7499041631fa..000000000000
--- a/x11-fonts/libXfont/files/patch-src_fontfile_decompress.c
+++ /dev/null
@@ -1,101 +0,0 @@
-From bd48ad11fd11412c62c3ac8ed5d52c4f10a985aa Mon Sep 17 00:00:00 2001
-From: Joerg Sonnenberger <joerg@britannica.bec.de>
-Date: Sun, 21 Aug 2011 16:51:53 +0000
-Subject: Do proper input validation to fix for CVE-2011-2895.
-
-It ensures that all valid input can be decompressed, checks that the
-overflow conditions doesn't happen and generally tightens the
-validation of the LZW stream and doesn't pessimize the inner loop for
-no good reason. It's derived from a change in libarchive from 2004.
-
-Signed-off-by: Matthieu Herrb <matthieu.herrb@laas.fr>
-Reviewed-by: Tomas Hoger <thoger@redhat.com>
-
---- src/fontfile/decompress.c.orig 2011-08-10 22:22:01.000000000 +0200
-+++ src/fontfile/decompress.c 2012-03-13 12:55:35.000000000 +0100
-@@ -97,7 +97,7 @@ static char_type magic_header[] = { "\03
- #define FIRST 257 /* first free entry */
- #define CLEAR 256 /* table clear output code */
-
--#define STACK_SIZE 8192
-+#define STACK_SIZE 65300
-
- typedef struct _compressedFILE {
- BufFilePtr file;
-@@ -178,14 +178,12 @@ BufFilePushCompressed (BufFilePtr f)
- file->tab_suffix[code] = (char_type) code;
- }
- file->free_ent = ((file->block_compress) ? FIRST : 256 );
-+ file->oldcode = -1;
- file->clear_flg = 0;
- file->offset = 0;
- file->size = 0;
- file->stackp = file->de_stack;
- bzero(file->buf, BITS);
-- file->finchar = file->oldcode = getcode (file);
-- if (file->oldcode != -1)
-- *file->stackp++ = file->finchar;
- return BufFileCreate ((char *) file,
- BufCompressedFill,
- 0,
-@@ -230,9 +228,6 @@ BufCompressedFill (BufFilePtr f)
- if (buf == bufend)
- break;
-
-- if (oldcode == -1)
-- break;
--
- code = getcode (file);
- if (code == -1)
- break;
-@@ -241,26 +236,35 @@ BufCompressedFill (BufFilePtr f)
- for ( code = 255; code >= 0; code-- )
- file->tab_prefix[code] = 0;
- file->clear_flg = 1;
-- file->free_ent = FIRST - 1;
-- if ( (code = getcode (file)) == -1 ) /* O, untimely death! */
-- break;
-+ file->free_ent = FIRST;
-+ oldcode = -1;
-+ continue;
- }
- incode = code;
- /*
- * Special case for KwKwK string.
- */
- if ( code >= file->free_ent ) {
-+ if ( code > file->free_ent || oldcode == -1 ) {
-+ /* Bad stream. */
-+ return BUFFILEEOF;
-+ }
- *stackp++ = finchar;
- code = oldcode;
- }
--
-+
-+ /*
-+ * The above condition ensures that code < free_ent.
-+ * The construction of tab_prefixof in turn guarantees that
-+ * each iteration decreases code and therefore stack usage is
-+ * bound by 1 << BITS - 256.
-+ */
-+
- /*
- * Generate output characters in reverse order
- */
- while ( code >= 256 )
- {
-- if (stackp - de_stack >= STACK_SIZE - 1)
-- return BUFFILEEOF;
- *stackp++ = file->tab_suffix[code];
- code = file->tab_prefix[code];
- }
-@@ -270,7 +274,7 @@ BufCompressedFill (BufFilePtr f)
- /*
- * Generate the new entry.
- */
-- if ( (code=file->free_ent) < file->maxmaxcode ) {
-+ if ( (code=file->free_ent) < file->maxmaxcode && oldcode != -1) {
- file->tab_prefix[code] = (unsigned short)oldcode;
- file->tab_suffix[code] = finchar;
- file->free_ent = code+1;