aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/libXft
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-05 18:27:03 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-05 18:27:03 +0000
commit238fa4a636e8882424b515eda80313fdeff4fbce (patch)
tree4a4fe17c1996e0fc1e820d39469a36b99db83db2 /x11-fonts/libXft
parent9c3cf5f690ea0468b7847fb6b6597874e9af47a1 (diff)
downloadports-238fa4a636e8882424b515eda80313fdeff4fbce.tar.gz
ports-238fa4a636e8882424b515eda80313fdeff4fbce.zip
Add patch to fix build with freetype 2.5.1.
Use a LIB_DEPEND line to replace a RUN_/BUILD_ lines for fontconfig. Stageify.
Notes
Notes: svn path=/head/; revision=335678
Diffstat (limited to 'x11-fonts/libXft')
-rw-r--r--x11-fonts/libXft/Makefile11
-rw-r--r--x11-fonts/libXft/files/patch-src_xftglyphs.c17
-rw-r--r--x11-fonts/libXft/pkg-plist1
3 files changed, 22 insertions, 7 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index 28eb60397ee0..9cf1b5528f24 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -7,16 +7,12 @@ CATEGORIES= x11-fonts
MAINTAINER= gnome@FreeBSD.org
COMMENT= Client-sided font API for X applications
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
-BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
XORG_CAT= lib
USE_XORG= xproto:both xrender
-MAN3= Xft.3
-
-NO_STAGE= yes
post-extract:
@${CP} ${FILESDIR}/xft-config.in \
${WRKSRC}/xft-config.in
@@ -27,6 +23,7 @@ post-patch:
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/xft-config \
- ${PREFIX}/bin/
+ ${STAGEDIR}${PREFIX}/bin/
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libXft.so.2
.include <bsd.port.mk>
diff --git a/x11-fonts/libXft/files/patch-src_xftglyphs.c b/x11-fonts/libXft/files/patch-src_xftglyphs.c
new file mode 100644
index 000000000000..0ce9c8c75683
--- /dev/null
+++ b/x11-fonts/libXft/files/patch-src_xftglyphs.c
@@ -0,0 +1,17 @@
+--- src/xftglyphs.c.orig 2012-06-02 18:36:35.000000000 +0200
++++ src/xftglyphs.c 2013-12-05 16:57:20.000000000 +0100
+@@ -21,10 +21,11 @@
+ */
+
+ #include "xftint.h"
+-#include <freetype/ftoutln.h>
+-#include <freetype/ftlcdfil.h>
+
+-#include <freetype/ftsynth.h>
++#include <ft2build.h>
++#include FT_OUTLINE_H
++#include FT_LCD_FILTER_H
++#include FT_SYNTHESIS_H
+
+ /*
+ * Validate the memory info for a font
diff --git a/x11-fonts/libXft/pkg-plist b/x11-fonts/libXft/pkg-plist
index 5cc50dcb281a..8f888b747cc4 100644
--- a/x11-fonts/libXft/pkg-plist
+++ b/x11-fonts/libXft/pkg-plist
@@ -6,4 +6,5 @@ lib/libXft.la
lib/libXft.so
lib/libXft.so.2
libdata/pkgconfig/xft.pc
+man/man3/Xft.3.gz
@dirrm include/X11/Xft