aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/libXft
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2013-03-20 05:49:00 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2013-03-20 05:49:00 +0000
commit939edcb67d1a6ab84c15a7f93ba8db7758d3d277 (patch)
tree3816304320ff81ca88af8e812a3583ef42400cb4 /x11-fonts/libXft
parent71f13d6ce0fd1fbc418218c7055533019e56b351 (diff)
downloadports-939edcb67d1a6ab84c15a7f93ba8db7758d3d277.tar.gz
ports-939edcb67d1a6ab84c15a7f93ba8db7758d3d277.zip
-Update to 2.3.1.
-Update the header. In this version has removed the xft-config, but I have brought it back to avoid require test in the pointyhat-exp/tinderbox to see if it will break old ports that needs xft-config. PR: ports/176801 Submitted by: Pierre Guinoiseau <pierre@guinoiseau.eu>
Notes
Notes: svn path=/head/; revision=314712
Diffstat (limited to 'x11-fonts/libXft')
-rw-r--r--x11-fonts/libXft/Makefile23
-rw-r--r--x11-fonts/libXft/distinfo4
-rw-r--r--x11-fonts/libXft/files/xft-config.in100
-rw-r--r--x11-fonts/libXft/pkg-plist6
4 files changed, 120 insertions, 13 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index 696f58073d65..1e96411ec3c5 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: Xft
-# Date created: 06 October 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+#Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libXft
-PORTVERSION= 2.1.14
+PORTVERSION= 2.3.1
CATEGORIES= x11-fonts
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A client-sided font API for X applications
+COMMENT= Client-sided font API for X applications
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
@@ -19,7 +15,18 @@ RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
XORG_CAT= lib
USE_XORG= xproto:both xrender
-MAN1= xft-config.1
MAN3= Xft.3
+post-extract:
+ @${CP} ${FILESDIR}/xft-config.in \
+ ${WRKSRC}/xft-config.in
+
+post-patch:
+ @${REINPLACE_CMD} -e '/ac_config_files/s|xft\.pc|xft\.pc xft-config|' \
+ ${WRKSRC}/configure
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/xft-config \
+ ${PREFIX}/bin/
+
.include <bsd.port.mk>
diff --git a/x11-fonts/libXft/distinfo b/x11-fonts/libXft/distinfo
index 32ad2993614e..1d172ee05749 100644
--- a/x11-fonts/libXft/distinfo
+++ b/x11-fonts/libXft/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xorg/lib/libXft-2.1.14.tar.bz2) = 700e9d594b81cad3dfd5fac4a5cfd0c4cf7780c812507ef04eb40139ebf5175e
-SIZE (xorg/lib/libXft-2.1.14.tar.bz2) = 289068
+SHA256 (xorg/lib/libXft-2.3.1.tar.bz2) = 7fce32b92dcb7b2869bed567af2abc7bbad0d5d6fcf471b8a3e137964a31bbbd
+SIZE (xorg/lib/libXft-2.3.1.tar.bz2) = 311556
diff --git a/x11-fonts/libXft/files/xft-config.in b/x11-fonts/libXft/files/xft-config.in
new file mode 100644
index 000000000000..549b73ae0d9c
--- /dev/null
+++ b/x11-fonts/libXft/files/xft-config.in
@@ -0,0 +1,100 @@
+#! /bin/sh
+
+prefix="@prefix@"
+exec_prefix="@exec_prefix@"
+libdir="@libdir@"
+includedir="@includedir@"
+version="@VERSION@"
+freetypelibs="@FREETYPE_LIBS@"
+freetypecflags="@FREETYPE_CFLAGS@"
+fontconfiglibs="@FONTCONFIG_LIBS@"
+fontconfigcflags="@FONTCONFIG_CFLAGS@"
+xrenderlibs="@XRENDER_LIBS@"
+xrendercflags="@XRENDER_CFLAGS@"
+
+usage()
+{
+ cat <<EOF
+Usage: xft-config [OPTIONS] [LIBRARIES]
+Options:
+ [--prefix[=DIR]]
+ [--exec-prefix[=DIR]]
+ [--version]
+ [--libs]
+ [--cflags]
+EOF
+ exit $1
+}
+
+if test $# -eq 0 ; then
+ usage 1 1>&2
+fi
+
+while test $# -gt 0 ; do
+ case "$1" in
+ -*=*) optarg=`echo "$1" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
+ *) optarg= ;;
+ esac
+
+ case $1 in
+ --prefix=*)
+ prefix=$optarg
+ local_prefix=yes
+ ;;
+ --prefix)
+ echo_prefix=yes
+ ;;
+ --exec-prefix=*)
+ exec_prefix=$optarg
+ exec_prefix_set=yes
+ local_prefix=yes
+ ;;
+ --exec-prefix)
+ echo_exec_prefix=yes
+ ;;
+ --version)
+ echo $version
+ exit 0
+ ;;
+ --cflags)
+ echo_cflags=yes
+ ;;
+ --libs)
+ echo_libs=yes
+ ;;
+ *)
+ usage 1 1>&2
+ ;;
+ esac
+ shift
+done
+
+if test "$local_prefix" = "yes" ; then
+ if test "$exec_prefix_set" != "yes" ; then
+ exec_prefix=$prefix
+ fi
+fi
+
+if test "$echo_prefix" = "yes" ; then
+ echo $prefix
+fi
+
+if test "$echo_exec_prefix" = "yes" ; then
+ echo $exec_prefix
+fi
+
+if test "$echo_cflags" = "yes" ; then
+ cflags="-I${includedir} ${freetypecflags} ${fontconfigcflags} ${xrendercflags}"
+ echo $cflags
+fi
+
+if test "$echo_libs" = "yes" ; then
+ libs="-lXft -lX11 ${freetypelibs} ${fontconfiglibs} ${xrenderlibs}"
+ if test "${libdir}" != "/usr/lib" ; then
+ echo -L${libdir} $libs
+ else
+ echo $libs
+ fi
+fi
+
+# EOF
diff --git a/x11-fonts/libXft/pkg-plist b/x11-fonts/libXft/pkg-plist
index f8ec4c5ac63c..5cc50dcb281a 100644
--- a/x11-fonts/libXft/pkg-plist
+++ b/x11-fonts/libXft/pkg-plist
@@ -1,9 +1,9 @@
bin/xft-config
include/X11/Xft/Xft.h
include/X11/Xft/XftCompat.h
-lib/libXft.so.2
-lib/libXft.so
-lib/libXft.la
lib/libXft.a
+lib/libXft.la
+lib/libXft.so
+lib/libXft.so.2
libdata/pkgconfig/xft.pc
@dirrm include/X11/Xft